Learn about Centmin Mod LEMP Stack today
Register Now

Recommend Server Specs Calculator

Discussion in 'Virtual Private Server (VPS) hosting' started by eva2000, Oct 30, 2023.

  1. eva2000

    eva2000 Administrator Staff Member

    51,725
    11,944
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,436
    Local Time:
    8:06 PM
    Nginx 1.25.x
    MariaDB 10.x
    For app specific issues probably best to post a thread at https://community.centminmod.com/forums/other-web-apps-usage.36/. The recommended server specs aren't 100% indicative or your web app usage requirements - that would require more in-depth analysis that the recommended server specs page wouldn't be equipped to do.

    That's not how CPU steal is read - higher CPU steal percentages are bad it means other VPS neighbours are using more CPU resources which web host has configured to be shared with all VPS servers on the VPS host node. Usually, VPS like KVM VPS can be configured by a web host with either shared or dedicated CPU resources, or they segregate their VPS plans to shared or dedicated CPU-based VPS servers.


    So if your usage goes from 32.65% CPU steal to 0%, that is a good thing mean no CPU hogging neighbours taking away your CPU resources = better C[I performance for your VPS. Though your 7-day peak CPU steal at 25% is higher than the recommended 10% max. Meaning your VPS didn't have enough CPU resources as they were stolen/shared by other VPS servers. Hetzner has both shared and dedicated CPU based VPS servers where dedicated CPU based VPS servers guarantee more CPU allocation compared to shared VPS - at a higher price though.
     
  2. MaximilianKohler

    MaximilianKohler Member

    152
    1
    18
    Jun 23, 2023
    Ratings:
    +15
    Local Time:
    3:06 AM
    I was just about to post an update in the listmonk thread because I opened up Putty and it showed low CPU usage, but the listmonk UI was still not loading:
    Code:
    ============================================
     - CPU usage.....: 0.00, 0.01, 0.05 (1, 5, 15 min)
     - Processes.....: 119 running
     - System uptime.: 32 days 22 hours 30 minutes 8 seconds
    ============================================
                  total        used        free      shared  buff/cache   available
    Mem:           1789         620         405         275         763         664
    Swap:          1023          77         946
    ============================================
    
    But then I went and refreshed my Xenforo forum and admin page, and it was slow too. So it definitely seems to be a server problem. Forum traffic hasn't spiked. I restarted the server since it was 33 days uptime. Maybe that helped temporarily, but I tried again later and it still happened (listmonk UI very slow).

    EDIT: I contacted Hetzner support to see what they say.
     
    Last edited: Jan 17, 2024
  3. MaximilianKohler

    MaximilianKohler Member

    152
    1
    18
    Jun 23, 2023
    Ratings:
    +15
    Local Time:
    3:06 AM
    I looked at the Hetzner stats https://catbox.moe/c/zl5osl and they seem to agree that my usage is very low with rare spikes. Those screenshots are 24 hours and 1 week. It looks like there may have been an outage on the 16th.

    Updates here on further troubleshooting.