Want more timely Centmin Mod News Updates?
Become a Member

Processing Dependency: libwebp.so.4()(64bit) for package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.x

Discussion in 'System Administration' started by rdan, Apr 23, 2015.

  1. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    post contents of your /etc/yum.repos.d/epel.repo
     
  2. rdan

    rdan Well-Known Member

    4,523
    1,084
    113
    May 25, 2014
    Ratings:
    +1,582
    Local Time:
    11:25 PM
    Mainline
    10.2
  3. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    I think problem is with remi repo itself
    • CentOS 6 remi repo has only libwebp 0.3.1-2 version
    • CentOS 7 remi repo has libwebp 0.4.3-3 version
    however, ImageMagick-last-libs-6.9.1.2-1.el6.remi in CentOS 6 requires libwebp 0.4.3-3 version !

    Code:
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.1.2-1.el6.remi.1 for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
    --> Processing Dependency: libfftw3.so.3()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
    --> Processing Dependency: libMagickWand-6.Q16.so.2()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
    --> Processing Dependency: libMagickCore-6.Q16.so.2()(64bit) for package: ImageMagick-last-6.9.1.2-1.el6.remi.1.x86_64
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
    ---> Package ImageMagick-last-c++-devel.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
    ---> Package ImageMagick-last-devel.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
    --> Running transaction check
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.1.2-1.el6.remi.1 will be installed
    --> Processing Dependency: libwebp.so.5()(64bit) for package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.1.x86_64
    ---> Package fftw.x86_64 0:3.2.1-3.1.el6 will be installed
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.1.x86_64 (remi)
               Requires: libwebp.so.5()(64bit)
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    probable workaround is to force epel repo's 0.4.3-3 version install only on CentOS 6..

    Code:
    yum install libwebp libwebp-devel --disableexcludes=epel --skip-broken
    will see what I can do
     
    Last edited: Apr 29, 2015
    • Like Like x 1
  4. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    • Like Like x 1
  5. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  6. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    hmmm re-reading your original error it's not due to what we thought it was, it's due to epel repo not being able to find your libweb pacakge... so could of been a problem specific to your epel repo mirror package availability only
    Code:
    Error: Package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.x86_64 (@remi)
               Requires: libwebp.so.4()(64bit)
               Removing: libwebp-0.3.1-2.el6.remi.x86_64 (@remi)
                   libwebp.so.4()(64bit)
               Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
                   Not found
     
  7. rdan

    rdan Well-Known Member

    4,523
    1,084
    113
    May 25, 2014
    Ratings:
    +1,582
    Local Time:
    11:25 PM
    Mainline
    10.2
    Same error happen on New Linode I installed also.
    Not just from my SYS server.
     
  8. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  9. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what do you get for output for
    Code:
    yum list libwebp libwebp-devel --disableplugin=priorities --enablerepo=remi
     
  10. rdan

    rdan Well-Known Member

    4,523
    1,084
    113
    May 25, 2014
    Ratings:
    +1,582
    Local Time:
    11:25 PM
    Mainline
    10.2
    No, last encounter it yesterday.
     
  11. rdan

    rdan Well-Known Member

    4,523
    1,084
    113
    May 25, 2014
    Ratings:
    +1,582
    Local Time:
    11:25 PM
    Mainline
    10.2
     
  12. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    okay, then latest .08 beta 02 should fix it ;)
     
  13. eva2000

    eva2000 Administrator Staff Member

    39,777
    8,774
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,505
    Local Time:
    1:25 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    found problem it's epel's steadfast mirror centos 6.5 directory is empty Steadfast Mirror - Index of /centos/6.5/

    they left a readme file in 6.5
    6.6 is fine Steadfast Mirror - Index of /centos/6.6/

    edit: sorry that is CentOS not epel repo

    check epel mirror for steadfast and my aussie mirror for centos 6 el6
    Code:
    lynx -dump -listonly http://mirror.overthewire.com.au/epel/6/x86_64/ | grep libwebp
    4915. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-0.4.3-3.el6.i686.rpm
    4916. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-0.4.3-3.el6.x86_64.rpm
    4917. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-devel-0.4.3-3.el6.i686.rpm
    4918. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-devel-0.4.3-3.el6.x86_64.rpm
    4919. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-java-0.4.3-3.el6.x86_64.rpm
    4920. http://mirror.overthewire.com.au/epel/6/x86_64/libwebp-tools-0.4.3-3.el6.x86_64.rpm
    Code:
    lynx -dump -listonly http://mirror.steadfast.net/epel/6/x86_64/ | grep libwebp                                              
    4930. http://mirror.steadfast.net/epel/6/x86_64/libwebp-0.4.3-3.el6.i686.rpm
    4931. http://mirror.steadfast.net/epel/6/x86_64/libwebp-0.4.3-3.el6.x86_64.rpm
    4932. http://mirror.steadfast.net/epel/6/x86_64/libwebp-devel-0.4.3-3.el6.i686.rpm
    4933. http://mirror.steadfast.net/epel/6/x86_64/libwebp-devel-0.4.3-3.el6.x86_64.rpm
    4934. http://mirror.steadfast.net/epel/6/x86_64/libwebp-java-0.4.3-3.el6.x86_64.rpm
    4935. http://mirror.steadfast.net/epel/6/x86_64/libwebp-tools-0.4.3-3.el6.x86_64.rpm
    both exist so probably just your unique issue at the time
     
    Last edited: Apr 29, 2015
    • Like Like x 1
..