Learn about Centmin Mod LEMP Stack today
Register Now

Processing Dependency: libwebp.so.4()(64bit) for package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.x

Discussion in 'System Administration' started by rdan, Apr 23, 2015.

  1. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    I have this yum update problem.
    Code:
    # yum update
    Loaded plugins: downloadonly, fastestmirror, priorities, security
    Setting up Update Process
    Loading mirror speeds from cached hostfile
    * base: centos.mirror.netelligent.ca
    * epel: mirror.steadfast.net
    * extras: mirror.gpmidi.net
    * rpmforge: mirror.us.leaseweb.net
    * updates: centos.mirror.netelligent.ca
    1640 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package libwebp.x86_64 0:0.3.1-2.el6.remi will be updated
    --> Processing Dependency: libwebp.so.4()(64bit) for package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.x86_64
    ---> Package libwebp.x86_64 0:0.4.3-3.el6 will be an update
    ---> Package libwebp-devel.x86_64 0:0.3.1-2.el6.remi will be updated
    ---> Package libwebp-devel.x86_64 0:0.4.3-3.el6 will be an update
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-libs-6.9.1.2-1.el6.remi.x86_64 (@remi)
               Requires: libwebp.so.4()(64bit)
               Removing: libwebp-0.3.1-2.el6.remi.x86_64 (@remi)
                   libwebp.so.4()(64bit)
               Updated By: libwebp-0.4.3-3.el6.x86_64 (epel)
                   Not found
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    

     
  2. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    Any advice to solve this? :/
     
  3. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    conflicting remi and epel yum repo's libwebp* package versions

    Code:
    yum list libwebp* --enablerepo=remi -q
    Installed Packages
    libwebp.x86_64                                                           0.3.1-2.el6.remi                                                     @remi
    libwebp-devel.x86_64                                                     0.3.1-2.el6.remi                                                     @remi
    Available Packages
    libwebp.x86_64                                                           0.4.3-3.el6                                                          epel
    libwebp-devel.x86_64                                                     0.4.3-3.el6                                                          epel
    libwebp-java.x86_64                                                      0.4.3-3.el6                                                          epel
    libwebp-tools.x86_64                                                     0.4.3-3.el6                                                          epel 
    probably best to exclude libwebp* from epel updates via exclude= in epel.repo

    /etc/yum.repos.d/epel.repo
    Code:
    [epel]
    name=Extra Packages for Enterprise Linux 6 - $basearch
    #baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-6&arch=$basearch
    failovermethod=priority
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
    priority=3
    exclude=varnish clamd clamav clamav-db libwebp*
    
    [epel-debuginfo]
    name=Extra Packages for Enterprise Linux 6 - $basearch - Debug
    #baseurl=http://download.fedoraproject.org/pub/epel/6/$basearch/debug
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-debug-6&arch=$basearch
    failovermethod=priority
    enabled=0
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
    gpgcheck=1
    
    [epel-source]
    name=Extra Packages for Enterprise Linux 6 - $basearch - Source
    #baseurl=http://download.fedoraproject.org/pub/epel/6/SRPMS
    mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-source-6&arch=$basearch
    failovermethod=priority
    enabled=0
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-6
    gpgcheck=1
    or manually exclude it from update
    Code:
    yum -y update --exclude=libwebp* 
     
    • Like Like x 1
  4. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    Oh that is the only workaround :D

    My bad, I did some search and trying to fix it myself yesterday and installed a lot that I think not needed :/.
    Here' my install log:
    Code:
    yum install -y --enablerepo=remi ImageMagick-last-c++-devel
    yum install libwebp.so.4
    yum install libwebp
    
    yum install libtool-ltdl-devel fftw3-devel djvulibre-devel OpenEXR-devel llibwebp4
    
    yum install ImageMagick-last ImageMagick-last-devel --enablerepo=remi
    yum install ImageMagick ImageMagick-devel ImageMagick-last ImageMagick-last-c++ ImageMagick-last-c++-devel ImageMagick-last-devel  ImageMagick-last-libs  libwebp libwebp-devel --enablerepo=remi
    yum install ImageMagick ImageMagick-devel ImageMagick-last ImageMagick-last-c++ ImageMagick-last-c++-devel ImageMagick-last-devel  ImageMagick-last-libs  libwebp libwebp-devel --enablerepo=remi --skip-broken
    yum install libwebp.x86_64 --enablerepo=remi
    yum install libwebp-0.4.3-3.el6.x86_64 --enablerepo=remi
    yum install libwebp-0.4.3-3.el6.x86_64 --enablerepo=remi --skip-broken
    
    I maybe messed some things :D
    I would like to remove all Imagick related software and re-install it again cleanly.
    How can I do that?
    Hopefully possible.
     
  5. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    yum remove packagesyourwanttoremove
     
  6. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    After following this again:
    Can't install back from Remi repo :/
     
  7. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    This solution will have an issue for first time install.
    Issue on post #6.
     
  8. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  9. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
  10. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    then try installing libwebp first

    Code:
    yum -y install libwebp libwebp-devel --enablerepo=remi
    yum -y install ImageMagick-last ImageMagick-last-devel ImageMagick-last-c++ ImageMagick-last-c++-devel --enablerepo=remi --disableplugin=priorities
     
    • Like Like x 1
  11. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    I think this is not the solution.
    I built a fresh centminmod based server, and PHP has warning with imagick because of this.
     
  12. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    specific error messages ? you did only add excludes to epel.repo and not yum.conf ?
     
  13. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    No, I didn't do anything.
    I mean new install of CentminMod.
     
  14. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what OS ? I just tried CentOS 7 + centmin mod .08 beta 02 fresh install and no PHP-FPM errors
     
  15. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    CentOS 6.5 64 Bit on Linode.
     
  16. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    where are you seeing the PHP warning ?
     
  17. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    During fpmrestart
     
  18. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    centminmod post install does service php-fpm restart also, and that notice already displayed.
     
  19. eva2000

    eva2000 Administrator Staff Member

    35,033
    7,733
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,926
    Local Time:
    1:02 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Strange i don't get that on fresh .08 beta 02 install on CentOS 7.1. Doing test install on CentOS 6.6 now to see

    can you post the exact warning error you got
     
  20. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    11:02 AM
    Mainline
    10.2
    Same as above error.
     
..