Welcome to Centmin Mod Community
Register Now

[Solved] Enable ipv6 error

Discussion in 'Bug Reports' started by pamamolf, Dec 5, 2019.

  1. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Checking the logs installation of Postfix was ok:
    Code:
    Loaded plugins: fastestmirror, versionlock
    Loading mirror speeds from cached hostfile
     * base: centosmirror.netcup.net
     * centos-sclo-rh: mirror.ratiokontakt.de
     * centos-sclo-sclo: centosmirror.netcup.net
     * extras: centosmirror.netcup.net
     * updates: mirror.plustech.de
    Resolving Dependencies
    --> Running transaction check
    ---> Package postfix.x86_64 2:2.10.1-7.el7 will be installed
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ================================================================================
     Package          Arch            Version                   Repository     Size
    ================================================================================
    Installing:
     postfix          x86_64          2:2.10.1-7.el7            base          2.4 M
    
    Transaction Summary
    ================================================================================
    Install  1 Package
    
    Total download size: 2.4 M
    Installed size: 12 M
    Downloading packages:
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Installing : 2:postfix-2.10.1-7.el7.x86_64                                1/1
      Verifying  : 2:postfix-2.10.1-7.el7.x86_64                                1/1
    
    Installed:
      postfix.x86_64 2:2.10.1-7.el7                                               
    
    Complete!
    Next reference:
    Code:
    smtp_tls_CAfile =
    smtp_tls_security_level =
    smtp_tls_loglevel = 0
    smtp_tls_session_cache_database =
    Redirecting to /bin/systemctl reload postfix.service
    Job for postfix.service invalid.
    smtp_tls_CAfile = /etc/pki/tls/certs/ca-bundle.crt
    smtp_tls_security_level = may
    smtp_tls_loglevel = 1
    smtp_tls_session_cache_database = btree:/var/lib/postfix/smtp_scache
    inet_protocols = all
    inet_protocols = ipv4
    1024000000
    *************************************************
    [1;32;40mPostfix already detected, postfix install aborted
    (B[m*************************************************
    Job for postfix.service invalid.

    Don't know if that helps....

    So the issues are:

    1)When a user install Centminmod using DISABLE_IPVSIX='y' Postfix is not working/starting:
    Code:
    Dec 07 23:07:06 server.mydomain.com systemd[1]: Unit postfix.service cannot be reloaded because it is inactive.
    2)When a user install GlusterFS:
    Code:
    yum install centos-release-gluster
    yum install glusterfs-server --disableplugin=priorities -q
    and a user uses DISABLE_IPVSIX='y' then the Rpcbind service will not start and will never start automatically at server reboot.
     
  2. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  3. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Hope that the fix will take care existing installations that was used DISABLE_IPVSIX='y' too :)

    Is your fix also related to the issue on clean install at my post #21:

    https://community.centminmod.com/threads/enable-ipv6-error.18792/page-2#post-79984

    ?
     
    Last edited: Dec 8, 2019
  4. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  5. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Just test it and it doesn't work as expected.

    I had DISABLE_IPVSIX='y' and i checked both services and was running with no issues.

    Then i restart the server and postfix was ok. Didn't check rpcbind.

    after that i did a test to change it to DISABLE_IPVSIX='n' and run centminmod

    That killed postfix without even restarting the server:
    Code:
    systemctl status postfix
    ● postfix.service - Postfix Mail Transport Agent
       Loaded: loaded (/usr/lib/systemd/system/postfix.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Sat 2019-12-07 23:57:35 UTC; 4min 13s ago
     Main PID: 1507 (code=killed, signal=TERM)
    
    Dec 07 23:57:33 haproxy systemd[1]: Unit postfix.service entered failed state.
    Dec 07 23:57:33 haproxy systemd[1]: postfix.service failed.
    Dec 07 23:57:33 haproxy systemd[1]: Starting Postfix Mail Transport Agent...
    Dec 07 23:57:33 haproxy aliasesdb[2296]: /usr/sbin/postconf: fatal: parameter inet_interfaces: no local interface found for ::1
    Dec 07 23:57:34 haproxy aliasesdb[2296]: newaliases: fatal: parameter inet_interfaces: no local interface found for ::1
    Dec 07 23:57:34 haproxy postfix[2302]: fatal: parameter inet_interfaces: no local interface found for ::1
    Dec 07 23:57:35 haproxy systemd[1]: postfix.service: control process exited, code=exited status=1
    Dec 07 23:57:35 haproxy systemd[1]: Failed to start Postfix Mail Transport Agent.
    Dec 07 23:57:35 haproxy systemd[1]: Unit postfix.service entered failed state.
    Dec 07 23:57:35 haproxy systemd[1]: postfix.service failed.
    Can you please re check my server or the code in the fix?

    The fix may need some tweaking...?
     
  6. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    your persistent config file still had DISABLE_IPVSIX='n', when i changed to DISABLE_IPVSIX='y' and ran centmin.sh, it worked and postfix is running and restarting rpcbind.socket works too
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Yes both services worked and after reboot i check Postfix and was working great. Didn't check rpcbind but probably was ok too.

    Then i changed it to from DISABLE_IPVSIX='y' as you left it to DISABLE_IPVSIX='n' and i run Centminmod and then i check the status of Postfix and was not working...

    Changing from DISABLE_IPVSIX='y' to DISABLE_IPVSIX='n' and the opposite should keep postfix/rpcbind running and should be running also after reboots.
     
  8. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Your fix from DISABLE_IPVSIX='n' to DISABLE_IPVSIX='y' was ok as you tested !

    But my test after from DISABLE_IPVSIX='y' to DISABLE_IPVSIX='n' was not ok :)

    Maybe some adjustments needed for the opposite way?
     
    Last edited: Dec 8, 2019
  9. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    ok updated 123.09beta01 with an additional fix for this :)
     
  10. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Checking... :)
     
  11. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Without touching anything i check postfix and was running but rpcbind not.

    Then i reboot the server and both was working.

    Then without adjusting anything i run centminmod and i check again.

    Postfix was ok and rpcbind not :(

    It killed rpcbind...

    Then i tried to use from DISABLE_IPVSIX='n' (as you left it) the DISABLE_IPVSIX='y' and run centminmod.

    Postfix running great. Rpcbind still not working...

    Then i reboot to check also this one:

    Postfix running great. Rpcbind not.

    Then i tried to enable rpcbind manually using:
    Code:
    systemctl enable rpcbind.socket
    systemctl restart rpcbind.socket
    systemctl start rpcbind.service
    Rpcbind was working again. Then i reboot.

    Postfix working great. Rpcbind not.

    Then i tried to revert again from DISABLE_IPVSIX='y' to DISABLE_IPVSIX='n' and run centminmod

    Postfix working again. Rpcbind not so i started manually again and reboot.
    Code:
    systemctl enable rpcbind.socket
    systemctl restart rpcbind.socket
    systemctl start rpcbind.service
    Postfix working again. Rpcbind working also !!!

    Then without adjusting anything i run centminmod and it killed rpcbind :(

    So it seems for me that Postfix is working now no matter what setting i have and no matter if i change it back or forward !!!! Perfect.

    Rpcbind seems to work only when i use DISABLE_IPVSIX='n' and restart the server but it gets killed when i run centminmod...

    Can you please re check?

    Some tweaking for rpcbind please :)
     
    Last edited: Dec 8, 2019
  12. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Ah i believe I see the problem, I am only dealing with rpcbind.socket not rpcbind.service in my check/restarts. Next 123.09beta01 update I just did should fix this now.
     
  13. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    checking again... :)
     
  14. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Using DISABLE_IPVSIX='n'

    Now rpcbind is no get killed by running centminmod !!!
    After reboots is ok also

    changing to DISABLE_IPVSIX='y'

    Rpcbind is ok and running centminmod is not killing it !!!

    After reboot rpcbind not working :(

    We are very close :)
     
  15. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    looks like can't automate every combination of rpcbind state as centmin mod centmin.sh run will only restart rpcbind if rpcbind is active and running. If rpcbind is not active and not running, centmin.sh won't restart it. This is for the situation where you manual disable/stop rpcbind and don't want it to be restarted automatically.

    But I guess if you have rpcbind installed yourself you want it running, so I will change it to restart rpcbind regardless if rpcbind is active or not. And leave it to folks if they don't want rpcbind running, they will manually remove the rpcbind yum package themselves.
     
  16. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    I got rpcbind as a dependency from GlusterFS and if rpcbind stop running then nothing works...

    That fix will help for sure but my issue was when i used DISABLE_IPVSIX='y' after reboot rpcbind was not started ...

    From running state using DISABLE_IPVSIX='y' after reboot was not working...

    Don't know if it will fix that also....
     
    Last edited: Dec 8, 2019
  17. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    it should now as i set it to restart rpcbind regardless if it was active or not now
     
  18. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    checking... :)
     
  19. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    9:22 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    All working great now !

    Now i am checking a clean install as Postfix was failing before.... :)
     
  20. eva2000

    eva2000 Administrator Staff Member

    44,742
    10,200
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,809
    Local Time:
    4:22 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Good to hear :D