Welcome to Centmin Mod Community
Become a Member

PHP-FPM Zend Opcache opcache.enable_file_override

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by Kintaro, Jan 24, 2023.

  1. Kintaro

    Kintaro Member

    92
    9
    8
    Dec 2, 2016
    Italy
    Ratings:
    +26
    Local Time:
    11:55 PM
    1.15.x
    MariaDB 10
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: i.e. 123.08stable
    • Nginx Version Installed: i.e. 1.17.1
    • PHP Version Installed: 7.2.34
    • MariaDB MySQL Version Installed: 10.1.48
    • When was last time updated Centmin Mod code base ? : 1 day ago
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      cat /etc/centminmod/custom_config.inc
      CLANG='n'
      DEVTOOLSETSEVEN='y'
      NGINX_DEVTOOLSETGCC='y'
      CLOUDFLARE_ZLIB='y'
      MARCH_TARGETNATIVE='n'
      LIBRESSL_SWITCH='n'
      LETSENCRYPT_DETECT='y'
      ENABLE_MARIADBTENTWOUPGRADE='y'
      PHPFINFO='y'
      
    I notice many warning like:
    Code (Text):
    [23-Jan-2023 18:20:11] PHP Warning:  filemtime(): stat failed for /home/nginx/domains/domain.com/public/cache/smarty/compile/40/3f/03/403f032d3ac9c19f4d09a48a66b32de17503343c_0.file.layout.tpl.php in /home/nginx/domains/domain.com/public/vendor/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php on line 148
    [23-Jan-2023 18:20:11] PHP Warning:  touch(): Unable to create file /home/nginx/domains/domain.com/public/cache/smarty/compile/40/3f/03/403f032d3ac9c19f4d09a48a66b32de17503343c_0.file.layout.tpl.php because No such file or directory in /home/nginx/domains/domain.com/public/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php on line 178
    


    Code (Text):
    php --ri 'Zend Opcache'
    PHP Warning:  PHP Startup: Unable to load dynamic library 'redis.so' (tried: /usr/local/lib/php/extensions/no-debug-non-zts-20170718/redis.so (/usr/local/lib/php/extensions/no-debug-non-zts-20170718/redis.so: cannot open shared object file: No such file or directory), /usr/local/lib/php/extensions/no-debug-non-zts-20170718/redis.so.so (/usr/local/lib/php/extensions/no-debug-non-zts-20170718/redis.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
    
    Zend OPcache
    
    Opcode Caching => Disabled
    Optimization => Disabled
    SHM Cache => Enabled
    File Cache => Disabled
    Startup Failed => Opcode Caching is disabled for CLI
    
    Directive => Local Value => Master Value
    opcache.enable => On => On
    opcache.use_cwd => On => On
    opcache.validate_timestamps => On => On
    opcache.validate_permission => Off => Off
    opcache.validate_root => Off => Off
    opcache.inherited_hack => On => On
    opcache.dups_fix => Off => Off
    opcache.revalidate_path => Off => Off
    opcache.log_verbosity_level => 1 => 1
    opcache.memory_consumption => 144 => 144
    opcache.interned_strings_buffer => 8 => 8
    opcache.max_accelerated_files => 65407 => 65407
    opcache.max_wasted_percentage => 5 => 5
    opcache.consistency_checks => 0 => 0
    opcache.force_restart_timeout => 180 => 180
    opcache.revalidate_freq => 180 => 180
    opcache.file_update_protection => 2 => 2
    opcache.preferred_memory_model => no value => no value
    opcache.blacklist_filename => no value => no value
    opcache.max_file_size => 0 => 0
    opcache.protect_memory => 0 => 0
    opcache.save_comments => 1 => 1
    opcache.optimization_level => 0x7FFFBFFF => 0x7FFFBFFF
    opcache.opt_debug_level => 0 => 0
    opcache.enable_file_override => On => On
    opcache.enable_cli => Off => Off
    opcache.error_log => no value => no value
    opcache.restrict_api => no value => no value
    opcache.lockfile_path => /tmp => /tmp
    opcache.file_cache => no value => no value
    opcache.file_cache_only => 0 => 0
    opcache.file_cache_consistency_checks => 1 => 1
    opcache.huge_code_pages => Off => Off



    I found this:
    filemtime(): stat failed for warnings · Issue #510 · smarty-php/smarty

    Do you think I have to disable "opcache.enable_file_override"? or simply ignore those warnings?
     
  2. eva2000

    eva2000 Administrator Staff Member

    49,762
    11,447
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,789
    Local Time:
    8:55 AM
    Nginx 1.21.x
    MariaDB 10.x
    are the file and directory permissions for all directories listed in this path correct for
    Code (Text):
    /home/nginx/domains/domain.com/public/vendor/smarty/smarty/libs/sysplugins/smarty_template_compiled.php