Join the community today
Become a Member

YUM update not possible?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by hkim, Apr 17, 2019 at 8:25 AM.

  1. hkim

    hkim New Member

    24
    2
    3
    Feb 14, 2019
    Ratings:
    +3
    Local Time:
    6:22 PM
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.12
    • PHP Version Installed: 7.3.2
    • MariaDB MySQL Version Installed: 10.2.22
    • When was last time updated Centmin Mod code base ? : today
    • Persistent Config: No
    After the latest update I constantly get this message:

    ------------------------------------------------------------
    New YUM Updates available for host centhost.psykolog.nu
    -------------------------------------------------------------
    To list available YUM Updates type:
    -------------------------------------------------------------
    yum list updates --disableplugin=priorities,versionlock --setopt=deltarpm=0 --enablerepo=remi
    -------------------------------------------------------------
    Following Updates are available:
    -------------------------------------------------------------
    python2-pip.noarch 8.1.2-8.el7 epel

    -------------------------------------------------------------
    To update type these commands:
    -------------------------------------------------------------
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi

    The first yum command works, but not the second one (yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi). Entering this, renders this error message:

    [22:22][[email protected] ~]# yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi
    Loaded plugins: versionlock
    Excluding 1 update due to versionlock (use "yum versionlock status" to show it)
    No packages marked for update


    How can I remedy this error message?
     
  2. eva2000

    eva2000 Administrator Staff Member

    39,155
    8,647
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,296
    Local Time:
    2:22 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    That is normal python2-pip is now version locked in favour of using pip installed pip. So it's excluded from yum updates to prevent conflict with pip install/updated version.
     
    • Like Like x 1
..