Join the community today
Register Now

yum update need help

Discussion in 'Install & Upgrades or Pre-Install Questions' started by xenbiarritz, May 1, 2019.

  1. xenbiarritz

    xenbiarritz Member

    34
    3
    8
    May 7, 2017
    Ratings:
    +3
    Local Time:
    2:52 PM
    hi
    after upgrading centminmod,

    i run a yum update

    Code:
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi --exclude=python34-*,python35-*,python36-*
    
    and it return
    Code:
    Error: Package: cmake3-data-3.13.4-2.el7.noarch (epel)
               Requires: /usr/bin/python3.6
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    what should i do?
    thank you for your help
     
  2. eva2000

    eva2000 Administrator Staff Member

    40,190
    8,888
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,698
    Local Time:
    10:52 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    you can switch from IUS Community python packages o EPEL versions. I wrote a quick script to fix this which is added to all new 123.09beta01's addons/python34_install.sh routines but if your system is older you wouldn't have ran the script with the fix

    you can do that via SSH command which runs the code displayed at fix python34/python34u and python36/python36u conflicts on centos 7 in centminmod 123.09beta01
    Code (Text):
    curl -4s https://gist.github.com/centminmod/e050cf02794fb5bcdf3090c28efab202/raw/python-conflict-fix.sh | bash


    then yum update should be fine
     
  3. xenbiarritz

    xenbiarritz Member

    34
    3
    8
    May 7, 2017
    Ratings:
    +3
    Local Time:
    2:52 PM
    thank you for quick replay

    i am on 123.09beta01
    i run
    Code:
    curl -4s https://gist.github.com/centminmod/e050cf02794fb5bcdf3090c28efab202/raw/python-conflict-fix.sh | bash
    then yum update
    Code:
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi --exclude=python34-*,python35-*,python36-*
    and it still return
    Code:
    Error: Package: cmake3-data-3.13.4-2.el7.noarch (epel)
               Requires: /usr/bin/python3.6
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
     
  4. eva2000

    eva2000 Administrator Staff Member

    40,190
    8,888
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,698
    Local Time:
    10:52 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    after the fix the exclude python lines won't show on centmin.sh menu option 24 exits so yum update command would be
    Code (Text):
    yum update --disableplugin=priorities --setopt=deltarpm=0 --enablerepo=remi
    
     
  5. xenbiarritz

    xenbiarritz Member

    34
    3
    8
    May 7, 2017
    Ratings:
    +3
    Local Time:
    2:52 PM
    it workes
    next time, should i exclude python lines?

    thank you
     
  6. eva2000

    eva2000 Administrator Staff Member

    40,190
    8,888
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,698
    Local Time:
    10:52 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Use the yum update line reported/displayed by centmin.sh menu option 24 exit at the time of a particular exit run as it changes depending on what is detected by your system. So if python34u packages are no more, it won't show those exclude lines on next time you do a centmin.sh menu option 24 exit
     
  7. xenbiarritz

    xenbiarritz Member

    34
    3
    8
    May 7, 2017
    Ratings:
    +3
    Local Time:
    2:52 PM
    thank you so much
     
..