Welcome to Centmin Mod Community
Register Now

Sysadmin yum update issue

Discussion in 'System Administration' started by hitman, Aug 24, 2016.

  1. hitman

    hitman Member

    121
    11
    18
    Jul 18, 2014
    Ratings:
    +15
    Local Time:
    4:56 AM
    hello while trying to update, i get this error
    any idea why?

    using beta09 command to update is
    yum update --enablerepo=remi --disableplugin=priorities
    Code:
    Loaded plugins: fastestmirror, security
    Setting up Update Process
    Determining fastest mirrors
    epel/metalink                                                                     |  21 kB     00:00
    * base: mirror.de.leaseweb.net
    * epel: mirror.imt-systems.com
    * extras: centos.intergenia.de
    * remi: mirror.23media.de
    * rpmforge: mirror.de.leaseweb.net
    * updates: ftp.plusline.de
    base                                                                              | 3.7 kB     00:00
    epel                                                                              | 4.3 kB     00:00
    epel/primary_db                                                                   | 5.0 MB     00:00
    extras                                                                            | 3.3 kB     00:00
    mariadb                                                                           | 2.9 kB     00:00
    remi                                                                              | 2.9 kB     00:00
    remi/primary_db                                                                   | 1.0 MB     00:00
    rpmforge                                                                          | 1.9 kB     00:00
    slc6-scl                                                                          | 2.6 kB     00:00
    updates                                                                           | 3.4 kB     00:00
    updates/primary_db                                                                | 2.0 MB     00:00
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last.i686 0:6.9.5.4-1.el6.remi will be updated
    ---> Package ImageMagick-last.i686 0:6.9.5.5-1.el6.remi will be an update
    ---> Package ImageMagick-last-c++.i686 0:6.9.5.4-1.el6.remi will be updated
    ---> Package ImageMagick-last-c++.i686 0:6.9.5.5-1.el6.remi will be an update
    ---> Package ImageMagick-last-c++-devel.i686 0:6.9.5.4-1.el6.remi will be updated
    ---> Package ImageMagick-last-c++-devel.i686 0:6.9.5.5-1.el6.remi will be an update
    ---> Package ImageMagick-last-devel.i686 0:6.9.5.4-1.el6.remi will be updated
    ---> Package ImageMagick-last-devel.i686 0:6.9.5.5-1.el6.remi will be an update
    ---> Package ImageMagick-last-libs.i686 0:6.9.5.4-1.el6.remi will be updated
    ---> Package ImageMagick-last-libs.i686 0:6.9.5.5-1.el6.remi will be an update
    ---> Package avahi-libs.i686 0:0.6.25-15.el6 will be updated
    ---> Package avahi-libs.i686 0:0.6.25-15.el6_8.1 will be an update
    ---> Package cronie.i686 0:1.4.4-15.el6_7.1 will be updated
    ---> Package cronie.i686 0:1.4.4-16.el6_8.2 will be an update
    ---> Package cronie-anacron.i686 0:1.4.4-15.el6_7.1 will be updated
    ---> Package cronie-anacron.i686 0:1.4.4-16.el6_8.2 will be an update
    ---> Package device-mapper.i686 0:1.02.117-7.el6 will be updated
    ---> Package device-mapper.i686 0:1.02.117-7.el6_8.1 will be an update
    ---> Package device-mapper-libs.i686 0:1.02.117-7.el6 will be updated
    ---> Package device-mapper-libs.i686 0:1.02.117-7.el6_8.1 will be an update
    ---> Package kernel.i686 0:2.6.32-642.4.2.el6 will be installed
    ---> Package kernel-devel.i686 0:2.6.32-642.4.2.el6 will be installed
    ---> Package kernel-firmware.noarch 0:2.6.32-642.3.1.el6 will be updated
    ---> Package kernel-firmware.noarch 0:2.6.32-642.4.2.el6 will be an update
    ---> Package kernel-headers.i686 0:2.6.32-642.3.1.el6 will be updated
    ---> Package kernel-headers.i686 0:2.6.32-642.4.2.el6 will be an update
    ---> Package libudev.i686 0:147-2.73.el6 will be updated
    ---> Package libudev.i686 0:147-2.73.el6_8.1 will be an update
    ---> Package net-snmp.i686 1:5.5-57.el6 will be updated
    ---> Package net-snmp.i686 1:5.5-57.el6_8.1 will be an update
    ---> Package net-snmp-devel.i686 1:5.5-57.el6 will be updated
    ---> Package net-snmp-devel.i686 1:5.5-57.el6_8.1 will be an update
    ---> Package net-snmp-libs.i686 1:5.5-57.el6 will be updated
    ---> Package net-snmp-libs.i686 1:5.5-57.el6_8.1 will be an update
    ---> Package net-snmp-utils.i686 1:5.5-57.el6 will be updated
    ---> Package net-snmp-utils.i686 1:5.5-57.el6_8.1 will be an update
    ---> Package nettle.i686 0:2.2-1.el6.rf will be updated
    --> Processing Dependency: libnettle.so.4 for package: aria2-1.16.4-1.el6.rf.i686
    ---> Package nettle.i686 0:3.2-2.el6 will be an update
    ---> Package python.i686 0:2.6.6-64.el6 will be updated
    ---> Package python.i686 0:2.6.6-66.el6_8 will be an update
    ---> Package python-libs.i686 0:2.6.6-64.el6 will be updated
    ---> Package python-libs.i686 0:2.6.6-66.el6_8 will be an update
    ---> Package python2-boto.noarch 0:2.40.0-1.el6 will be updated
    ---> Package python2-boto.noarch 0:2.41.0-1.el6 will be an update
    ---> Package udev.i686 0:147-2.73.el6 will be updated
    ---> Package udev.i686 0:147-2.73.el6_8.1 will be an update
    --> Finished Dependency Resolution
    Error: Package: aria2-1.16.4-1.el6.rf.i686 (@rpmforge)
               Requires: libnettle.so.4
               Removing: nettle-2.2-1.el6.rf.i686 (@rpmforge)
                   libnettle.so.4
               Updated By: nettle-3.2-2.el6.i686 (epel)
                   Not found
               Available: nettle-2.1-1.el6.rf.i686 (rpmforge)
                   libnettle.so.4
               Available: nettle-1.15-1.el6.rf.i686 (rpmforge)
                   Not found
    

     
  2. eva2000

    eva2000 Administrator Staff Member

    37,311
    8,153
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,549
    Local Time:
    12:56 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Code (Text):
    --> Finished Dependency Resolution
    Error: Package: aria2-1.16.4-1.el6.rf.i686 (@rpmforge)
               Requires: libnettle.so.4
               Removing: nettle-2.2-1.el6.rf.i686 (@rpmforge)
                   libnettle.so.4
               Updated By: nettle-3.2-2.el6.i686 (epel)
                   Not found
               Available: nettle-2.1-1.el6.rf.i686 (rpmforge)
                   libnettle.so.4
               Available: nettle-1.15-1.el6.rf.i686 (rpmforge)
                   Not found

    looks like epel repo poked it's head in on the update but doesn't have libnettle.so.4

    what's output for command
    Code (Text):
    yum -q provides */libnettle.so.4 --disableplugin=priorities


    for a workaround and one time only, just exclude epel repo on this update so yum update doesn't pick up nettle 3.2.2 from epel repo
    Code (Text):
    yum update --enablerepo=remi --disableplugin=priorities --disablerepo=epel
    
     
  3. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    4:56 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I have the same issue also :)

    That's my output:

    Code:
    [[email protected] ~]# yum -q provides */libnettle.so.4 --disableplugin=priorities
    nettle-2.2-1.el6.rf.x86_64 : Cryptographic library
    Repo        : rpmforge
    Matched from:
    Filename    : /usr/lib64/libnettle.so.4
    
    
    
    nettle-2.1-1.el6.rf.x86_64 : Cryptographic library
    Repo        : rpmforge
    Matched from:
    Filename    : /usr/lib64/libnettle.so.4
    
    
    
    nettle-2.2-1.el6.rf.x86_64 : Cryptographic library
    Repo        : installed
    Matched from:
    Filename    : /usr/lib64/libnettle.so.4
     
  4. eva2000

    eva2000 Administrator Staff Member

    37,311
    8,153
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,549
    Local Time:
    12:56 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    same work around in post i made previously

    or just remove aria2 as it's not currently actively used by centmin mod, it was added to replace broken axel multi-threaded download alternative to wget but now that i have latest axel working, aria2 is not needed
     
    Last edited: Aug 25, 2016
    • Like Like x 1
    • Informative Informative x 1
  5. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    4:56 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Ok i remove it and all working now :)

    Thanks
     
  6. hitman

    hitman Member

    121
    11
    18
    Jul 18, 2014
    Ratings:
    +15
    Local Time:
    4:56 AM
    Code:
    yum remove aria2
    so this would resolve the problem?
    i am asking just in case i misunderstood, and i do not want to mess up
     
  7. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    4:56 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    yes :)
     
    • Like Like x 1
  8. trxerz

    trxerz Member

    66
    5
    8
    Jun 25, 2015
    Ratings:
    +7
    Local Time:
    2:56 AM
    Hey, I also got this.
    Hi, I also got this today.
    Yum remove the aria2 then it works but show this when yum update:
    Code:
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/weak-updates failed: No such file or directory
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/modules.order failed: No such file or directory
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/modules.networking failed: No such file or directory
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/modules.modesetting failed: No such file or directory
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/modules.drm failed: No such file or directory
    warning:    erase unlink of /lib/modules/2.6.32-573.22.1.el6.x86_64/modules.block failed: No such file or directory
    Is it Okay?
     
  9. eva2000

    eva2000 Administrator Staff Member

    37,311
    8,153
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,549
    Local Time:
    12:56 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    which web host ? type of server openvz, kvm, xen, vmware, dedicated ?

    Warnig erase old kernel - CentOS
     
  10. trxerz

    trxerz Member

    66
    5
    8
    Jun 25, 2015
    Ratings:
    +7
    Local Time:
    2:56 AM
  11. eva2000

    eva2000 Administrator Staff Member

    37,311
    8,153
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,549
    Local Time:
    12:56 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    should be fine from that link
    though from Bug 1343411 – new-kernel-pkg removes files owned by kernel package causing warning on kernel update it could be a bug
     
    • Like Like x 1
  12. eva2000

    eva2000 Administrator Staff Member

    37,311
    8,153
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,549
    Local Time:
    12:56 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what version of centos you using ?
    Code (Text):
    cat /etc/redhat-release
     
  13. trxerz

    trxerz Member

    66
    5
    8
    Jun 25, 2015
    Ratings:
    +7
    Local Time:
    2:56 AM
  14. rdan

    rdan Premium Member Premium Member

    4,420
    1,059
    113
    May 25, 2014
    Ratings:
    +1,543
    Local Time:
    10:56 AM
    Mainline
    10.2
    Thanks A LOT EVA :)
     
    • Like Like x 1
..