Welcome to Centmin Mod Community
Register Now

Yum transaction error oniguruma

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Rake-GH, Jun 19, 2020.

  1. Rake-GH

    Rake-GH Active Member

    131
    60
    28
    Jul 29, 2019
    USA
    Ratings:
    +97
    Local Time:
    12:18 PM
    default
    default
    • CentOS Version: 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.17.10
    • PHP Version Installed: 7.4.7
    • MariaDB MySQL Version Installed: 10.3.23
    • When was last time updated Centmin Mod code base ? : today

    Error on yum update:
    Code:
    Transaction check error:
      file /usr/lib64/libonig.so.5.0.0 from install of oniguruma-6.8.2-1.el7.x86_64 conflicts with file from package oniguruma5-6.9.4-1.el7.remi.x86_64
    
    To solve this, I just remove the version of oniguruma currently installed and then run yum update again right?
     
  2. Rake-GH

    Rake-GH Active Member

    131
    60
    28
    Jul 29, 2019
    USA
    Ratings:
    +97
    Local Time:
    12:18 PM
    default
    default
    This was actually solved just by upgrading to PHP7.4.7 first, which took care of this conflict for me
     
  3. eva2000

    eva2000 Administrator Staff Member

    44,525
    10,170
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,742
    Local Time:
    2:18 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x