Learn about Centmin Mod LEMP Stack today
Register Now

Upgrade Yum / ImageMagick Errors

Discussion in 'Install & Upgrades or Pre-Install Questions' started by BigIron, May 4, 2016.

  1. BigIron

    BigIron Member

    49
    10
    8
    Sep 18, 2015
    Ratings:
    +13
    Local Time:
    8:33 PM
    I've been getting these errors for quite some time, every time yum tries to update.

    Any suggestions?

    Code:
    225 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.9-1.el7.remi will be an update
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.9-1.el7.remi will be an update
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-libs-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-libs-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-libs(x86-64) = 6.9.3.9-1.el7.remi
    Error: Package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-c++-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-c++-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-c++(x86-64) = 6.9.3.9-1.el7.remi
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    
    Code:
    Installed Packages
    ImageMagick-last.x86_64                                                                                           6.9.3.8-1.el7.remi                                                                                  @remi
    ImageMagick-last-c++.x86_64                                                                                       6.9.3.8-1.el7.remi                                                                                  @remi
    ImageMagick-last-c++-devel.x86_64                                                                                 6.9.3.8-1.el7.remi                                                                                  @remi
    ImageMagick-last-devel.x86_64                                                                                     6.9.3.8-1.el7.remi                                                                                  @remi
    ImageMagick-last-libs.x86_64                                                                                      6.9.3.8-1.el7.remi                                                                                  @remi
    Available Packages
    ImageMagick-last-c++.x86_64                                                                                       6.9.3.9-1.el7.remi                                                                                  remi-safe
    ImageMagick-last-djvu.x86_64                                                                                      6.9.3.9-1.el7.remi                                                                                  remi-safe
    ImageMagick-last-libs.x86_64                                                                                      6.9.3.9-1.el7.remi                                                                                  remi-safe
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    Last edited: May 4, 2016
  3. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    6:33 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I have the same issue and when i run:

    Code:
    yum -y update --enablerepo=remi
    i am getting this:

    Code:
    Error: Package: ImageMagick-last-libs-6.9.3.9-1.el6.remi.x86_64 (remi)
               Requires: libwebp.so.5()(64bit)
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    forgot to disable yum priorities
    Code (Text):
    yum -y update --enablerepo=remi --disableplugin=priorities

    see if that works
     
  5. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    6:33 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    nope :(

    same error

    I was use the last time that i had this issue an edit also to the Repo to exclude it:

    /etc/yum.repos.d/epel.repo

    Code:
     clamd clamav clamav-db libwebp*
    
    don't know if it is related....

    also:

    Code:
    yum list libwebp libwebp-devel --disableplugin=priorities --enablerepo=remi
    results:
    Code:
    libwebp.x86_64                                             0.3.1-2.el6.remi                                 
    
    libwebp-devel.x86_64                                             0.3.1-2.el6.remi 
    It looks like it can't find it and maybe is related to a link of it as i can read on another topic ? :

    Code:
    http://mirror.steadfast.net/centos/6.6/
    is empty

    I am on:

    Code:
    CentOS release 6.7 (Final)
    No issues on Centos 7 !

    So it looks like specific to Centos 6.x
     
    Last edited: May 4, 2016
  6. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    there's your problem remove libwebp from exclude line !
     
    • Informative Informative x 1
  7. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    6:33 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    All working now :)

    I just got this:

    Code:
    http://mirrors.ircam.fr/pub/fedora/epel/6/x86_64/libwebp-0.4.3-3.el6.x86_64.rpm: [Errno 12] Timeout on http://mirrors.ircam.fr/pub/fedora/epel/6/x86_64/libwebp-0.4.3-3.el6.x86_64.rpm: (28, 'connect() timed out!')
    but at the end it works....
     
  8. pamamolf

    pamamolf Well-Known Member

    2,722
    242
    63
    May 31, 2014
    Ratings:
    +433
    Local Time:
    6:33 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Last edited: May 4, 2016
  9. BigIron

    BigIron Member

    49
    10
    8
    Sep 18, 2015
    Ratings:
    +13
    Local Time:
    8:33 PM
    @eva2000 here's what I get:

    Code:
    yum -y update --enablerepo=remi --disableplugin=priorities
    
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.linode.com
    * epel: linux.mirrors.es.net
    * extras: mirrors.linode.com
    * remi: mirrors.mediatemple.net
    * remi-safe: mirrors.mediatemple.net
    * rpmforge: mirror.hmc.edu
    * updates: mirrors.linode.com
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.9-1.el7.remi will be an update
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.9-1.el7.remi will be an update
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-libs-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-libs-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-libs(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-libs-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.7-1.el7.remi
    Error: Package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-c++-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-c++-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-c++(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-c++-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.7-1.el7.remi
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    
     
  10. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    try 2 commands
    Code (Text):
    yum -y update ImageMagick-last-libs libwebp --enablerepo=remi --disableplugin=priorities
    yum -y update --enablerepo=remi --disableplugin=priorities
     
  11. BigIron

    BigIron Member

    49
    10
    8
    Sep 18, 2015
    Ratings:
    +13
    Local Time:
    8:33 PM
    No luck sir.

    Code:
    [root@--- centminmod]# yum -y update ImageMagick-last-libs libwebp --enablerepo=remi --disableplugin=pri                                                                 orities
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.linode.com
    * epel: linux.mirrors.es.net
    * extras: mirrors.linode.com
    * remi: mirrors.mediatemple.net
    * remi-safe: mirrors.mediatemple.net
    * rpmforge: mirror.hmc.edu
    * updates: mirrors.linode.com
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-l                                                                 ast-c++-6.9.3.8-1.el7.remi.x86_64
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-l                                                                 ast-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.9-1.el7.remi will be an update
    --> Running transaction check
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-la                                                                 st-c++-devel-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.9-1.el7.remi will be an update
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-l                                                                 ast-6.9.3.8-1.el7.remi.x86_64
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-libs-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-libs-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-libs(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-libs-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.7-1.el7.remi
    Error: Package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-c++-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-c++-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-c++(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-c++-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.7-1.el7.remi
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [root@--- centminmod]# yum -y update --enablerepo=remi --disableplugin=priorities
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirrors.linode.com
    * epel: linux.mirrors.es.net
    * extras: mirrors.linode.com
    * remi: mirrors.mediatemple.net
    * remi-safe: mirrors.mediatemple.net
    * rpmforge: mirror.hmc.edu
    * updates: mirrors.linode.com
    Resolving Dependencies
    --> Running transaction check
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-la                                                                 st-c++-devel-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-c++.x86_64 0:6.9.3.9-1.el7.remi will be an update
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.8-1.el7.remi will be updated
    --> Processing Dependency: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi for package: ImageMagick-l                                                                 ast-6.9.3.8-1.el7.remi.x86_64
    ---> Package ImageMagick-last-libs.x86_64 0:6.9.3.9-1.el7.remi will be an update
    --> Finished Dependency Resolution
    Error: Package: ImageMagick-last-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-libs-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-libs-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-libs(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-libs-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-libs(x86-64) = 6.9.3.7-1.el7.remi
    Error: Package: ImageMagick-last-c++-devel-6.9.3.8-1.el7.remi.x86_64 (@remi)
               Requires: ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Removing: ImageMagick-last-c++-6.9.3.8-1.el7.remi.x86_64 (@remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.8-1.el7.remi
               Updated By: ImageMagick-last-c++-6.9.3.9-1.el7.remi.x86_64 (remi-safe)
                   ImageMagick-last-c++(x86-64) = 6.9.3.9-1.el7.remi
               Available: ImageMagick-last-c++-6.9.3.7-1.el7.remi.x86_64 (remi)
                   ImageMagick-last-c++(x86-64) = 6.9.3.7-1.el7.remi
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    [root@--- centminmod]#
    
     
  12. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    what about
    Code (Text):
    yum -y update --enablerepo=remi --disablerepo=remi-safe --disableplugin=priorities
     
    • Like Like x 1
  13. BigIron

    BigIron Member

    49
    10
    8
    Sep 18, 2015
    Ratings:
    +13
    Local Time:
    8:33 PM
    That did it!
     
    • Like Like x 1
  14. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:33 PM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 1