Discover Centmin Mod today
Register Now

Domains DNS www. prefix leads to error

Discussion in 'Domains, DNS, Email & SSL Certificates' started by bruno, Oct 31, 2017.

  1. bruno

    bruno Premium Member Premium Member

    54
    3
    8
    Oct 14, 2016
    Ratings:
    +7
    Local Time:
    10:42 PM
    Hey

    Freshly installed centminmod. Added WordPress via option 22.

    When I visit https://mywebsite.com , it works.

    When I visit https://www.mywebsite.com , I get this error:

    [​IMG]

    Any idea how to fix this?

    Thanks in advance!
     
  2. Jimmy

    Jimmy Premium Member Premium Member

    1,138
    252
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +609
    Local Time:
    5:42 PM
    1.13.x
    MariaDB 10.1.x
    Is woostripe.com your website?
     
  3. eva2000

    eva2000 Administrator Staff Member

    30,569
    6,854
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,274
    Local Time:
    8:42 AM
    Nginx 1.13.x
    MariaDB 5.5
    Check DNS A records are correct for non-www and www version of your domain via dig to check DNS for domain
    Code (Text):
    dig +short A @8.8.8.8 yourdomain.com
    dig +short A @8.8.8.8 www.yourdomain.com
    

    check HTTP headers via curl for both HTTP (and HTTPS if you have HTTPS/SSL)
    Code (Text):
    curl -I http://yourdomain.com
    curl -I http://www.yourdomain.com
    curl -I https://yourdomain.com
    curl -I https://www.yourdomain.com
    

    also check via Global DNS Propagation Checker - What's My DNS?
     
  4. bruno

    bruno Premium Member Premium Member

    54
    3
    8
    Oct 14, 2016
    Ratings:
    +7
    Local Time:
    10:42 PM
    yes
     
  5. Jon Snow

    Jon Snow Active Member

    188
    27
    28
    Jun 30, 2017
    Ratings:
    +32
    Local Time:
    6:42 PM
    Nginx 1.13.4
    MariaDB 10.1.26
    I'm getting redirected from www to non-www. I guess this has been fixed?
     
  6. bruno

    bruno Premium Member Premium Member

    54
    3
    8
    Oct 14, 2016
    Ratings:
    +7
    Local Time:
    10:42 PM
    thanks guys. i think the fix for this was to uncomment the cloudflare line or the permalink line in the conf files.
     
  7. eva2000

    eva2000 Administrator Staff Member

    30,569
    6,854
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,274
    Local Time:
    8:42 AM
    Nginx 1.13.x
    MariaDB 5.5
    yes both those would be needed if using cloudflare and if your nginx https vhost doesn't have same wp related config settings as your nginx non-https vhost