Join the community today
Become a Member

Wordpress WP Password protected page requests wp-login pass

Discussion in 'Blogs & CMS usage' started by 1121, Jan 1, 2019.

  1. 1121

    1121 New Member

    15
    1
    3
    Nov 29, 2018
    Ratings:
    +2
    Local Time:
    4:51 AM
    1.15.7
    MariaDB 10.1.37
    Happy New year!
    Strange thing happens: when I set a page or a post password protected inside WordPress, I have to also enter wp-login page password as well. this request pops up after entering the page password.
    This is inconvenient, because I want to share this password protected page with others and I only want to provide them with the page password, not the wp-login password as well.
    Any way to disable the wp-login password requirement on regular password protected pages? Thanks
     
  2. eva2000

    eva2000 Administrator Staff Member

    37,710
    8,254
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,710
    Local Time:
    7:51 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Does wp password protected pages redirect to /wp-admin/ ? as wp-login.php password protect involves also protecting wp-admin. If you have user logins, you need to disable wp-login.php nginx level HTTP password protection.
     
  3. 1121

    1121 New Member

    15
    1
    3
    Nov 29, 2018
    Ratings:
    +2
    Local Time:
    4:51 AM
    1.15.7
    MariaDB 10.1.37
    There are no user logins per se. It is just a WordPress page that is set to Private with password protection. The password is set in the page settings under the Status and Visibility tab -> Private.
     
  4. eva2000

    eva2000 Administrator Staff Member

    37,710
    8,254
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,710
    Local Time:
    7:51 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    If the wordpress page private password protection uses same function as wp-login.php or has a call to wp-admin/* somewhere, then yes it would trigger wp-login.php protection, so would need to disable wp-login.php password protection unfortunately.

    sounds like setting private is only for admin/editors viewing so needs login permissions
     
..