Welcome to Centmin Mod Community
Become a Member

Wordpress wp-login.php login not working after installation

Discussion in 'Blogs & CMS usage' started by quicksalad, Apr 6, 2022.

  1. quicksalad

    quicksalad Member

    174
    9
    18
    May 31, 2015
    Ratings:
    +14
    Local Time:
    4:04 PM
    Please advise why the auto generated password for wp-login.php is not working after installation via option 22.
    Accessing URL: https://mydomain.com/wp-login.php
    Other details:
    CentOs7 from DO
    LetsEncrypt
    Cloudflare
    Thanks!

     
  2. eva2000

    eva2000 Administrator Staff Member

    48,440
    11,102
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,281
    Local Time:
    8:34 PM
    Nginx 1.21.x
    MariaDB 10.x
    Do you mean the Wordpress login itself or the HTTP password protected user/pass in front of Wordpress login page?

    Does the auto generated password have any non-alphanumeric characters? Could be the Wordpress install doesn't like it? You also just do a password reset from Wordpress login page.
     
  3. quicksalad

    quicksalad Member

    174
    9
    18
    May 31, 2015
    Ratings:
    +14
    Local Time:
    4:04 PM
    Hi eva,
    The HTTP password protected userpass that is generated.
    Thanks
     
  4. quicksalad

    quicksalad Member

    174
    9
    18
    May 31, 2015
    Ratings:
    +14
    Local Time:
    4:04 PM
    I'm also having not secure warning when access my wordpress site domain via https://mydomain.c0m. I follow the LetsEncrypt prompt during installation. Could it be the reason why the HTTP password protect is not working?

    I set it to
    Full - Encrypts end-to-end, using a self signed certificate on the server option
    and the warning is gone.
    Setting to Full (strict) and Flexible makes my site not accessible. Should select Full only? seems like Cloudflare updated their dashboard.
     
    Last edited: Apr 6, 2022
  5. quicksalad

    quicksalad Member

    174
    9
    18
    May 31, 2015
    Ratings:
    +14
    Local Time:
    4:04 PM
    Solved thanks!
    Maybe Wordpress install doesn't like the autogenerated pw. Did a password reset via command below!
    Code:
    vhostname=mydomain.com
    /usr/local/nginx/conf/htpasswd.sh create /home/nginx/domains/$vhostname/htpasswd_wplogin USERNAME PASSWORD
    where USERNAME - is your new desired username and PASSWORD - is your new desired password
     
  6. eva2000

    eva2000 Administrator Staff Member

    48,440
    11,102
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,281
    Local Time:
    8:34 PM
    Nginx 1.21.x
    MariaDB 10.x
    Yup that's the solution :)