Join the community today
Register Now

Wordpress WP-CLI Community Packages

Discussion in 'Blogs & CMS usage' started by Guilherme Jaccoud, Oct 8, 2014.

  1. Guilherme Jaccoud

    Guilherme Jaccoud Member

    63
    30
    18
    May 29, 2014
    Ratings:
    +30
    Local Time:
    10:46 AM
    Hi there :)

    I've been trying to install some community packages for WP-CLI and now my WP-CLI is broken and I can't seem to revert it. I've tried to re-install WP-CLI add-on also without luck.

    [root@mars wp]# wp plugin list
    PHP Warning: require(/root/.wp-cli/
    - vendor/autoload.php): failed to open stream: No such file or directory in phar:///usr/bin/wp/php/utils.php on line 41
    PHP Fatal error: require(): Failed opening required '/root/.wp-cli/
    - vendor/autoload.php' (include_path='.:/usr/local/lib/php') in phar:///usr/bin/wp/php/utils.php on line 41

    Can someone give me a little help?

    Cheers,
    Guigo
     
  2. eva2000

    eva2000 Administrator Staff Member

    29,008
    6,580
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,770
    Local Time:
    11:46 PM
    Nginx 1.13.x
    MariaDB 5.5
    how old is the wp-cli installation itself ?

    output from command

    Code:
    wp --info --allow-root
    i.e.
    Code:
    wp --info --allow-root
    PHP binary:     /usr/local/bin/php
    PHP version:    5.4.33
    php.ini used:   /usr/local/lib/php.ini
    WP-CLI root dir:        phar://wp-cli.phar
    WP-CLI global config:
    WP-CLI project config:
    WP-CLI version: 0.17.0
     
  3. eva2000

    eva2000 Administrator Staff Member

    29,008
    6,580
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,770
    Local Time:
    11:46 PM
    Nginx 1.13.x
    MariaDB 5.5
  4. Guilherme Jaccoud

    Guilherme Jaccoud Member

    63
    30
    18
    May 29, 2014
    Ratings:
    +30
    Local Time:
    10:46 AM
    I've deleted ~/.wp-cli/config.yml and everything seems to be working again.

    [root@mars wp]# wp --allow-root --info
    PHP binary: /usr/local/bin/php
    PHP version: 5.5.14
    php.ini used: /usr/local/lib/php.ini
    WP-CLI root dir: phar://wp-cli.phar
    WP-CLI global config:
    WP-CLI project config:
    WP-CLI version: 0.15.1

    Is there some difference about how to install Community Packages on CentmimMod systems?
     
  5. eva2000

    eva2000 Administrator Staff Member

    29,008
    6,580
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,770
    Local Time:
    11:46 PM
    Nginx 1.13.x
    MariaDB 5.5
    Last edited: Oct 8, 2014
  6. Guilherme Jaccoud

    Guilherme Jaccoud Member

    63
    30
    18
    May 29, 2014
    Ratings:
    +30
    Local Time:
    10:46 AM
    Last edited: Oct 8, 2014
    • Like Like x 1
  7. eva2000

    eva2000 Administrator Staff Member

    29,008
    6,580
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,770
    Local Time:
    11:46 PM
    Nginx 1.13.x
    MariaDB 5.5
  8. Guilherme Jaccoud

    Guilherme Jaccoud Member

    63
    30
    18
    May 29, 2014
    Ratings:
    +30
    Local Time:
    10:46 AM
    • Like Like x 1