Want to subscribe to topics you're interested in?
Become a Member

Wordpress Wordpress wp-cli

Discussion in 'Blogs & CMS usage' started by SFLC, Dec 14, 2016.

  1. SFLC

    SFLC Active Member

    224
    59
    28
    Dec 4, 2016
    The Canadas
    Ratings:
    +112
    Local Time:
    11:11 PM
    1
    10
    I want to stop WordPress WP-CLI Auto Update from running, mainly as it restarts php-fpm every time it runs and I don’t want that.

    So is there any way to block it from running or atleast stop it from restarting php-fpm a few times a day. My server runs other websites where uploads and downloads take place and I can’t have wordpress restarting things whenever it feels like it.

    In the wp-config file i added the following

    define( ‘WP_AUTO_UPDATE_CORE’, ‘false’ );
    define( ‘AUTOMATIC_UPDATER_DISABLED’, true );

    and it still continued running and ignored the aforementioned lines

    and I tried a few plugins that disable updates and still no joy.

    I’m running wp 4.7.

    What sucks about dealing with this is whatever change I make i have to wait to see if it’ll try to auto update by itself, this is not right.

    I also checked crontab and there’s nothing there.

    I reached out to wordpress support and they said they don't bundle wp-cli,

    so since i installed it from the centmin menu it must have added it from there,
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    7:11 AM
    Nginx 1.13.x
    MariaDB 5.5
    the wp-cli update is in cronjob

    you can see your cronjobs via command as root user
    Code (Text):
    crontab -l
    

    use crontab -e command to invoke nano text editor see guide at HowTo: Add Jobs To cron Under Linux or UNIX?

    it would reference a script generated by centmin.sh menu option 22 /root/tools/wp_updater_${vhostname}.sh where ${vhostname} is your site domain name

    the nginx/php-fpm restart is to make sure zend opcache picks up the updated wordpress files due to the opcache.revalidate_freq setting in zendopcache.ini
    Code (Text):
    ; http://php.net/manual/en/opcache.configuration.php#ini.opcache.revalidate-freq
    ; defaults to zend opcache checking every 180 seconds for PHP file changes
    ; set to zero to check every second if you are doing alot of frequent
    ; php file edits/developer work
    ; opcache.revalidate_freq=0
    opcache.revalidate_freq=180
     
    • Like Like x 1
  3. SFLC

    SFLC Active Member

    224
    59
    28
    Dec 4, 2016
    The Canadas
    Ratings:
    +112
    Local Time:
    11:11 PM
    1
    10
    awesome thanks worked like a charm
     
    • Like Like x 1