Welcome to Centmin Mod Community
Become a Member

Wordpress Wordpress plugin throws error

Discussion in 'Blogs & CMS usage' started by gabel, Jul 10, 2019.

  1. gabel

    gabel Premium Member Premium Member

    54
    32
    18
    Jan 7, 2016
    Ratings:
    +50
    Local Time:
    5:11 PM
    1.9.9
    MariaDB 10
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: i.e. 123.09beta01
    • Nginx Version Installed: 1.17.1
    • PHP Version Installed: 7.1.29
    • MariaDB MySQL Version Installed:10.3.16

    Have a weird issue with a wordpress plugin on a new vps and can't tell why. Checking the php error logs i see this :

    Code:
    [09-Jul-2019 16:44:07 UTC] PHP Fatal error:  Maximum execution time of 9223372036854775807 seconds exceeded in /home/nginx/domains/*/public/wp-includes/wp-db.php on line 2761
    and

    Code:
    [09-Jul-2019 16:45:09 UTC] PHP Fatal error:  Maximum execution time of 9223372036854775807 seconds exceeded in /home/nginx/domains/*/public/wp-content/plugins/cyberseo/cyberseo.php(52) : eval()'d code on line 
    At first, i thought it had to do with the PHP execution time limit but that's not set to 9223372036854775807 seconds lol. I have asked the dev of the plugin if he has any idea and he says it's something to do with the server config and said that

    Haven't done any customization to the centmin installs, the same plugin, for example, works fine on a VPS with vestacp so thinking something in centmin config that this plugin doesn't like.

    I haven't installed Wordpress using option 22, used 2. Wondering if anyone has any ideas that i could try, would hate on having to use VestaCP :D
     
  2. eva2000

    eva2000 Administrator Staff Member

    41,321
    9,274
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,229
    Local Time:
    2:11 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  3. eva2000

    eva2000 Administrator Staff Member

    41,321
    9,274
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,229
    Local Time:
    2:11 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    it's cybersep wp plugin ? never used it but FAQ – CyberSEO Pro
     
  4. gabel

    gabel Premium Member Premium Member

    54
    32
    18
    Jan 7, 2016
    Ratings:
    +50
    Local Time:
    5:11 PM
    1.9.9
    MariaDB 10
    @eva2000 The plugin is called CyberSeo, it can scrape data from other sites. It seems it stores the logic in the database so it runs from there.
    Found an answer in their FAQ but that doesn't shade to much light. Not using anything like wordfence and the 9223372036854775807 seconds exceeded is something i never have seen before :D

    Code:
    Q: I have received the following error message: “Fatal error: Maximum execution time of 9223372036854775807 seconds exceeded in /wp-content/plugins/cyberseo/cyberseo.php(52) : eval()’d code on line 3”.
    
    A: It’s a error, caused by your PHP translator. First of all, make sure that all extensions included into the PHP build are enabled. The PHP mode is switched to “FastCGI” or “CGI”. Also this issue can be caused by a conflict with 3rd-party plugins like “Wordfence” etc.
     
  5. eva2000

    eva2000 Administrator Staff Member

    41,321
    9,274
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,229
    Local Time:
    2:11 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  6. eva2000

    eva2000 Administrator Staff Member

    41,321
    9,274
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,229
    Local Time:
    2:11 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    FYI, I'd update to PHP 7.3.6 or 7.3.7 if possible too
     
  7. gabel

    gabel Premium Member Premium Member

    54
    32
    18
    Jan 7, 2016
    Ratings:
    +50
    Local Time:
    5:11 PM
    1.9.9
    MariaDB 10
    I`ll try changing the PHP version too as I`m running 7.1 now and then will have to have a look at those php-fpm settings :cry::D
     
  8. gabel

    gabel Premium Member Premium Member

    54
    32
    18
    Jan 7, 2016
    Ratings:
    +50
    Local Time:
    5:11 PM
    1.9.9
    MariaDB 10
    A quick update on what i managed to do so far (not enough time :( ). Changed the PHP version to 7.3.7, made some tweaks on php-fpm. I'm still getting that error but not as often as before so there's still something that needs to be tweaked.