Want more timely Centmin Mod News Updates?
Become a Member

Wordpress Wordpress Multisite + FastCGI_Cache + Pagespeed + Cloudflare

Discussion in 'Blogs & CMS usage' started by Peter Downey, Jul 22, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    45,991
    10,448
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,210
    Local Time:
    6:47 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    yeah as i suspected if you moved the 2 includes higher up in location root /
    Code:
      location / {
        include /usr/local/nginx/conf/wpsecure.conf;
        include /usr/local/nginx/conf/wpcache.conf;

     
  2. Daniel J. Lewis

    Daniel J. Lewis Award-winning podcaster and consultant

    117
    15
    18
    Oct 20, 2014
    Ratings:
    +33
    Local Time:
    3:47 PM
    1.8.0
    5.6
    Thanks. I didn't realize their location mattered.
     
  3. Peter Downey

    Peter Downey Member

    64
    24
    8
    May 28, 2014
    Ratings:
    +27
    Local Time:
    3:47 PM
    Hey guys, it's been a while since I was active here. I updated the original post to reflect the final build I landed on with this installation. Just slight changes to the yoast code and moving the location for wpcache.conf and wpsecure.conf.

    After about 8 months with WordPress Multisite with this configuration, I decided to roll the combined sites into their own installations. There were just too many headaches throughout the process that seemed to be either directly related to multisite, or at least partially multisite-related because it overcomplicated relatively simple tasks. Which is funny, because the whole idea behind multisite is to simplify management of multiplte sites. I think under the right conditions multisite is great, but with vastly different sites and ever-changing technology, multisite isn't suitable for all scenarios just yet. I do plan on re-exploring the technology as they continue to refine it though, there is still a lot to like about it in my opinion.

    Anyway, OP reflects final code. I'm planning on making some additional posts soon with some basic WP related stuff that might help some people too.
     
  4. AKIN SENOL

    AKIN SENOL Member

    36
    3
    8
    Oct 17, 2014
    London
    Ratings:
    +8
    Local Time:
    8:47 PM
    1.9.12
    10.1.12
    I'm trying with exactly same configuration but nginx-helper plugin's time stamp shows on-time created when I refresh the tab from front-end (with logout)

    Also I tried with Nginx « WordPress Codex but result is the same.

    Looks like fastcgi nothing cache, anyone has same problem?
     
  5. eva2000

    eva2000 Administrator Staff Member

    45,991
    10,448
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,210
    Local Time:
    6:47 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    do you have ngx_pagespeed enabled ? if you do it won't work with fastcgi_cache as ngx_pagespeed requires cache control header = none/no so fastcgi_cache won't cache with that cache control header in place. If you use fastcgi_cache these days, disable ngx_pagespeed.
     
  6. AKIN SENOL

    AKIN SENOL Member

    36
    3
    8
    Oct 17, 2014
    London
    Ratings:
    +8
    Local Time:
    8:47 PM
    1.9.12
    10.1.12
    Pagespeed totally off and I setup new single website with 22. menu. And same fastcgi configurations applied. Result, single site working well with fastcgi, but I couldn't connect multisite to fastcgi.

    In var/cache/nginx has just single wp setup's cache files.

    I'm tearing my hair right now.
     
    Last edited: Apr 2, 2016
  7. nader shawky

    nader shawky New Member

    2
    0
    1
    Aug 10, 2020
    Ratings:
    +0
    Local Time:
    10:47 PM
  8. R0rke

    R0rke Member

    163
    20
    18
    Jun 2, 2016
    Iran
    Ratings:
    +34
    Local Time:
    12:47 PM
    1.11.1
    10.1
    yeah, same problem not working at all.
    it ends up in a redirect loop!