Join the community today
Become a Member

Wordpress Gravatars and Nginx, Help..

Discussion in 'Blogs & CMS usage' started by Jesus Higuerey, Aug 31, 2018.

  1. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    oh be sure to disable pre-compression as directed in the guide for
    though that will slightly slow down performance as dynamic compression is used instead of gzip static

    Best performance would be from just disabling gravatars altogether
     
  2. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    I must be doing something wrong, I copy & pasted the code you posted, changed HTTPS to HTTP and still getting gravatars from their end, hmm..

    Screenshot

    And also disabled the pre-compression you mentioned a couple of mins ago
     
  3. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    did you uncheck pre-compression of cached pages and save the cache enabler settings

    upload_2018-8-31_10-13-36.png

    sub_filter only works for wordpress with cache enabler when pre-compression is disabled
     
  4. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Yes, looks exactly the same as the picture above
     
  5. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    try clearing browser cache, cache enabler cache and restart nginx + php-fpm

    the configuration i suggested works on my test install as long as pre-compression is disabled in cache enabler
     
  6. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Code:
    [00:28][root@DevSrv conf.d]# nprestart
    Restarting nginx (via systemctl):                          [  OK  ]
    Gracefully shutting down php-fpm . done
    Starting php-fpm  done
    [00:28][root@DevSrv conf.d]#
    
    Yeah I mean is disabled, weird.. I tested it on my phone which this site I am testing on was never opened before on that phone, so I don't think is the cache of the browser.. hmmmm

    I currently have a site with EasyEngine, but when I looked at the difference on requests, wanted to change to centmin, but first wanted to make sure it works. On the easyengine setup doesn't work, I added the config file on my server block and now, gravatars' are being pulled from my server but once opening "domain.com/avatar/" I am encountering a 502 error
     
  7. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    on which server easyengine or centmin mod getting 502 error ?

    you did change domain.com to actual domain name with valid DNS A record pointing to your centmin mod server IP address ?
     
  8. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Found these logs which seems kinda weird
    Code:
    2018/08/31 00:23:09 [error] 23677#0: *4 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 00:23:43 [error] 23677#0: *4 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 00:23:49 [error] 23677#0: *6 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com"$
    2018/08/31 00:23:49 [error] 23677#0: *7 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com"$
    2018/08/31 00:33:44 [error] 23677#0: *20 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:33:50 [error] 23677#0: *21 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:34:23 [error] 23677#0: *23 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 00:34:29 [error] 23677#0: *23 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 00:35:07 [error] 23677#0: *25 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:35:07 [error] 23677#0: *26 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:35:07 [error] 23677#0: *27 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:38 [error] 26123#0: *37 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:38 [error] 26123#0: *38 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:44 [error] 26123#0: *45 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:44 [error] 26123#0: *46 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:45 [error] 26123#0: *48 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:40:51 [error] 26123#0: *49 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:42:12 [error] 26408#0: *3 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com"$
    2018/08/31 00:42:21 [error] 26408#0: *4 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 00:49:34 [error] 26408#0: *13 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:49:34 [error] 26408#0: *14 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:49:34 [error] 26408#0: *15 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:49:41 [error] 26408#0: *20 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:49:41 [error] 26408#0: *21 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:49:42 [error] 26408#0: *22 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/1.1", host: "domain.com$
    2018/08/31 00:50:00 [error] 26408#0: *25 no resolver defined to resolve secure.gravatar.com, client: 45.43.21.250, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/1.1", host: "domain.com"
    2018/08/31 00:50:03 [error] 26408#0: *10 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/2.0", host: "domain.co$
    
     
    Last edited: Aug 31, 2018
  9. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    On the easyengine server, centminmod server is not even rewriting the urls, easyengine does rewrite the urls to "cdn.domain.com" but getting a 502 error..
     
  10. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    make sure server's dns resolver is working properly

    this command should return the DNS A record IP address for secure.gravatar.com
    Code (Text):
    dig +short A secure.gravatar.com
    

    like
    Code (Text):
    dig +short A secure.gravatar.com
    192.0.73.2
    

    if it doesn't then dns resolver set in /etc/resolv.conf isn't working

    you should have something like below in /etc/resolv.conf
    Code (Text):
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    
     
  11. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    I changed to cloudflare's nameservers (1.1.1.1) getting same error pretty much, this is driving me nuts.
     
  12. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    use 8.8.8.8 instead.. the problem could be due to your server's DNS resolver

    what do you get when you run this command in SSH
    Code (Text):
    dig +short A secure.gravatar.com
    
     
  13. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Code:
    /var/log/nginx# dig +short A secure.gravatar.com
    192.0.73.2
    
     
  14. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Now I am getting
    Code:
    2018/08/31 00:50:03 [error] 26408#0: *10 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:02:44 [error] 29029#0: *63 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 01:12:47 [error] 31606#0: *80 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:12:47 [error] 31606#0: *80 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:12:47 [error] 31606#0: *80 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:12:53 [error] 31606#0: *80 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:12:57 [error] 31606#0: *80 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68 HTTP/2.0", host: "domain.com"
    2018/08/31 01:16:26 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 01:17:29 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:17:29 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:17:30 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:17:36 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 01:20:51 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/ HTTP/2.0", host: "domain.com"
    2018/08/31 01:26:01 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:26:01 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:26:03 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/d7a973c7dab26985da5f961be7b74480?s=50&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:26:03 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=26&d=mm&r=g HTTP/2.0", host: "domain.co$
    2018/08/31 01:26:03 [error] 31606#0: *87 no resolver defined to resolve secure.gravatar.com, client: 209.89.XX.XXX, server: domain.com, request: "GET /avatar/655600f7c3156eaf9cc2f5fe96d11c68?s=64&d=mm&r=g HTTP/2.0", host: "domain.co$
    
    Where, 209.89.XX.XXX is my ip address..

    Tried with my phone and the ip changes to my data provider
     
  15. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    if you get IP address returned then try adding to your nginx vhost server{} content the following
    Code (Text):
      resolver 8.8.8.8 8.8.4.4 valid=10m;
      resolver_timeout 10s;
    

    so whole thing becomes
    Code (Text):
    # Centmin Mod Getting Started Guide
    # must read http://centminmod.com/getstarted.html
    
    # redirect from non-www to www
    # uncomment, save file and restart Nginx to enable
    # if unsure use return 302 before using return 301
    #server {
    #            listen   80;
    #            server_name domain.com;
    #            return 301 $scheme://www.domain.com$request_uri;
    #       }
    
    server {
    
      server_name domain.com www.domain.com;
    
      resolver 8.8.8.8 8.8.4.4 valid=10m;
      resolver_timeout 10s;
    
    # ngx_pagespeed & ngx_pagespeed handler
    #include /usr/local/nginx/conf/pagespeed.conf;
    #include /usr/local/nginx/conf/pagespeedhandler.conf;
    #include /usr/local/nginx/conf/pagespeedstatslog.conf;
    
      #add_header X-Frame-Options SAMEORIGIN;
      add_header X-Xss-Protection "1; mode=block" always;
      add_header X-Content-Type-Options "nosniff" always;
      #add_header Referrer-Policy "strict-origin-when-cross-origin";
    
      # limit_conn limit_per_ip 16;
      # ssi  on;
    
      access_log /home/nginx/domains/domain.com/log/access.log combined buffer=256k flush=5m;
      error_log /home/nginx/domains/domain.com/log/error.log;
    
      include /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf;
      root /home/nginx/domains/domain.com/public;
    
      sub_filter 'https://secure.gravatar.com/avatar/' 'https://domain.com/avatar/';
      sub_filter_last_modified on;
      sub_filter_once off;
    
      # uncomment cloudflare.conf include if using cloudflare for
      # server and/or vhost site
      #include /usr/local/nginx/conf/cloudflare.conf;
      include /usr/local/nginx/conf/503include-main.conf;
    
      include /usr/local/nginx/conf/wpincludes/domain.com/wpcacheenabler_domain.com.conf;
      #include /usr/local/nginx/conf/wpincludes/domain.com/wpsupercache_domain.com.conf;
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/wpincludes/domain.com/rediscache_domain.com.conf;
    
      location /avatar {
       proxy_pass https://secure.gravatar.com$request_uri;
      }
    
      location / {
      include /usr/local/nginx/conf/503include-only.conf;
    
      # Enables directory listings when index file not found
      #autoindex  on;
    
      # for wordpress super cache plugin
      #try_files /wp-content/cache/supercache/$http_host/$cache_uri/index.html $uri $uri/ /index.php?q=$uri&$args;
    
      # for wp cache enabler plugin
       try_files $cache_enabler_uri $uri $uri/ $custom_subdir/index.php?$args;
    
      # Wordpress Permalinks
      #try_files $uri $uri/ /index.php?q=$uri&$args;
    
      # Nginx level redis Wordpress
      # https://community.centminmod.com/posts/18828/
      #try_files $uri $uri/ /index.php?$args;
    
      }
    
    location ~* /(wp-login\.php) {
       limit_req zone=xwplogin burst=1 nodelay;
       #limit_conn xwpconlimit 30;
       auth_basic "Private";
       auth_basic_user_file /home/nginx/domains/domain.com/htpasswd_wplogin;
       include /usr/local/nginx/conf/php-wpsc.conf;
    
       # https://community.centminmod.com/posts/18828/
       #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /(xmlrpc\.php) {
       limit_req zone=xwprpc burst=45 nodelay;
       #limit_conn xwpconlimit 30;
       include /usr/local/nginx/conf/php-wpsc.conf;
    
       # https://community.centminmod.com/posts/18828/
       #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-scripts\.php) {
       limit_req zone=xwprpc burst=5 nodelay;
       #limit_conn xwpconlimit 30;
       include /usr/local/nginx/conf/php-wpsc.conf;
    
       # https://community.centminmod.com/posts/18828/
       #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
    location ~* /wp-admin/(load-styles\.php) {
       limit_req zone=xwprpc burst=5 nodelay;
       #limit_conn xwpconlimit 30;
       include /usr/local/nginx/conf/php-wpsc.conf;
    
       # https://community.centminmod.com/posts/18828/
       #include /usr/local/nginx/conf/php-rediscache.conf;
    }
    
      include /usr/local/nginx/conf/wpincludes/domain.com/wpsecure_domain.com.conf;
      include /usr/local/nginx/conf/php-wpsc.conf;
    
      # https://community.centminmod.com/posts/18828/
      #include /usr/local/nginx/conf/php-rediscache.conf;
    
      include /usr/local/nginx/conf/staticfiles.conf;
      include /usr/local/nginx/conf/drop.conf;
      #include /usr/local/nginx/conf/errorpage.conf;
      include /usr/local/nginx/conf/vts_server.conf;
    }
    
     
  16. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    That worked on my easyengine config, going to go ahead, take a break, re install centminmod,a vhost with ssl and then Ill let you know, why do you think my dns's were not working? Should I be worried? I am planning from moving away from DO, looking for alternatives. Any recommendations?
     
  17. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    hard to say why on easyengine config but for centmin mod probably because non-https nginx generated vhosts don't have resolver set only https nginx generated vhosts due to ssl stapling usage and centmin mod doesn't have a default resolver set outside of any nginx vhost by default. I should change that and add on to nginx.conf http{} context for non-https generated vhosts in Centmin Mod 123.09beta01.
     
  18. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Just updated centmin mod 123.09beta01's /usr/local/nginx/conf/nginx.conf with a resolver to local dns within http{} context just below hash variable size settings like
    Code (Text):
    http {
     map_hash_bucket_size 128;
     map_hash_max_size 4096;
     server_names_hash_bucket_size 128;
     server_names_hash_max_size 2048;
     variables_hash_max_size 2048;
    
     resolver 127.0.0.1 valid=10m;
     resolver_timeout 10s;
    
     
  19. Jesus Higuerey

    Jesus Higuerey New Member

    25
    0
    1
    Aug 26, 2018
    Ratings:
    +1
    Local Time:
    2:52 AM
    Hey there,

    I tried on a Hetzner server and also I had to change to Google's NS for some reason as well.. Otherwise it will give me an 502 error...
     
  20. eva2000

    eva2000 Administrator Staff Member

    44,693
    10,193
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,794
    Local Time:
    7:52 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    so 127.0.0.1 doesn't work ?

    what's output for Hetzner server
    Code (Text):
    cat /etc/resolv.conf