Want to subscribe to topics you're interested in?
Become a Member

Wordpress wordpress 'download failed' when installing plugin from wp-content

Discussion in 'Blogs & CMS usage' started by moshbit, Jun 8, 2016.

  1. moshbit

    moshbit Member

    41
    10
    8
    Jun 15, 2014
    Ratings:
    +10
    Local Time:
    8:35 PM
    1.5.8
    MariaDB 5.5
    hey, i was wondering if someone might be able to help me with this, i'm having an issue where i set up a test server and i'm trying to install some wordpress plugins. they're in a folder in the wp-content (as they are included with a theme) but i get the following error when i try to install them:

    i have the permissions set on the wp-content folder to 755 and all the folders/files are owned by the nginx user. my only guess is that i don't have something set correctly in my nginx setup in the beta.locationindie.com.conf file.

    can someone point me in the right direction? thanks!
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,161
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    1:35 PM
    Nginx 1.13.x
    MariaDB 5.5
    1. How did you install wordpress ?
    2. What wordpress plugin does the url or php belong to ?
    3. Which Centmin Mod version 123.08stable or 123.09beta01 ?
    4. Was it via centmin.sh menu option 22 auto installer Wordpress Nginx Auto Installer (WP Super Cache) ? If so the default wpsecure conf file at /usr/local/nginx/conf/wpsecure_${vhostname}.conf where vhostname is your domain name, blocks php scripts from executing in wp-content for security
    Below links you can see examples of setting up specific wordpress location matches to punch a hole in the wpsecure blocking to whitelist specific php files that need to be able to run.
     
  3. moshbit

    moshbit Member

    41
    10
    8
    Jun 15, 2014
    Ratings:
    +10
    Local Time:
    8:35 PM
    1.5.8
    MariaDB 5.5
    i installed wordpress manually with the files from wordpress.org. i set up the vhost using option 22.

    errr... i'm not quite sure? it's a set of plugins that the theme needs after installing the theme. i tried looking around but i can't seem to tell where the script is located :(

    1.2.3-eva2000.08

    that was super helpful! i looked into the documentation on this. i tried adding plugins to the wp secure conf, but couldn't narrow it down properly (as stated above). instead, i just commented out the wpsecure include line in my vhost conf and was able to finish the install process from there. i figure i'll uncomment it after i'm finished setting up the website to re-enable it.

    thanks for the help, i'll come back to this thread if i have issues after re-enabling the wpsecure conf file.