Join the community today
Become a Member

Wordpress Wordpress Auto Installer + WP Super Cache Plugin [Premium Users]

Discussion in 'Blogs & CMS usage' started by eva2000, Nov 8, 2014.

Tags:
  1. eva2000

    eva2000 Administrator Staff Member

    46,976
    10,646
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,525
    Local Time:
    5:25 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    removed ( meant to mean =

    it works and fastcgi is setup out of box on Centmin Mod for PHP-FPM is already used in your include php.conf for each Nginx vhost Nginx Vhost & NSD DNS Setup - Centmin Mod - Menu based Nginx installer for CentOS servers


    you don't need to specify that in nginx vhosts's it's already in php.conf

    Code:
    include /usr/local/nginx/conf/php.conf;
    contents of /usr/local/nginx/conf/php.conf
    Code:
    location ~ \.php$ {
        try_files $uri =404;
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass   127.0.0.1:9000;
        #fastcgi_pass   unix:/tmp/php5-fpm.sock;
        fastcgi_index  index.php;
        #fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
        fastcgi_param  SCRIPT_FILENAME    $request_filename;
    
    # might shave 200+ ms off PHP requests
    # which don't pass on a content length header
    # slightly faster page response time at the
    # expense of throughput / scalability
    sendfile on;
    tcp_nopush off;
    keepalive_requests 0;
    
    fastcgi_connect_timeout 60;
    fastcgi_send_timeout 180;
    fastcgi_read_timeout 180;
    fastcgi_buffer_size 512k;
    fastcgi_buffers 2048 16k;
    fastcgi_busy_buffers_size 8m;
    fastcgi_temp_file_write_size 32m;
    fastcgi_max_temp_file_size 32m;
    fastcgi_intercept_errors on;
    
    # next 3 lines when uncommented / enabled
    # pallow Nginx to handle uploads which then
    # passes back the completed upload to PHP
    #fastcgi_pass_request_body off;
    #client_body_in_file_only clean;
    #fastcgi_param  REQUEST_BODY_FILE  $request_body_file;
    
    #new .04+ map method
    fastcgi_param HTTPS $server_https;
    
    # comment out PATH_TRANSLATED line if /usr/local/lib/php.ini sets following:
    # cgi.fix_pathinfo=0
    # as of centminmod v1.2.3-eva2000.01 default is set to cgi.fix_pathinfo=1
    
    fastcgi_param  PATH_INFO          $fastcgi_path_info;
    fastcgi_param  PATH_TRANSLATED    $document_root$fastcgi_path_info;
    
    fastcgi_param  QUERY_STRING       $query_string;
    fastcgi_param  REQUEST_METHOD     $request_method;
    fastcgi_param  CONTENT_TYPE       $content_type;
    fastcgi_param  CONTENT_LENGTH     $content_length;
    
    fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
    fastcgi_param  REQUEST_URI        $request_uri;
    fastcgi_param  DOCUMENT_URI       $document_uri;
    fastcgi_param  DOCUMENT_ROOT      $document_root;
    fastcgi_param  SERVER_PROTOCOL    $server_protocol;
    
    fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
    fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;
    
    fastcgi_param  REMOTE_ADDR        $remote_addr;
    fastcgi_param  REMOTE_PORT        $remote_port;
    fastcgi_param  SERVER_ADDR        $server_addr;
    fastcgi_param  SERVER_PORT        $server_port;
    fastcgi_param  SERVER_NAME        $server_name;
    
    # PHP only, required if PHP was built with --enable-force-cgi-redirect
    fastcgi_param  REDIRECT_STATUS    200;
    
     
  2. JarylW

    JarylW Active Member

    216
    41
    28
    Jun 19, 2014
    Singapore
    Ratings:
    +103
    Local Time:
    3:25 AM
    you don't need to specify that in nginx vhosts's it's already in php.conf

    Code:
    include /usr/local/nginx/conf/php.conf;
    I cant believe that actually did it :sillyme:

    Code:
    FastCGI sent in stderr: "PHP message: PHP Warning:  Cannot use a scalar value as an array in wp-settings.php
    PHP message: PHP Catchable fatal error:  Call to a member function is_rtl() on null 
    ^ Now I get this when i try to access /wp-admin/plugins.php

    I see that you posted it a month ago - WordPress › Support » PHP Warning: Cannot use a scalar value as an array how did you solve it / managed to configure Super Cache without going into the plugins settings panel?
     
  3. eva2000

    eva2000 Administrator Staff Member

    46,976
    10,646
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,525
    Local Time:
    5:25 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    it fixed itself for me. So don't recall to be honest.

    All I know is installed via the auto installer script and it works :D
     
    Last edited: Dec 31, 2014
  4. JarylW

    JarylW Active Member

    216
    41
    28
    Jun 19, 2014
    Singapore
    Ratings:
    +103
    Local Time:
    3:25 AM
    I dont have access to the autoinstaller script and the script is supposed to follow the same steps - pls correct me if I'm wrong.
     
  5. eva2000

    eva2000 Administrator Staff Member

    46,976
    10,646
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,525
    Local Time:
    5:25 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Autoinstaller script almost follows same steps as there's alot of extra plugins auto installed and tweaked for Centmin Mod and Wordpress usage + auto generation of the Nginx vhost conf and directory structure at the same time.
     
  6. KinderOvO

    KinderOvO Member

    92
    1
    8
    Jan 13, 2015
    Ratings:
    +1
    Local Time:
    5:25 AM
    1.4
    10
    localizar ./wpcli_wordpress.sh

    -bash: ./wpcli_wordpress.sh: Nenhum arquivo ou diretório
     
  7. eva2000

    eva2000 Administrator Staff Member

    46,976
    10,646
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,525
    Local Time:
    5:25 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x