Learn about Centmin Mod LEMP Stack today
Register Now

Wordpress Whitelist OneSignal - Free Web Push Notifications plugin in your wpsecure.conf file

Discussion in 'Blogs & CMS usage' started by Saumya Majumder, Dec 30, 2016.

  1. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    10:20 PM
    1.9.12
    10.0.24
    Hi,
    Today I've installed OneSignal - Free Web Push Notifications on my wordpress site and and it seems it is needed to be whitelisted in the wpsecure.conf file to actually work. So, I manually have to update that and restart nginx to make it work.

    Code:
    # Whitelist Exception for https://wordpress.org/plugins/onesignal-free-web-push-notifications//
    location ~ ^/wp-content/plugins/onesignal-free-web-push-notifications/ {
      include /usr/local/nginx/conf/php.conf;
    }
    
    Please add this to your default wordpress plugin whitelist script so that other people don't face this issue.
     
    • Informative Informative x 2
  2. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    cheers thanks for the heads up :D
     
  3. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    10:20 PM
    1.9.12
    10.0.24
    No problemo :D
     
  4. kinhatula

    kinhatula New Member

    7
    2
    3
    Sep 6, 2017
    Ratings:
    +2
    Local Time:
    11:50 PM
    where is add this code ? thanks
     
  5. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:50 AM
    Nginx 1.13.x
    MariaDB 5.5
    if you use centmin.sh menu option 22 installed wordpress install in 123.09beta01, it would be already added into wordpress generated include file /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf where ${vhostname} is your vhost name.