Discover Centmin Mod today
Register Now

Wordpress White screen of death on fresh WP option 22 install when saving WP super cache settings

Discussion in 'Blogs & CMS usage' started by Benjamin74, May 2, 2016.

  1. Benjamin74

    Benjamin74 Member

    32
    2
    8
    May 2, 2016
    Ratings:
    +5
    Local Time:
    11:44 PM
    Hello guys,

    There is apparently a bug with the option 22 (installed from this morning).

    After installing WP from the command line, I login into wordpress and simply doing:
    - change permalink to %postname%
    - then editing the WP super cache advanced settings to what they should be leads to a whitepage of death (well not that much of death as I can go back to the dashboard but basically WP super cache new settings CAN'T BE SAVED).

    2016-05-02_1309 - benjmacpro's library

    Any idea ?

    Cheers,
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,947
    6,915
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,413
    Local Time:
    8:44 AM
    Nginx 1.13.x
    MariaDB 5.5
    FAQ item 19 lists where php-fpm error logs are
    You can check them to see what errors exist as centmin mod by default has php expose errors disabled for security purposes, so all you see and all other visitors would see is a blank page

    Any clues in your access.log and error.log in vhost listed paths at
    Code (Text):
    access_log /home/nginx/domains/domain.com/log/access.log combined buffer=256k flush=60m;
    error_log /home/nginx/domains/domain.com/log/error.log;
    


    I assume you're using centmin mod 123.08stable as that centmin.sh menu option 22 isn't as advanced/improved as the version in 123.09beta01. So if you're still testing, I'd suggest you reload a fresh CentOS OS and try centmin mod 123.09beta01 - 1st post at Beta Branch - Centmin Mod .09 beta branch Testing | Centmin Mod Community has instructions for install. It's going to be the next stable version soon with heaps of improvements as per change log in 2nd post of that thread. Centmin Mod 123.09beta01 centmin.sh menu option 22 switches from WP Super Cache to KeyCDN Cache Enabler which is less problematic and easier to get started with and has same performance still :)
     
  3. Benjamin74

    Benjamin74 Member

    32
    2
    8
    May 2, 2016
    Ratings:
    +5
    Local Time:
    11:44 PM
    Thanks !

    Yes apparently Super Cache isn't very happy with something...

    Code:
    [root@VultrParisCent6OS2GB centminmod]#   tail -10 /var/log/php-fpm/www-error.log
    [root@VultrParisCent6OS2GB centminmod]# tail -10 /var/log/php-fpm/www-php.error.log
    [02-May-2016 10:45:40 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [02-May-2016 10:45:52 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [02-May-2016 10:47:14 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [02-May-2016 10:50:06 UTC] PHP Warning:  file_get_contents(/home/nginx/domains/mytestdomain.com/public/wp-content/advanced-cache.php): failed to open stream: No such file or directory in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 2372
    [02-May-2016 10:52:31 UTC] PHP Warning:  implode(): Invalid arguments passed in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 3088
    [02-May-2016 10:52:31 UTC] PHP Warning:  implode(): Invalid arguments passed in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 3090
    [02-May-2016 10:53:00 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [02-May-2016 11:08:32 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [02-May-2016 11:09:40 UTC] PHP Fatal error:  Call to undefined function wpsc_deep_replace() in /home/nginx/domains/mytestdomain.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 502
    [root@VultrParisCent6OS2GB centminmod]# 
    I'll see how it goes with KeyCDN plugin instead.

    Cheers,
     
    • Informative Informative x 1
  4. eva2000

    eva2000 Administrator Staff Member

    30,947
    6,915
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,413
    Local Time:
    8:44 AM
    Nginx 1.13.x
    MariaDB 5.5
  5. Benjamin74

    Benjamin74 Member

    32
    2
    8
    May 2, 2016
    Ratings:
    +5
    Local Time:
    11:44 PM
    OK well not sooo happy with how things are turning out.

    After manually deleting wp-super-cache plugin through FTP (because it's impossible from WP itself, it says there is permissions issues), I then tried to delete all the existing plugins and again I get the white-screen...

    Something is profoundly wrong with how things are setup with the stable version, I'll try with the beta.

    Cheers,
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,947
    6,915
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,413
    Local Time:
    8:44 AM
    Nginx 1.13.x
    MariaDB 5.5
    It's partially why 123.09beta01 centmin.sh menu 22 switched from WP Super Cache to KeyCDN Cache Enabler :)

    with white screens, again check php-fpm error log for clues

    if you want to delete plugins you can also use wp-cli command within your wordpress install directory wp plugin | WP-CLI

    specific command wp plugin deactivate | WP-CLI to deactivate and uninstall where /home/nginx/domains/yourdomain.com/public is where wp was installed
    Code (Text):
    cd /home/nginx/domains/yourdomain.com/public
    wp plugin deactivate wp-super-cache --uninstall --allow-root
    


    for example in 123.09beta01 centmin.sh menu option 22, to get wp plugin status and deactivate and reactive a wp plugin called optimus you'd do
    Code (Text):
    cd /home/nginx/domains/testdomain.com/public
    
    wp plugin status --allow-root
    8 installed plugins:
      I akismet                         3.1.10
      A cache-enabler                   1.0.9
      A cdn-enabler                     1.0.2
      A disable-xml-rpc                 1.0.1
      A optimus                         1.4.5
      A sucuri-scanner                  1.7.17
      A wp-super-cache                  1.4.8
      A wp-super-cache-clear-cache-menu 1.3.1
    
    Legend: I = Inactive, A = Active
    

    Code (Text):
    wp plugin deactivate optimus --allow-root
    Success: Plugin 'optimus' deactivated.
    

    Code (Text):
    wp plugin status --allow-root          
    8 installed plugins:
      I akismet                         3.1.10
      A cache-enabler                   1.0.9
      A cdn-enabler                     1.0.2
      A disable-xml-rpc                 1.0.1
      I optimus                         1.4.5
      A sucuri-scanner                  1.7.17
      A wp-super-cache                  1.4.8
      A wp-super-cache-clear-cache-menu 1.3.1
    
    Legend: I = Inactive, A = Active
    
    wp plugin activate optimus --allow-root
    Success: Plugin 'optimus' activated.
    

    permissions
    Code (Text):
    ls -lah /home/nginx/domains/testdomain.com/public/wp-content/plugins/
    total 16K
    drwxr-sr-x 10 nginx nginx 4.0K May  2 12:44 .
    drwxr-s---  7 nginx nginx  140 May  2 12:44 ..
    drwxr-sr-x  4 nginx nginx 4.0K May  2 12:43 akismet
    drwxr-xr-x  5 nginx nginx   77 May  2 12:43 cache-enabler
    drwxr-xr-x  3 nginx nginx   55 May  2 12:43 cdn-enabler
    drwxr-xr-x  2 nginx nginx   49 May  2 12:43 disable-xml-rpc
    -rw-r--r--  1 nginx nginx   28 May  2 12:43 index.php
    drwxr-xr-x  6 nginx nginx   81 May  2 12:43 optimus
    drwxr-xr-x  3 nginx nginx  117 May  2 12:43 sucuri-scanner
    drwxr-xr-x  4 nginx nginx 4.0K May  2 12:43 wp-super-cache
    drwxr-xr-x  3 nginx nginx   81 May  2 12:43 wp-super-cache-clear-cache-menu
     
    Last edited: May 2, 2016
  7. Benjamin74

    Benjamin74 Member

    32
    2
    8
    May 2, 2016
    Ratings:
    +5
    Local Time:
    11:44 PM
    OK no luck either with the beta...

    I told it to NOT install WP Super Cache :

    And the result is well... here we go:

    I guess for Wordpress I'll just continue using EasyEngine as it clearly seems like Wordpress is a new feature within CentMinMod.

    Cheers,
     
  8. eva2000

    eva2000 Administrator Staff Member

    30,947
    6,915
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,413
    Local Time:
    8:44 AM
    Nginx 1.13.x
    MariaDB 5.5
    bug fixed just now heh Beta Branch - wp super cache fix centmin.sh menu option 22 for 123.09beta01 | Centmin Mod Community

    just disable them manually and you should be good to go
    Code (Text):
    cd /home/nginx/domains/yourdomain.com/public
    wp plugin deactivate wp-super-cache --uninstall --allow-root
    wp plugin deactivate wp-super-cache-clear-cache-menu --uninstall --allow-root
    

    not really new just evolving feature as it is 123.09beta01 .. but yeah wouldn't be as on top of things as Easyengine for wordpress as Easyengine/rtcamp have 37+ staff members versus Centmin Mod has alot more features going on with it and I am only one person doing this in my free time (which is lacking right now due to my mother heart surgery & care right now)

    fyi, here's centmin.sh menu option 22 test site at wordpress7.centminmod.com - Centmin Mod LEMP stack Wordpress Auto Installer on CentOS 7.0 which i setup for demo'ing so you can see it working etc

    to update 123.09beta01 with fixed code just use centmin.sh menu option 23 submenu option 2 to use git to update your local centmin mod code

    Upgrading Centmin Mod Code to Latest Version



    Getting Started Guide step 19 outlines also how to keep Centmin Mod code updated or how to switch version branches.

    Centmin Mod LEMP stack's script code is constantly updated for improvements, bug fixes and security fixes so keeping the Centmin Mod code up to date is important. With Centmin Mod 1.2.3-eva2000.08) (123.08stable) and higher releases, a newly added centmin.sh menu option 23 allows much easier code updates and version branch swicthing via Git backed environment you can setup. For full details read the following links:
    Upgrading Centmin Mod involves 2 parts.
    1. Upgrading the actual Centmin Mod code outlined at Upgrade Centmin Mod. This is heart of Centmin Mod where the code is the engine that runs centmin.sh shell based menu and all the automation you're accustomed to. You can easily update within a Centmin Mod version branch or switch version branches via centmin.sh menu option 23 outlined here.
    2. Upgrade software that Centmin Mod installed or manages. For this part following outline at How to upgrade Centmin Mod software installed on your server.
    So essentially, you can upgrade from .07 to .08 in place, but not everything is upgraded as some things like server initial environment setup isn't changed i.e. how swap, tmp setup and allocation are created etc. The main parts from part 2 above are what in place upgrades do i.e. Nginx and PHP-FPM compilation and config/settings parameters and MariaDB version from 5.5 to 10.0.x. If you want the full environment changed including tmp and swap setup to .08's configuration, then you would need a fresh OS install and fresh .08 initial install. You can think of it like upgrading Windows 7 to Windows 8. An in place upgrade will upgrade code but won't change your computer environment from when you installed Windows 7 i.e. disk configuration and partition sizes won't change from when you initially installed Windows 7. Only way to change that would be fresh Windows 8 install.


    edit: guess wp super cache code is buggy as even wp-cli uninstall has issues
    Code (Text):
     wp plugin deactivate wp-super-cache --uninstall --allow-root
    
    PHP Warning:  include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    PHP Warning:  include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Success: Plugin 'wp-super-cache' deactivated.
    

    Code (Text):
    Uninstalling 'wp-super-cache'...
    PHP Fatal error:  Cannot redeclare wp_super_cache_text_domain() (previously declared in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache.php:68) in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 69
    Fatal error: Cannot redeclare wp_super_cache_text_domain() (previously declared in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache.php:68) in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache.php on line 69


    deactivating works with errors
    Code (Text):
    wp plugin deactivate wp-super-cache --allow-root               
    PHP Warning:  include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    PHP Warning:  include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Success: Plugin 'wp-super-cache' deactivated.

    uninstall on its own works with errors
    Code (Text):
    wp plugin uninstall wp-super-cache --allow-root             
    PHP Warning:  include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php): failed to open stream: No such file or directory in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    PHP Warning:  include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Warning: include(): Failed opening '/home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php' for inclusion (include_path='phar:///usr/bin/wp/vendor/phpunit/php-token-stream:phar:///usr/bin/wp/vendor/phpunit/phpunit-mock-objects:phar:///usr/bin/wp/vendor/phpunit/php-code-coverage:phar:///usr/bin/wp/vendor/phpunit/phpunit:phar:///usr/bin/wp/vendor/symfony/yaml:.:/usr/local/lib/php') in /home/nginx/domains/testdomain2.com/public/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 7
    Success: Uninstalled and deleted 'wp-super-cache' plugin.

    plugin status with wp-super-cache uninstalled
    Code (Text):
    wp plugin status --allow-root                 
    7 installed plugins:
      I akismet                         3.1.10
      A cache-enabler                   1.0.9
      A cdn-enabler                     1.0.2
      A disable-xml-rpc                 1.0.1
      A optimus                         1.4.5
      A sucuri-scanner                  1.7.17
      I wp-super-cache-clear-cache-menu 1.3.1
    
    Legend: I = Inactive, A = Active


    ah i see what the bug is now, when wp-super-cache was incorrectly activated, it didn't setup
    /home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php file as keycdn cacher enabler is the default caching option, so the
    /home/nginx/domains/testdomain2.com/public/wp-content/wp-cache-config.php file is missing. Should be fixed in latest 123.09beta01 as a result of fixing the incorrectly activated wp-super-cache plugin :)
     
    Last edited: May 3, 2016