Learn about Centmin Mod LEMP Stack today
Become a Member

Poll What PHP Version do you use ?

Discussion in 'Introductions' started by eva2000, Dec 23, 2015.

  1. PHP 5.3

    0 vote(s)
    0.0%
  2. PHP 5.4

    2.2%
  3. PHP 5.5

    0 vote(s)
    0.0%
  4. PHP 5.6

    17.8%
  5. PHP 7.0

    24.4%
  6. PHP 7.1

    28.9%
  7. PHP 7.2

    28.9%
  8. PHP 7.3

    22.2%
  9. PHP 7.4

    0 vote(s)
    0.0%
Multiple votes are allowed.
  1. Andy

    Andy Active Member

    433
    66
    28
    Aug 6, 2014
    Ratings:
    +90
    Local Time:
    1:30 PM
    poll should have 7.3 version.
    I'm using 7.3.1 at the moment.
     
    • Like Like x 1
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,394
    320
    83
    May 31, 2014
    Ratings:
    +604
    Local Time:
    8:30 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    I am using 7.2.x
     
  3. ArisC

    ArisC Active Member

    119
    29
    28
    Jun 1, 2017
    Ratings:
    +57
    Local Time:
    8:30 PM
    Nginx Latest
    MariaDB Latest
    I'm using 7.2.X
     
  4. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,173
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,075
    Local Time:
    3:30 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Updated poll options with PHP 7.3 and 7.4 too ;)
     
    • Like Like x 3
  5. Atrix

    Atrix Premium Member Premium Member

    16
    4
    3
    Oct 7, 2018
    Ratings:
    +12
    Local Time:
    11:30 AM
    1.15.3
    MariaDB 10.1.36
    It depends on what I have to run unfortunately. 7.1 for Magento2, I have an old stack for an old site with tons of legacy software which isn't worth remaking at this time and it requires php 5. For wordpress I can get away with the latest php version usually.
     
  6. babyshark

    babyshark New Member

    13
    4
    3
    Jan 22, 2019
    Ratings:
    +5
    Local Time:
    12:30 AM
    php 7.2 :)

    7.3 not work with some old regular expression funtion (ex: simple_html_dom) :D
     
    • Informative Informative x 1
  7. JJC84

    JJC84 Active Member

    204
    83
    28
    Jan 31, 2018
    Ratings:
    +129
    Local Time:
    12:30 PM
    1.15.x
    10.1.x
    7.3 at the moment what's this 7.4? :geek:
     
  8. Revenge

    Revenge Active Member

    442
    92
    28
    Feb 21, 2016
    Portugal
    Ratings:
    +333
    Local Time:
    6:30 PM
    1.9.x
    10.1.x
    IPS 4.4 that will be released next month, will drop support for PHP 5.6 and PHP 7.0.
    PHP 7.1 will be the minimum now.

    Main reason is because they are EOL and also because they want to start to use the new fancy things.

    Also, the main focus of IPS 4.4 is performance. Making the loading times as fast as possible.

    Xenforo is doing the same thing or they still use the old PHP 5.x?
     
    Last edited: Jan 25, 2019
    • Informative Informative x 1
  9. eva2000

    eva2000 Administrator Staff Member

    41,060
    9,173
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,075
    Local Time:
    3:30 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Xenforo 2.1 is supporting PHP 7.3 and Xenforo 2.0 and below at least PHP 7.2 AFAIK :)
     
  10. Revenge

    Revenge Active Member

    442
    92
    28
    Feb 21, 2016
    Portugal
    Ratings:
    +333
    Local Time:
    6:30 PM
    1.9.x
    10.1.x
    Yes, ips 4.4 also supporting php 7.3. But what is the minimum version they support?
     
  11. rdan

    rdan Well-Known Member

    4,560
    1,092
    113
    May 25, 2014
    Ratings:
    +1,601
    Local Time:
    1:30 AM
    Mainline
    10.2
    • Informative Informative x 1
  12. Revenge

    Revenge Active Member

    442
    92
    28
    Feb 21, 2016
    Portugal
    Ratings:
    +333
    Local Time:
    6:30 PM
    1.9.x
    10.1.x
    Ya, but that way they need to code with the limitations of 5.6 in mind, to be compatible.
     
  13. rdan

    rdan Well-Known Member

    4,560
    1,092
    113
    May 25, 2014
    Ratings:
    +1,601
    Local Time:
    1:30 AM
    Mainline
    10.2
    I would be cool if Eva can do benchmark xf 2.1 and ipb 4.4.
     
  14. Revenge

    Revenge Active Member

    442
    92
    28
    Feb 21, 2016
    Portugal
    Ratings:
    +333
    Local Time:
    6:30 PM
    1.9.x
    10.1.x
    It need to be 2 installations on the same server, but ips 4.4 is not released yet.
    At least for ips, it needs to be properly configured, since most cache configurations comes disabled by default, because they need redis, etc etc.

    An example, if i enter invision site as a guest (they are using ips 4.4 beta), the TCP Request only takes 42 ms. Full page loads in less than half a second.

    [​IMG]
    Logged in, the TCP request will go to about 350ms.

    PS: They admitted they don't optimize their server like we do with centminmod ;) Basically they use default options for maximum stability.
    It could be a lot faster faster.
     
    • Informative Informative x 1