Learn about Centmin Mod LEMP Stack today
Become a Member

Poll What PHP Version do you use ?

Discussion in 'Introductions' started by eva2000, Dec 23, 2015.

  1. PHP 5.3

    0 vote(s)
    0.0%
  2. PHP 5.4

    2.1%
  3. PHP 5.5

    0 vote(s)
    0.0%
  4. PHP 5.6

    16.7%
  5. PHP 7.0

    22.9%
  6. PHP 7.1

    27.1%
  7. PHP 7.2

    27.1%
  8. PHP 7.3

    25.0%
  9. PHP 7.4

    2.1%
Multiple votes are allowed.
  1. eva2000

    eva2000 Administrator Staff Member

    47,853
    10,920
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,961
    Local Time:
    9:06 PM
    Nginx 1.21.x
    MariaDB 10.x
    As per FAQ item 5, Centmin Mod 123.08stable defaults to PHP 5.4.30 out of box. Centmin Mod 123.09beta01 defaults to PHP 5.5.30 out of the box.

    I am currently using PHP 5.6 branch with PHP 7.0 for testing.


    So which version of PHP do you use these days ?
     
  2. Sunka

    Sunka Well-Known Member

    1,148
    319
    83
    Oct 31, 2015
    Pula, Croatia
    Ratings:
    +517
    Local Time:
    12:06 PM
    Nginx 1.17.9
    MariaDB 10.3.22
    7.0.1 :sneaky:
     
  3. rdan

    rdan Premium Member Premium Member

    5,131
    1,279
    113
    May 25, 2014
    Ratings:
    +1,961
    Local Time:
    7:06 PM
    Mainline
    10.2
    7.x and will use the latest one always :).
     
  4. Matt Williams

    Matt Williams WordPress Fanatic

    497
    96
    28
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +143
    Local Time:
    6:06 AM
    latest
    10
    7.0.1
     
  5. Ahmad

    Ahmad Active Member

    209
    80
    28
    Apr 13, 2015
    Ratings:
    +150
    Local Time:
    12:06 PM
    1.9.9
    10.1.10
    7.0.1 & 5.6.16
     
  6. Matt

    Matt Well-Known Member

    889
    402
    63
    May 25, 2014
    Rotherham, UK
    Ratings:
    +643
    Local Time:
    11:06 AM
    1.5.15
    MariaDB 10.2
    5.5, 5.6 and 7 depending on the server.
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,963
    407
    83
    May 31, 2014
    Ratings:
    +788
    Local Time:
    1:06 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    5.6
     
  8. Matt Williams

    Matt Williams WordPress Fanatic

    497
    96
    28
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +143
    Local Time:
    6:06 AM
    latest
    10
    Actually, I have discovered a few themes and plugins still not compatible with php 7 so those sites are running 5.6.14
     
  9. eva2000

    eva2000 Administrator Staff Member

    47,853
    10,920
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,961
    Local Time:
    9:06 PM
    Nginx 1.21.x
    MariaDB 10.x
    Probably take at least another 3-4 months for developers to catch up with PHP 7 compatibility :)
     
  10. Matt Williams

    Matt Williams WordPress Fanatic

    497
    96
    28
    Nov 22, 2014
    Virginia, USA
    Ratings:
    +143
    Local Time:
    6:06 AM
    latest
    10
    well, they need to get with the program! lol!
     
  11. Xon

    Xon Active Member

    173
    61
    28
    Nov 16, 2015
    Ratings:
    +229
    Local Time:
    7:06 PM
    1.15.x
    MariaDB 10.3.x
    I'm still using php 5.6 on Spacebattles, but plan to migrate them to php7 after Christmas.

    Since I play with a load balanced web server setup (picking VMs for vCPU cores introduces "fun"), I'm able to incrementally roll out php version upgrades without disrupting site usability :D
     
    Last edited: Dec 24, 2015
  12. eva2000

    eva2000 Administrator Staff Member

    47,853
    10,920
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,961
    Local Time:
    9:06 PM
    Nginx 1.21.x
    MariaDB 10.x
    you mean load balanced web server front end ? yeah would be advantageous you can start with one web server cluster node update first and depending on load balancer give it a percentage weight in terms of allocated traffic % :)
     
  13. Xon

    Xon Active Member

    173
    61
    28
    Nov 16, 2015
    Ratings:
    +229
    Local Time:
    7:06 PM
    1.15.x
    MariaDB 10.3.x
    @eva2000 yup.

    It also lets me use Elastic Search clustering too, which is interesting and allows rolling updates to Elastic Search. Elastic Search is 'smart' so it doesn't need an explicit load balancer for the most part. :)
     
  14. MartinBratteng

    MartinBratteng New Member

    5
    3
    3
    Dec 29, 2015
    Ratings:
    +3
    Local Time:
    12:06 PM
    1.9.9
    10.0.23
    I'm always running the latest php versions to be up to speed on security patches and fixes, so that mean atm I'm running 7.0.1
     
  15. Sametto Chan

    Sametto Chan Member

    37
    11
    8
    Feb 26, 2017
    Kepler-186F
    Ratings:
    +13
    Local Time:
    8:06 PM
    10.2.9
    Poll Voted,

    PHP 7.0.16
     
  16. RB1

    RB1 Active Member

    292
    75
    28
    Nov 11, 2016
    California
    Ratings:
    +122
    Local Time:
    3:06 AM
    Nginx 1.21.x
    MariaDB 10.1.x
    7.0.16 but a lot of hosted software I use requires 5.6 because they claim ioncube isn't fully stable on 7.0 :(
     
  17. eva2000

    eva2000 Administrator Staff Member

    47,853
    10,920
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,961
    Local Time:
    9:06 PM
    Nginx 1.21.x
    MariaDB 10.x
    Yeah php modules are still catching up to PHP 7. Updated above poll for PHP 7.1 and 7.2 options too :)
     
  18. RB1

    RB1 Active Member

    292
    75
    28
    Nov 11, 2016
    California
    Ratings:
    +122
    Local Time:
    3:06 AM
    Nginx 1.21.x
    MariaDB 10.1.x
    It's taking too long :rage::rage::rage:
     
  19. Sametto Chan

    Sametto Chan Member

    37
    11
    8
    Feb 26, 2017
    Kepler-186F
    Ratings:
    +13
    Local Time:
    8:06 PM
    10.2.9
    PHP 7.1 and 7.2 doesn't work on XenForo for add-on would be give for error problem. I downgraded to 7.0 it's works.
     
  20. eva2000

    eva2000 Administrator Staff Member

    47,853
    10,920
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,961
    Local Time:
    9:06 PM
    Nginx 1.21.x
    MariaDB 10.x
    what addon ?