Learn about Centmin Mod LEMP Stack today
Register Now

Xenforo What is your pagespeed config on xenforo 2

Discussion in 'Forum software usage' started by Dnyan, May 6, 2018.

  1. Dnyan

    Dnyan Member

    65
    9
    8
    Sep 16, 2017
    Ratings:
    +11
    Local Time:
    7:10 AM
    1.17.2
    10.1.41
    Hello to all great members of Centminmod Community,

    I would like to see what pagespeed config you are using on xenforo 2.

    I tried a lot but had many issues like post reply box is blank (nothing loads)

    i saw its a more powerful thing but dont know, how to use it.

    i also dont have knowledge on configuring js and CSS optimization.

    so i always endup in unusable pageload which are good for reading but not for interacting.

    pagespeed makes a powerful boost in performance and i really like it.

    waiting to see some of xF2 best pagespeed conf here.

    I also request @eva2000 to share this forum pagespeed conf, as this community forum is also upgraded to xF2.

    Thank you
     
  2. eva2000

    eva2000 Administrator Staff Member

    41,719
    9,390
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,424
    Local Time:
    11:40 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Not many folks using Xenforo 2 + ngx_pagepseed, so you'd have to troubleshoot and tweak it yourself following these guides and info outlined below
    I'd start by using pagespeed Disallow to disable all Xenforo 2 css and js files and slowly just re-enable individual css and js files until you find problematic ones like what I did at PageSpeed - This forum's pagespeed.conf

    FYI, community.centminmod.com still using Xenforo 1.5.x
     
    • Like Like x 1