Want more timely Centmin Mod News Updates?
Become a Member

Weird issue with infinite redirect loop

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Jay Chen, Jun 16, 2018.

  1. Jay Chen

    Jay Chen Active Member

    135
    37
    28
    Sep 10, 2017
    Ratings:
    +73
    Local Time:
    10:55 AM
    So I setup wordpress via option 22 with redis full page cache on a new server.
    Vhost is created using the ip of the server, because I want to make sure everything is working before pointing the domain name to the new server.

    I didn't make any change to any of the configuration files.

    From time to time, I will get infinite redirect loop when I try to access the site, and this problem goes away after I delete the redis cache via nginx helper plugin.

    Has anyone ran into similar issue before?
     
  2. eva2000

    eva2000 Administrator Staff Member

    46,469
    10,555
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,388
    Local Time:
    12:55 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    non-https or https site ? and non-https to https redirecting ?

    Instead of IP, if you want to preview newdomain.com on new centminmod server without updating DNS, on Windows PC edit your windows HOSTS file at c:\Windows\System32\Drivers\etc\hosts (see guide at Modify your hosts file | Knowledge Center | Rackspace Hosting or install Hostman app HostsMan - abelhadigital.com which can manage the file too and allows easy dns flushing when you make changes to the hosts file.

    c:\Windows\System32\Drivers\etc\hosts contents to preview without DNS update
    Code:
    centminmodserver-ip-address newdomain.com
    to disable preview comment it out and flush dns for your system
    Code:
    #centminmodserver-ip-address newdomain.com
    Hostsman app to flush dns and edit the c:\Windows\System32\Drivers\etc\hosts file
     
  3. Jay Chen

    Jay Chen Active Member

    135
    37
    28
    Sep 10, 2017
    Ratings:
    +73
    Local Time:
    10:55 AM
    it is a non-http site, and there is no redirect being set up at all.

    I will try this when I get home. The redirect only seems to happen after I made changes to the theme files, and I always flush the cache after I made the change.