Want to subscribe to topics you're interested in?
Become a Member

WebPerf Webp Not working after configuring nginx

Discussion in 'Web Development & Web Performance' started by pheonis, Mar 22, 2019.

Tags:
  1. pheonis

    pheonis Member

    51
    3
    8
    Dec 21, 2018
    Ratings:
    +4
    Local Time:
    7:45 AM
    Hi,
    I am using Wordpress. Recently i found out the benefits of webp image format and wanted to use it in my wordpress website.
    I followed the steps mentioned here https://centminmod.com/webp/
    But the end at the end when i checked my website its still serving jpg. Is there anything need to be done after these steps?
    NOTE : I am also using cloudflare
    and how can i install and use optimise-images.sh script. I have no idea and there is no documentation i can found.
     
    Last edited: Mar 22, 2019
  2. eva2000

    eva2000 Administrator Staff Member

    39,816
    8,782
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,517
    Local Time:
    12:15 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    you won't see webp images until you make a copy of your jpg/png files which is webp format converted. The steps at https://centminmod.com/webp/ are just to tell nginx to server webp extension files if they exist to supported browsers. If no webp version of the image exists, it won't server webp.

    first sentence on the webp linked page links to optimise-images.sh docs via hyperlink = optimise-images.sh
    also discussed at https://community.centminmod.com/th...age-load-times-with-optimise-images-sh.11533/

    and in wordpress context at https://community.centminmod.com/th...-optimizer-wordpress-plugin.12573/#post-53333
     
  3. eva2000

    eva2000 Administrator Staff Member

    39,816
    8,782
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,517
    Local Time:
    12:15 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
..