Get the most out of your Centmin Mod LEMP stack
Become a Member

Web Server down & ERR_CONNECTION_REFUSED after i configured the emails Settings

Discussion in 'Domains, DNS, Email & SSL Certificates' started by pheonis, Mar 30, 2019.

  1. pheonis

    pheonis Member

    51
    3
    8
    Dec 21, 2018
    Ratings:
    +4
    Local Time:
    11:17 AM
    Hi @eva2000
    More recently i configured the email DNS and all settings so that i can receive transactional emails. I made that successfully.
    Now from past 2days. My websites showing ERR_CONNECTION_REFUSED error automatically and The website hosted with Cloudflare shows Error 521, Web server down.
    My web server is up and running but i face the above issue. Now i have to solve it by restarting my server. After i restart the issue goes away for some hours, And it again comes after 2,3 hours. I contacted my hosting provider, they said its a software issue, Can you please guide me or point me what can be the issue?
     
  2. pheonis

    pheonis Member

    51
    3
    8
    Dec 21, 2018
    Ratings:
    +4
    Local Time:
    11:17 AM
    There is an error showing in In the error log.
    Code:
    1650#1650: worker process 1651 exited on signal 9
     
  3. eva2000

    eva2000 Administrator Staff Member

    41,095
    9,195
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,106
    Local Time:
    3:47 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    If you use a reverse proxy like Cloudflare, Sucuri, or Incapsula in front of Centmin Mod Nginx, you need to setup nginx realip to be passed onto Nginx.

    See Getting Started Guide step 5 and setting correct real ip via nginx module config at http://centminmod.com/nginx_configure_cloudflare.html.

    If using Centmin Mod 123.09beta01 and newer, there's an added tools/csfcf.sh script to aid in this. Details at:
    You just need to setup a cronjob to run
    Code (Text):
    /usr/local/src/centminmod/tools/csfcf.sh auto

    and ensure your nginx.conf http{} context has the include file /usr/local/nginx/conf/cloudflare.conf and/or your individual nginx vhost's server contexts has the same include file
    Code (Text):
    http {
    map_hash_bucket_size 128;
    map_hash_max_size 2048;
    server_names_hash_bucket_size 128;
    server_names_hash_max_size 2048;
    
    limit_req_zone $binary_remote_addr zone=xwplogin:16m rate=40r/m;
    #limit_conn_zone $binary_remote_addr zone=xwpconlimit:16m;
    
    more_set_headers "Server: nginx centminmod";
    more_set_headers "X-Powered-By: centminmod";
    
    include /usr/local/nginx/conf/cloudflare.conf;
    include /usr/local/nginx/conf/maintenance.conf;
    include /usr/local/nginx/conf/vts_http.conf;
    include /usr/local/nginx/conf/geoip.conf;
    #include /usr/local/nginx/conf/pagespeedadmin.conf;
    include /usr/local/nginx/conf/fastcgi_param_https_map.conf;

    Then restart nginx server via command shortcut
    Code (Text):
    ngxrestart

    or
    Code (Text):
    service nginx restart