Discover Centmin Mod today
Register Now

Redis Warning message after installing Redis

Discussion in 'Other Centmin Mod Installed software' started by modder, Apr 26, 2020.

  1. modder

    modder Member

    40
    3
    8
    Dec 6, 2019
    Ratings:
    +6
    Local Time:
    10:49 PM
    Code (Text):
    _._
    _.-``__ ''-._
    _.-`` `. `_. ''-._ Redis 5.0.9 (00000000/0) 64 bit
    .-`` .-```. ```\/ _.,_ ''-._
    ( ' , .-` | `, ) Running in standalone mode
    |`-._`-...-` __...-.``-._|'` _.-'| Port: 6379
    | `-._ `._ / _.-' | PID: 520
    `-._ `-._ `-./ _.-' _.-'
    |`-._`-._ `-.__.-' _.-'_.-'|
    | `-._`-._ _.-'_.-' | Redis
    `-._ `-._`-.__.-'_.-' _.-'
    |`-._`-._ `-.__.-' _.-'_.-'|
    | `-._`-._ _.-'_.-' |
    `-._ `-._`-.__.-'_.-' _.-'
    `-._ `-.__.-' _.-'
    `-._ _.-'
    `-.__.-'
    
    520:M 26 Apr 2020 10:58:06.249 # Server initialized
    520:M 26 Apr 2020 10:58:06.249 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
    520:M 26 Apr 2020 10:58:06.250 * Ready to accept connections
    
    


    Should I do something or simply ignore it?
     
  2. eva2000

    eva2000 Administrator Staff Member

    44,781
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    12:49 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    How as redis installed ? Was it installed manually as outlined at Redis - Insight Guide - How to install Redis server on Centmin Mod LEMP stack as outlined
    What's output for these 2 commands?
    Code (Text):
    lscpu
    virt-what
    


    You can ignore the message if OpenVZ based VPS server as you do not have permissions to do systctl Kernel level changes anyway. KVM/Xen/VMWare and dedicated servers do have permissions so you can do the change
     
  3. modder

    modder Member

    40
    3
    8
    Dec 6, 2019
    Ratings:
    +6
    Local Time:
    10:49 PM
    I'm using vultr's $5 VPS.

    Yes I followed your instructions for installing Redis.

    Code (Text):
    yum -y install redis --enablerepo=remi --disableplugin=priorities
    chkconfig redis on
    service redis start


    I skipped the following 2 steps though because it's for CentOS 6 / order version of centmin?

    Code (Text):
    vm.overcommit_memory = 1

    Code (Text):
    sysctl -p


    Then I finished the following steps:

    Code (Text):
    maxmemory 100mb
    maxmemory-policy allkeys-lru
    maxmemory-samples 10


    Code (Text):
    appendonly yes


    Code (Text):
    #save 900 1
    #save 300 10
    #save 60 10000


    Code (Text):
    ervice redis restart



    The two commands' output follows:

    Code (Text):
    # lscpu
    Architecture:          x86_64
    CPU op-mode(s):        32-bit, 64-bit
    Byte Order:            Little Endian
    CPU(s):                1
    On-line CPU(s) list:   0
    Thread(s) per core:    1
    Core(s) per socket:    1
    Socket(s):             1
    NUMA node(s):          1
    Vendor ID:             GenuineIntel
    CPU family:            6
    Model:                 61
    Model name:            Intel Core Processor (Broadwell, no TSX, IBRS)
    Stepping:              2
    CPU MHz:               2399.982
    BogoMIPS:              4799.96
    Hypervisor vendor:     KVM
    Virtualization type:   full
    L1d cache:             32K
    L1i cache:             32K
    L2 cache:              4096K
    L3 cache:              16384K
    NUMA node0 CPU(s):     0
    Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl xtopology eagerfpu pni pclmulqdq ssse3 fma cx16 pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand hypervisor lahf_lm abm invpcid_single ssbd ibrs ibpb fsgsbase bmi1 avx2 smep bmi2 erms invpcid xsaveopt arat spec_ctrl


    Code (Text):
    # virt-what
    kvm
     
  4. modder

    modder Member

    40
    3
    8
    Dec 6, 2019
    Ratings:
    +6
    Local Time:
    10:49 PM
    I just did the following:

    upload_2020-4-26_14-50-39.png

    and then restarted redis service. How do I check whether the warning is gone?
     
  5. eva2000

    eva2000 Administrator Staff Member

    44,781
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    12:49 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    check the redis log in /var/log to see ensuring you pay attention to timestamp and current date as logs could show previous error message

    and yes KVM VPS so should apply fine. I will update message for CentOS 6 and CentOS 7
     
  6. modder

    modder Member

    40
    3
    8
    Dec 6, 2019
    Ratings:
    +6
    Local Time:
    10:49 PM
    Yes seems the warning message is gone!

    Code (Text):
    14198:M 26 Apr 2020 14:49:10.388 # Server initialized
    14198:M 26 Apr 2020 14:49:10.388 * Ready to accept connections
    14198:M 26 Apr 2020 14:56:32.969 # User requested shutdown...
    14198:M 26 Apr 2020 14:56:32.969 * Calling fsync() on the AOF file.
    14198:M 26 Apr 2020 14:56:32.969 * Removing the pid file.
    14198:M 26 Apr 2020 14:56:32.969 # Redis is now ready to exit, bye bye...
    14676:C 26 Apr 2020 14:56:32.983 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
    14676:C 26 Apr 2020 14:56:32.983 # Redis version=5.0.9, bits=64, commit=00000000, modified=0, pid=14676, just started
    14676:C 26 Apr 2020 14:56:32.983 # Configuration loaded
    14676:C 26 Apr 2020 14:56:32.983 * supervised by systemd, will signal readiness
                    _._                                                 
               _.-``__ ''-._                                             
          _.-``    `.  `_.  ''-._           Redis 5.0.9 (00000000/0) 64 bit
      .-`` .-```.  ```\/    _.,_ ''-._                                   
     (    '      ,       .-`  | `,    )     Running in standalone mode
     |`-._`-...-` __...-.``-._|'` _.-'|     Port: 6379
     |    `-._   `._    /     _.-'    |     PID: 14676
      `-._    `-._  `-./  _.-'    _.-'                                   
     |`-._`-._    `-.__.-'    _.-'_.-'|                                 
     |    `-._`-._        _.-'_.-'    |           http://redis.io       
      `-._    `-._`-.__.-'_.-'    _.-'                                   
     |`-._`-._    `-.__.-'    _.-'_.-'|                                 
     |    `-._`-._        _.-'_.-'    |                                 
      `-._    `-._`-.__.-'_.-'    _.-'                                   
          `-._    `-.__.-'    _.-'                                       
              `-._        _.-'                                           
                  `-.__.-'                                               
    
    14676:M 26 Apr 2020 14:56:32.986 # Server initialized
    14676:M 26 Apr 2020 14:56:32.986 * Ready to accept connections


    I just installed Xon's Redis Cache By Xon

    Do need to do anything?

    My forums should be much faster now? :)
     
  7. eva2000

    eva2000 Administrator Staff Member

    44,781
    10,212
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,828
    Local Time:
    12:49 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    see Xon's config.php settings you need to add

    Redis cache via Xenforo maybe improve performance between 1-10% as it still has to go through PHP so PHP overhead factors in. But would be more beneficial for large forums with millions of posts and visitors.