Want more timely Centmin Mod News Updates?
Become a Member

MariaDB User create with localhost not 127.0.0.1

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by hellenic, May 6, 2019.

  1. hellenic

    hellenic New Member

    20
    4
    3
    Mar 4, 2019
    Ratings:
    +5
    Local Time:
    9:12 PM
    1.15.9
    10.1.38
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.3
    • PHP Version Installed: 7.3.5
    • MariaDB MySQL Version Installed: 10.3.14
    • When was last time updated Centmin Mod code base ? : just now
    Hello.
    I used the command:
    /usr/local/src/centminmod/addons/mysqladmin_shell.sh setuserdb

    to create a user and a database and when i checked from phpmyadmin i can see that the hostname is set as localhost and not 127.0.0.1.

    If i am not wrong localhost is faster and in general better to use.
    Am i wrong?
    At my application config it uses 127.0.0.1 . The user i created is localhost so it doesn't work when i enable the skip name resolve option at mycnf.
    Should i change my application to localhost or change the user to 127.0.0.1?
    Thanks.
     
    Last edited: May 6, 2019
  2. eva2000

    eva2000 Administrator Staff Member

    40,620
    9,014
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,880
    Local Time:
    4:12 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    both the same so localhost is fine for your web app configs too
     
    • Like Like x 1
  3. hellenic

    hellenic New Member

    20
    4
    3
    Mar 4, 2019
    Ratings:
    +5
    Local Time:
    9:12 PM
    1.15.9
    10.1.38
    Ok i will try with both localhost. Thank you!