Learn about Centmin Mod LEMP Stack today
Become a Member

Upgrade Pip

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Itworx4me, Sep 7, 2019.

  1. Itworx4me

    Itworx4me Premium Member Premium Member

    191
    20
    18
    Mar 14, 2017
    Ratings:
    +32
    Local Time:
    11:28 PM
    Nginx 1.17.X
    MariaDB 10.3.X
    I get this warning when signing onto my server.

    What is the command to upgrade pip? The suggestion above is a little confusing to me.

    Thanks,
    Itworx4me
     
  2. negative

    negative Active Member

    325
    36
    28
    Apr 11, 2015
    Ratings:
    +74
    Local Time:
    9:28 AM
    1.9.10
    10.1.11
    Yes, same here
    Just run the "pip install --upgrade pip" command.

    However, i get this warning after upgrade completed

    Code (Text):
    DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support


    Need pyhton upgrade separately i though.
     
  3. eva2000

    eva2000 Administrator Staff Member

    41,349
    9,279
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,236
    Local Time:
    4:28 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    if you're on 123.09beta01 run cmupdate to update to latest 123.09beta01 code and then run centmin.sh once and exit. It should update pip automatically for you and if not then just run manually
    Code (Text):
    pip install --upgrade pip

    and ignore deprecation message
     
    • Like Like x 1
  4. EckyBrazzz

    EckyBrazzz Active Member

    587
    125
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +231
    Local Time:
    3:28 AM
    1.17.x
    10.3.x
    @negative How did you upgrade Python. Just like below? I did not use 3.8.0, still beta (like CMM beta, but keep fingers crossed with Python:))

    Code (Text):
    wget https://www.python.org/ftp/python/3.7.4/Python-3.7.4.tar.xz
    tar -xJf Python-3.7.4.tar.xz
    cd Python-3.7.4
    ./configure
    make && make install
    
     
  5. eva2000

    eva2000 Administrator Staff Member

    41,349
    9,279
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,236
    Local Time:
    4:28 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    i wouldn't source compile python that way, you can break python yum packages including YUM functionality

    also CentOS 7.7 will also have python yum package changes to account for too
     
    • Informative Informative x 1
  6. EckyBrazzz

    EckyBrazzz Active Member

    587
    125
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +231
    Local Time:
    3:28 AM
    1.17.x
    10.3.x
    Oops, gona try to fix it and do it the YUM way.... Thx @eva2000
     
  7. EckyBrazzz

    EckyBrazzz Active Member

    587
    125
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +231
    Local Time:
    3:28 AM
    1.17.x
    10.3.x
    Better wait for a while....2020
    Just reading:
     
    Last edited: Sep 11, 2019
    • Agree Agree x 1