Learn about Centmin Mod LEMP Stack today
Register Now

Update mysltuner script on Centminmod

Discussion in 'Other Centmin Mod Installed software' started by pamamolf, Sep 7, 2016.

  1. pamamolf

    pamamolf Well-Known Member

    2,724
    243
    63
    May 31, 2014
    Ratings:
    +434
    Local Time:
    7:49 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Hi :)

    Default installation is using 1.6.14 and the latest version is 1.6.18 :)

    Can we have the latest version as default?
    Maybe get always the latest version from github?

    Thanks
     
    • Like Like x 1
  2. eva2000

    eva2000 Administrator Staff Member

    30,170
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,138
    Local Time:
    2:49 PM
    Nginx 1.13.x
    MariaDB 5.5
    hehe updated at Have as default the Tunning primer script | Centmin Mod Community

    updating is as easy as removing existing /root/mysqltuner.pl and downloading latest one
    Code (Text):
    rm /root/mysqltuner.pl
    wget -O /root/mysqltuner.pl https://centminmod.com/centminmodparts/mysqltuner/mysqltuner.pl
    


    example run of mysqltuner.pl 1.6.18
    Code (Text):
    /root/mysqltuner.pl  
     >>  MySQLTuner 1.6.18 - Major Hayden <major@mhtx.net>
     >>  Bug reports, feature requests, and downloads at http://mysqltuner.com/
     >>  Modified by George Liu (eva2000) at http://vbtechsupport.com/
     >>  Run with '--help' for additional options and output filtering
    
    [--] Skipped version check for MySQLTuner script
    [OK] Currently running supported MySQL version 10.1.17-MariaDB
    [OK] Operating on 64-bit architecture
    
    -------- Storage Engine Statistics -----------------------------------------------------------------
    [--] Status: +Aria +CSV +InnoDB +MEMORY +MRG_MyISAM +MyISAM +PERFORMANCE_SCHEMA +SEQUENCE
    [!!] InnoDB is enabled but isn't being used
    [OK] Total fragmented tables: 0
    
    -------- Security Recommendations ------------------------------------------------------------------
    [OK] There are no anonymous accounts for any database users
    [OK] All database users have passwords assigned
    [!!] There is no basic password file list!
    
    -------- CVE Security Recommendations --------------------------------------------------------------
    [--] Skipped due to --cvefile option undefined
    
    -------- Performance Metrics -----------------------------------------------------------------------
    [--] Up for: 13m 6s (151 q [0.192 qps], 55 conn, TX: 198K, RX: 15K)
    [--] Reads / Writes: 100% / 0%
    [--] Binary logging is disabled
    [--] Physical Memory     : 996.1M
    [--] Max MySQL memory    : 386.7M
    [--] Other process memory: 127.0M
    [--] Total buffers: 152.0M global + 801.0K per thread (300 max threads)
    [--] P_S Max memory usage: 0B
    [--] Galera GCache Max memory usage: 0B
    [OK] Maximum reached memory usage: 152.8M (15.34% of installed RAM)
    [OK] Maximum possible memory usage: 386.7M (38.82% of installed RAM)
    [OK] Overall possible memory usage with other process is compatible with memory available
    [OK] Slow queries: 0% (0/151)
    [OK] Highest usage of available connections: 0% (1/300)
    [OK] Aborted connections: 1.82%  (1/55)
    [!!] name resolution is active : a reverse name resolution is made for each new connection and can reduce performance
    [!!] Query cache efficiency: 0.0% (0 cached / 78 selects)
    [OK] Query cache prunes per day: 0
    [OK] Sorts requiring temporary tables: 0% (0 temp sorts / 4 sorts)
    [OK] No joins without indexes
    [OK] Temporary tables created on disk: 3% (1 on disk / 32 total)
    [OK] Thread cache hit rate: 98% (1 created / 55 connections)
    [OK] Table cache hit rate: 92% (82 open / 89 opened)
    [OK] Open file limit used: 0% (59/8K)
    [OK] Table locks acquired immediately: 100% (29 immediate / 29 locks)
    
    -------- Performance schema ------------------------------------------------------------------------
    [--] Performance schema is disabled.
    
    -------- ThreadPool Metrics ------------------------------------------------------------------------
    [--] ThreadPool stat is enabled.
    [--] Thread Pool Size: 1 thread(s).
    [--] Using default value is good enough for your version (10.1.17-MariaDB)
    
    -------- MyISAM Metrics ----------------------------------------------------------------------------
    [!!] Key buffer used: 18.3% (6M used / 33M cache)
    [OK] Key buffer size / total MyISAM indexes: 32.0M/124.0K
    [!!] Read Key buffer hit rate: 90.0% (20 cached / 2 reads)
    
    -------- AriaDB Metrics ----------------------------------------------------------------------------
    [--] AriaDB is enabled.
    [OK] Aria pagecache size / total Aria indexes: 8.0M/1B
    [OK] Aria pagecache hit rate: 98.4% (61 cached / 1 reads)
    
    -------- InnoDB Metrics ----------------------------------------------------------------------------
    [--] InnoDB is disabled.
    [!!] InnoDB Storage engine is disabled. InnoDB is the default storage engine
    
    -------- TokuDB Metrics ----------------------------------------------------------------------------
    [--] TokuDB is disabled.
    
    -------- Galera Metrics ----------------------------------------------------------------------------
    [--] Galera is disabled.
    
    -------- Replication Metrics -----------------------------------------------------------------------
    [--] Galera Synchronous replication: NO
    [--] No replication slave(s) for this server.
    [--] This is a standalone server.
    
    -------- Recommendations ---------------------------------------------------------------------------
    General recommendations:
        Add skip-innodb to MySQL configuration to disable InnoDB
        MySQL started within last 24 hours - recommendations may be inaccurate
        Configure your accounts with ip or subnets only, then update your configuration with skip-name-resolve=1
    Variables to adjust:
        query_cache_limit (> 512K, or use smaller result sets)
     
  3. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
    Why is mysqltuner showing InnoDB as being disabled? Is that normal?
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,170
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,138
    Local Time:
    2:49 PM
    Nginx 1.13.x
    MariaDB 5.5
    for your output or you mean above example ?
     
  5. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
    Either. My stock setup is showing basically the same thing as what you have above.
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,170
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,138
    Local Time:
    2:49 PM
    Nginx 1.13.x
    MariaDB 5.5
    You using Centmin Mod provided version or official ? I probably need to update my version hehe
     
    • Agree Agree x 1
  7. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
    CMM provided version. I'm running a stock 09 setup and ran mysqltuner.pl in the root dir.
     
  8. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
  9. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
    Updated mine, still showing

    Code:
    -------- InnoDB Metrics ----------------------------------------------------------------------------
    [--] InnoDB is disabled.
    [!!] InnoDB Storage engine is disabled. InnoDB is the default storage engine
    
    "InnoDB is enabled but isn't being used"! | DigitalOcean
     
  10. eva2000

    eva2000 Administrator Staff Member

    30,170
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,138
    Local Time:
    2:49 PM
    Nginx 1.13.x
    MariaDB 5.5
    yeah double check if your database tables are InnoDB or MyISAM
     
  11. Jimmy

    Jimmy Premium Member Premium Member

    1,114
    247
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +596
    Local Time:
    12:49 AM
    1.13.x
    MariaDB 10.1.x
    At this point, I don't have any databases for sites.

    There are three showing up:
    Code:
    MariaDB [(none)]> show databases;
    +--------------------+
    | Database           |
    +--------------------+
    | information_schema |
    | mysql              |
    | performance_schema |
    +--------------------+
    3 rows in set (0.00 sec)
    Are any of those needed?
     
    Last edited: Apr 30, 2017
  12. eva2000

    eva2000 Administrator Staff Member

    30,170
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,138
    Local Time:
    2:49 PM
    Nginx 1.13.x
    MariaDB 5.5
    There's the issue than you only have your 3 system databases for mysql which are not InnoDB based and you need them as such for MySQL server to work. Once you add mysql databases that are InnoDB based, you will see it work InnoDB in use
     
    • Informative Informative x 1