Want to subscribe to topics you're interested in?
Become a Member

Beta Branch update centmin.sh menu option 22 autoptimize AO-Fallback in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Nov 16, 2020.

  1. eva2000

    eva2000 Administrator Staff Member

    45,633
    10,356
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,070
    Local Time:
    9:56 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    update centmin.sh menu option 22 autoptimize AO-Fallback in 123.09beta01

    - Ensure Autoptimize optimized CSS/JS have expire headers for browser level caching in the centmin.sh menu option 22 generated include file at /usr/local/nginx/conf/wpincludes/yourdomain.com/wpsecure_yourdomain.com.conf where yourdomain.com is the name of your wordpress site.
    - Update is for fresh centmin.sh menu option 22 installs.
    - Existing installs can manually add the expires header directive (expires 30d;)in their /usr/local/nginx/conf/wpincludes/yourdomain.com/wpsecure_yourdomain.com.conf files as outlined at expires not set on Autoptimize js/css requests

    Continue reading...

    123.09beta01 branch

     
  2. eva2000

    eva2000 Administrator Staff Member

    45,633
    10,356
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,070
    Local Time:
    9:56 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Existing wordpress sites created via centmin.sh menu option 22 also have a newly added tools/wp-cache-enabler-generate.sh tool introduced back at Beta Branch - update centmin.sh menu option 22 wpsecure include file template in 123.09beta01 and made for cache enabler cache plugin. But has an wpsecure generator option applicable to generated a new /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf with suffix in name = -generated-XXXXXX timestamped include file which you can use to compare with your existing one and then you can manually decide what to merge and keep yourself in the live /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf include file.
    - Existing users can on 123.09beta01 or newer can run cmupdate command to update locate Centmin Mod code and then run tools/wp-cache-enabler-generate.sh tool's wpsecure option to generate the newer wpsecure include file and it will also do a universal diff compare highlighting the differences between your existing wpsecure include file and your newly generated one with suffix in name.

    To run tools/wp-cache-enabler-generate.sh tool's wpsecure option in SSH session type:

    Code (Text):
    cd /usr/local/src/centminmod/tools
    ./wp-cache-enabler-generate.sh wpsecure yourdomain.com
     
    Last edited: Nov 16, 2020