Learn about Centmin Mod LEMP Stack today
Register Now

Beta Branch update centmin.sh menu option 10 for php 7.3 compatibility in 123.09b…

Discussion in 'Centmin Mod Github Commits' started by eva2000, Dec 21, 2018.

  1. eva2000

    eva2000 Administrator Staff Member

    41,645
    9,380
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,408
    Local Time:
    11:19 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    update centmin.sh menu option 10 for php 7.3 compatibility in 123.09beta01

    - patch support for memcache PHP 7.3.0 extension compatibility in 123.09beta01. memcache PHP extension now supported in PHP 7.3 branch
    - memcached PHP extension issue with PHP 7.3.0 and centos 6's lower autoconf <2.68 version. Update adds autoconf268 package support to memcached, redis, igbinary and geoip PHP extension routines when PHP 7.3+ is used with centos 6

    Continue reading...

    123.09beta01 branch
     
  2. Jimmy

    Jimmy Well-Known Member

    1,614
    343
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +862
    Local Time:
    9:19 AM
    1.15.x
    MariaDB 10.3.x
    @eva2000 on my new machine w/ php 7.2.15 I'm getting the memcached warning.

    Also tried to re-install as per the link below. Didn't want to remove the memcache.so file, as per your link below, because you said you got it working for 7.3 - which made me assume that version 7.2 was working.

    PHP 7.3.1, 7.2.14, 7.1.26 & 5.6.40 Security Releases

    Code:
    # php --ri memcached
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20170718/memcache.so' (tried: /usr/local/lib/php/extensions/no-debug-non-zts-20170718/memcache.so (/usr/local/lib/php/extensions/no-debug-non-zts-20170718/memcache.so: cannot open shared object file: No such file or directory), /usr/local/lib/php/extensions/no-debug-non-zts-20170718//usr/local/lib/php/extensions/no-debug-non-zts-20170718/memcache.so.so (/usr/local/lib/php/extensions/no-debug-non-zts-20170718//usr/local/lib/php/extensions/no-debug-non-zts-20170718/memcache.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
    
    memcached
    
    memcached support => enabled
    Version => 3.1.3
    libmemcached version => 1.0.16
    SASL support => yes
    Session support => yes
    igbinary support => no
    json support => yes
    msgpack support => no
    
    Directive => Local Value => Master Value
    memcached.sess_locking => On => On
    memcached.sess_lock_wait_min => 150 => 150
    memcached.sess_lock_wait_max => 150 => 150
    memcached.sess_lock_retries => 5 => 5
    memcached.sess_lock_expire => 0 => 0
    memcached.sess_binary_protocol => Off => Off
    memcached.sess_consistent_hash => Off => Off
    memcached.sess_consistent_hash_type => ketama => ketama
    memcached.sess_number_of_replicas => 0 => 0
    memcached.sess_randomize_replica_read => Off => Off
    memcached.sess_remove_failed_servers => Off => Off
    memcached.sess_server_failure_limit => 0 => 0
    memcached.sess_connect_timeout => 3000 => 3000
    memcached.sess_sasl_username => no value => no value
    memcached.sess_sasl_password => no value => no value
    memcached.sess_persistent => Off => Off
    memcached.sess_prefix => memc.sess.key. => memc.sess.key.
    memcached.sess_lock_wait => not set => not set
    memcached.sess_lock_max_wait => not set => not set
    memcached.compression_type => fastlz => fastlz
    memcached.compression_factor => 1.3 => 1.3
    memcached.compression_threshold => 2000 => 2000
    memcached.serializer => php => php
    memcached.store_retry_count => 2 => 2
    memcached.default_consistent_hash => Off => Off
    memcached.default_binary_protocol => Off => Off
    memcached.default_connect_timeout => 0 => 0
    
    
     
    Last edited: Mar 2, 2019
  3. Jimmy

    Jimmy Well-Known Member

    1,614
    343
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +862
    Local Time:
    9:19 AM
    1.15.x
    MariaDB 10.3.x
    Just checked my older server and that's running 7.2.15 w/ memcached and there isn't any warnings.