Want to subscribe to topics you're interested in?
Become a Member

Unable to install nginx 1.7.5 in beta script

Discussion in 'Bug Reports' started by Josephm, Sep 19, 2014.

Tags:
  1. Josephm

    Josephm Active Member

    126
    43
    28
    Aug 26, 2014
    Ratings:
    +45
    Local Time:
    11:29 AM
    1.9.5
    10.0.21
    Hi eva2000, I just used your latest beta script in my VMWare with fresh Centos 7. The strange thing is that all programs are successfully installed but not nginx, I tried to use option 4 but not work (not sure whether it's from new pagespeed version?). I attached my log for your reference:
    centminmod_nginx175failed

    Thanks ;)
     
  2. eva2000

    eva2000 Administrator Staff Member

    29,037
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:29 PM
    Nginx 1.13.x
    MariaDB 5.5
    seems the ngx_pagespeed 1.9.32.1 PSOL library download was not found or unavailable for download. In the past this has happened as Google download url blocked some folks IP addresses (i.e. those IP from country with international embargos or sanctions)

    from your provided install log

    Code:
    checking for getaddrinfo() ... found
    configuring additional modules
    adding module in ../ngx-fancyindex-ngx-fancyindex
    + ngx_http_fancyindex_module was configured
    adding module in ../ngx_cache_purge-2.1
    + ngx_http_cache_purge_module was configured
    adding module in ../headers-more-nginx-module-0.25
    + ngx_http_headers_more_filter_module was configured
    adding module in ../nginx-accesskey-2.0.3
    + ngx_http_accesskey_module was configured
    adding module in ../nginx-http-concat-master
    + ngx_http_concat_module was configured
    adding module in ../nginx-dav-ext-module-0.0.3
    + ngx_http_dav_ext_module was configured
    adding module in ../openresty-memc-nginx-module-1518da4
    + ngx_http_memc_module was configured
    adding module in ../openresty-srcache-nginx-module-ffa9ab7
    + ngx_http_srcache_filter_module was configured
    adding module in ../nginx-sticky-module-1.2.5
    + ngx_http_sticky_module was configured
    adding module in ../nginx_upstream_check_module-0.1.9
    checking for ngx_http_upstream_check_module ... found
    + ngx_http_upstream_check_module was configured
    adding module in ../ngx_pagespeed-release-1.9.32.1-beta
    ngx_pagespeed: pagespeed optimization library not found:
    
       You need to separately download the pagespeed library:
    
         $ cd /path/to/ngx_pagespeed
         $ wget https://dl.google.com/dl/page-speed/psol/1.9.32.1.tar.gz
         $ tar -xzvf 1.9.32.1.tar.gz # expands to psol/
    
       Or see the installation instructions:
         https://github.com/pagespeed/ngx_pagespeed#how-to-build
    make: *** No rule to make target `build', needed by `default'.  Stop.
    You can confirm if this is the case of being blocked by manually downloading PSOL libary into /svr-setup/ngx_pagespeed-release-1.9.32.1-beta directory

    Code:
    cd /svr-setup/ngx_pagespeed-release-1.9.32.1-beta
    wget https://dl.google.com/dl/page-speed/psol/1.9.32.1.tar.gz
    If that manual download works, then you might have run into temporary case that https://dl.google.com/dl/page-speed/psol/1.9.32.1.tar.gz was not available so try again with fresh install test

    edit: just tested this on a test server and it worked fine too

     
    • Like Like x 1