Learn about Centmin Mod LEMP Stack today
Become a Member

[Solved] Unable to install FFMPEG PHP extension

Discussion in 'Bug Reports' started by Guneyd, Sep 30, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    Code:
    patching file ffmpeg_movie.c
    patch unexpectedly ends in middle of line
    Hunk #3 succeeded at 357 with fuzz 1.
    Code:
    checking for ffmpeg support... yes, shared
    checking whether to force gd support in ffmpeg-php... no
    checking for ffmpeg headers...
    configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option
    make: *** No targets specified and no makefile found.  Stop.
    make: *** No rule to make target `install'.  Stop.
    
    could be ffmpeg php extension and php 5.6 issue ? or centos 7 repos not having same packages that centos 6 has
     
  2. Matt

    Matt Moderator Staff Member

    689
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +442
    Local Time:
    8:36 AM
    1.7.1
    MariaDB 10
    ffmpeg doesn't install via yum
     
  3. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    tested on CentOS 6.6 + PHP 5.6.11 centmin.sh menu option 19 works fine so could be CentOS 7 specific

    Code:
    --------------------------------------------------------
    Centmin Mod 1.2.3-eva2000.08 - http://centminmod.com
    --------------------------------------------------------
                       Centmin Mod Menu                  
    --------------------------------------------------------
    1).  Centmin Install
    2).  Add Nginx vhost domain
    3).  NSD setup domain name DNS
    4).  Nginx Upgrade / Downgrade
    5).  PHP Upgrade / Downgrade
    6).  XCache Re-install
    7).  APC Cache Re-install
    8).  XCache Install
    9).  APC Cache Install
    10). Memcached Server Re-install
    11). MariaDB 5.2/5.5 & 10.x Upgrade Sub-Menu
    12). Zend OpCache Install/Re-install
    13). Install ioping.sh vbtechsupport.com/1239/
    14). SELinux disable
    15). Install/Reinstall ImagicK PHP Extension
    16). Change SSHD Port Number
    17). Multi-thread compression: pigz,pbzip2,lbzip2...
    18). Suhosin PHP Extension install
    19). Install FFMPEG and FFMPEG PHP Extension
    20). NSD Re-install
    21). Update - Nginx + PHP-FPM + Siege
    22). Add Wordpress Nginx vhost + WP Super Cache
    23). Update Centmin Mod Code Base
    24). Exit
    --------------------------------------------------------
    Enter option [ 1 - 24 ] 19
    --------------------------------------------------------
    FFMPEG install starting...
    Package matching re2c-0.13.5-1.el6.x86_64 already installed. Checking for update.
    Package libvpx-1.3.0-5.el6_5.x86_64 already installed and latest version
    Package libvpx-devel-1.3.0-5.el6_5.x86_64 already installed and latest version
    Error: ffmpeg-php-0.6.0.tbz2 not found!!! Downloading now......
    --2015-07-15 16:12:15--  http://downloads.sourceforge.net/project/ffmpeg-php/ffmpeg-php/0.6.0/ffmpeg-php-0.6.0.tbz2?use_mirror=aarnet
    Resolving downloads.sourceforge.net... 216.34.181.59
    Connecting to downloads.sourceforge.net|216.34.181.59|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://iweb.dl.sourceforge.net/project/ffmpeg-php/ffmpeg-php/0.6.0/ffmpeg-php-0.6.0.tbz2 [following]
    --2015-07-15 16:12:15--  http://iweb.dl.sourceforge.net/project/ffmpeg-php/ffmpeg-php/0.6.0/ffmpeg-php-0.6.0.tbz2
    Resolving iweb.dl.sourceforge.net... 70.38.0.134, 2607:f748:10:12::5f:2
    Connecting to iweb.dl.sourceforge.net|70.38.0.134|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 275557 (269K) [application/octet-stream]
    Saving to: `ffmpeg-php-0.6.0.tbz2'
    
         0K .......... .......... .......... .......... .......... 18%  231K 1s
        50K .......... .......... .......... .......... .......... 37%  345K 1s
       100K .......... .......... .......... .......... .......... 55% 78.9K 1s
       150K .......... .......... .......... .......... .......... 74%  402M 0s
       200K .......... .......... .......... .......... .......... 92%  231K 0s
       250K .......... .........                                  100% 39.1K=1.7s
    
    2015-07-15 16:12:17 (158 KB/s) - `ffmpeg-php-0.6.0.tbz2' saved [275557/275557]
    
    Code:
    make: *** No rule to make target `clean'.  Stop.
    Configuring for:
    PHP Api Version:         20131106
    Zend Module Api No:      20131226
    Zend Extension Api No:   220131226
    Configuring for:
    PHP Api Version:         20131106
    Zend Module Api No:      20131226
    Zend Extension Api No:   220131226
    --2015-07-15 16:12:18--  https://gist.github.com/centminmod/b3cd8785bed2a87c7ba8/raw/ffmpeg.patch
    Resolving gist.github.com... 192.30.252.141
    Connecting to gist.github.com|192.30.252.141|:443... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: https://gist.githubusercontent.com/centminmod/b3cd8785bed2a87c7ba8/raw/ffmpeg.patch [following]
    --2015-07-15 16:12:19--  https://gist.githubusercontent.com/centminmod/b3cd8785bed2a87c7ba8/raw/ffmpeg.patch
    Resolving gist.githubusercontent.com... 23.235.47.133
    Connecting to gist.githubusercontent.com|23.235.47.133|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1156 (1.1K) [text/plain]
    Saving to: `ffmpeg.patch'
    
         0K .                                                     100%  387M=0s
    
    2015-07-15 16:12:19 (387 MB/s) - `ffmpeg.patch' saved [1156/1156]
    
    Code:
    patching file ffmpeg_movie.c
    patch unexpectedly ends in middle of line
    Hunk #3 succeeded at 357 with fuzz 1.
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for a sed that does not truncate output... /bin/sed
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether ccache gcc accepts -g... yes
    checking for ccache gcc option to accept ISO C89... none needed
    checking how to run the C preprocessor... ccache gcc -E
    checking for icc... no
    checking for suncc... no
    checking whether ccache gcc and cc understand -c and -o together... yes
    checking for system library directory... lib
    checking if compiler supports -R... no
    checking if compiler supports -Wl,-rpath,... yes
    checking build system type... x86_64-unknown-linux-gnu
    checking host system type... x86_64-unknown-linux-gnu
    checking target system type... x86_64-unknown-linux-gnu
    checking for PHP prefix... /usr/local
    checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
    checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20131226
    checking for PHP installed headers prefix... /usr/local/include/php
    checking if debug is enabled... no
    checking if zts is enabled... no
    checking for re2c... re2c
    checking for re2c version... 0.14.3 (ok)
    checking for gawk... gawk
    checking for ffmpeg support... yes, shared
    checking whether to force gd support in ffmpeg-php... no
    checking for ffmpeg headers... ...found in /usr/include/libavcodec
    checking for ffmpeg libavcodec.so... ...found in /usr/lib64
    checking for ffmpeg swscale support... yes
    checking for ld used by ccache gcc... /usr/bin/ld
    checking if the linker (/usr/bin/ld) is GNU ld... yes
    checking for /usr/bin/ld option to reload object files... -r
    checking for BSD-compatible nm... /usr/bin/nm -B
    checking whether ln -s works... yes
    checking how to recognize dependent libraries... pass_all
    checking for ANSI C header files... yes
    checking for sys/types.h... yes
    checking for sys/stat.h... yes
    checking for stdlib.h... yes
    checking for string.h... yes
    checking for memory.h... yes
    checking for strings.h... yes
    checking for inttypes.h... yes
    checking for stdint.h... yes
    checking for unistd.h... yes
    checking dlfcn.h usability... yes
    checking dlfcn.h presence... yes
    checking for dlfcn.h... yes
    checking the maximum length of command line arguments... 1966080
    checking command to parse /usr/bin/nm -B output from ccache gcc object... ok
    checking for objdir... .libs
    checking for ar... ar
    checking for ranlib... ranlib
    checking for strip... strip
    checking if ccache gcc supports -fno-rtti -fno-exceptions... no
    checking for ccache gcc option to produce PIC... -fPIC
    checking if ccache gcc PIC flag -fPIC works... yes
    checking if ccache gcc static flag -static works... no
    checking if ccache gcc supports -c -o file.o... yes
    checking whether the ccache gcc linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
    checking whether -lc should be explicitly linked in... no
    checking dynamic linker characteristics... GNU/Linux ld.so
    checking how to hardcode library paths into programs... immediate
    checking whether stripping libraries is possible... yes
    checking if libtool supports shared libraries... yes
    checking whether to build shared libraries... yes
    checking whether to build static libraries... no
    
    Code:
    creating libtool
    appending configuration tag "CXX" to libtool
    checking whether the ccache g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
    checking for ccache g++ option to produce PIC...
    checking if ccache g++ static flag  works... yes
    checking if ccache g++ supports -c -o file.o... yes
    checking whether the ccache g++ linker (/usr/bin/ld -m elf_x86_64) supports shared libraries... yes
    checking dynamic linker characteristics... GNU/Linux ld.so
    (cached) (cached) checking how to hardcode library paths into programs... unsupported
    configure: creating ./config.status
    config.status: creating config.h
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c -o ffmpeg-php.lo
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_movie.c -o ffmpeg_movie.lo
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_frame.c -o ffmpeg_frame.lo
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_errorhandler.c -o ffmpeg_errorhandler.lo
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_tools.c -o ffmpeg_tools.lo
    mkdir .libs
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/ -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c  -fPIC -DPIC -o .libs/ffmpeg-php.o
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/ -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_movie.c  -fPIC -DPIC -o .libs/ffmpeg_movie.o
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/ -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_tools.c  -fPIC -DPIC -o .libs/ffmpeg_tools.o
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/ -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_frame.c  -fPIC -DPIC -o .libs/ffmpeg_frame.o
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg_tools.c: In function 'ffmpeg_img_convert':
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg_tools.c:79: warning: passing argument 2 of 'sws_scale' from incompatible pointer type
    /usr/include/libswscale/swscale.h:195: note: expected 'const uint8_t * const*' but argument is of type 'uint8_t **'
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/ -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg_errorhandler.c  -fPIC -DPIC -o .libs/ffmpeg_errorhandler.o
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg_movie.c: In function '_php_read_av_frame':
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg_movie.c:1215: warning: 'avcodec_decode_video' is deprecated (declared at /usr/include/libavcodec/avcodec.h:3452)
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=link ccache gcc -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/libavcodec/ -I/usr/include/libavformat/ -I/usr/include/libavutil/ -I/usr/include/libswscale/ -I/usr/include/libavfilter/ -I/usr/include/libavdevice/  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -o ffmpeg.la -export-dynamic -avoid-version -prefer-pic -module -rpath /svr-setup/ffmpeg-php-0.6.0/modules  ffmpeg-php.lo ffmpeg_movie.lo ffmpeg_frame.lo ffmpeg_errorhandler.lo ffmpeg_tools.lo -Wl,-rpath,/usr/lib64 -L/usr/lib64 -lswscale -Wl,-rpath,/usr/lib64 -L/usr/lib64 -lavformat -Wl,-rpath,/usr/lib64 -L/usr/lib64 -lavcodec
    ccache gcc -shared  .libs/ffmpeg-php.o .libs/ffmpeg_movie.o .libs/ffmpeg_frame.o .libs/ffmpeg_errorhandler.o .libs/ffmpeg_tools.o  -L/usr/lib64 -lswscale -lavformat -lavcodec  -Wl,-rpath -Wl,/usr/lib64 -Wl,-rpath -Wl,/usr/lib64 -Wl,-rpath -Wl,/usr/lib64 -Wl,-soname -Wl,ffmpeg.so -o .libs/ffmpeg.so
    creating ffmpeg.la
    (cd .libs && rm -f ffmpeg.la && ln -s ../ffmpeg.la ffmpeg.la)
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=install cp ./ffmpeg.la /svr-setup/ffmpeg-php-0.6.0/modules
    cp ./.libs/ffmpeg.so /svr-setup/ffmpeg-php-0.6.0/modules/ffmpeg.so
    cp ./.libs/ffmpeg.lai /svr-setup/ffmpeg-php-0.6.0/modules/ffmpeg.la
    PATH="$PATH:/sbin" ldconfig -n /svr-setup/ffmpeg-php-0.6.0/modules
    ----------------------------------------------------------------------
    Libraries have been installed in:
       /svr-setup/ffmpeg-php-0.6.0/modules
    
    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the `-LLIBDIR'
    flag during linking and do at least one of the following:
       - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
         during execution
       - add LIBDIR to the `LD_RUN_PATH' environment variable
         during linking
       - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
       - have your system administrator add LIBDIR to `/etc/ld.so.conf'
    
    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ----------------------------------------------------------------------
    
    Build complete.
    Don't forget to run 'make test'.
    
    Code:
    Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20131226/
    
    FFMPEG PHP extension installed..
    restarting php-fpm service ...
    
    service php-fpm restart
    Gracefully shutting down php-fpm . done
    Starting php-fpm  done
    
    Code:
    check phpinfo for FFMPEG PHP Extension...
    
    ffmpeg
    ffmpeg-php version => 0.6.0-svn
    ffmpeg-php built on => Jul 15 2015 16:12:21
    ffmpeg-php gd support  => disabled
    ffmpeg libavcodec version => Lavc52.72.2
    ffmpeg libavformat version => Lavf52.64.2
    ffmpeg swscaler version => SwS0.11.0
    ffmpeg.allow_persistent => 0 => 0
    ffmpeg.show_warnings => 0 => 0
    
    check FFMPEG
    
    FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
      built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)
      configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab
      libavutil     50.15. 1 / 50.15. 1
      libavcodec    52.72. 2 / 52.72. 2
      libavformat   52.64. 2 / 52.64. 2
      libavdevice   52. 2. 0 / 52. 2. 0
      libavfilter    1.19. 0 /  1.19. 0
      libswscale     0.11. 0 /  0.11. 0
      libpostproc   51. 2. 0 / 51. 2. 0
    Use -h to get full help or, even better, run 'man ffmpeg'
    Hyper fast Audio and Video encoder
    usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...
     
  4. Matt

    Matt Moderator Staff Member

    689
    319
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +442
    Local Time:
    8:36 AM
    1.7.1
    MariaDB 10
    Yeah, I think it's CentOS7 specific. Doesn't look like it's available in any of the yum repos.
     
  5. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    Guess it's package hunting time.. or building my own i.e. re2c 0.14, hiredis 0.13 and curl 7.43

    on CentOS 6
    Code:
    yum list -q ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel
    Installed Packages
    amrnb-devel.x86_64                7.0.0.2-1.el6.rf                 @rpmforge
    amrwb-devel.x86_64                7.0.0.3-1.el6.rf                 @rpmforge
    faad2.x86_64                      2.7-1.el6.rf                     @rpmforge
    ffmpeg.x86_64                     0.6.5-1.el6.rf                   @rpmforge
    ffmpeg-devel.x86_64               0.6.5-1.el6.rf                   @rpmforge
    flvtool2.noarch                   1.0.6-1.el6.rf                   @rpmforge
    lame.x86_64                       3.99.5-1.el6.rf                  @rpmforge
    libid3tag.x86_64                  0.15.1b-11.el6                   @base 
    libogg.x86_64                     2:1.1.4-2.1.el6                  @base 
    libvorbis.x86_64                  1:1.2.3-4.el6_2.1                @base 
    libvorbis-devel.x86_64            1:1.2.3-4.el6_2.1                @base 
    libvorbis-devel-docs.noarch       1:1.2.3-4.el6_2.1                @base 
    libvpx.x86_64                     1.3.0-5.el6_5                    @base 
    libvpx-devel.x86_64               1.3.0-5.el6_5                    @base 
    libwmf.x86_64                     0.2.8.4-23.el6                   @base 
    mencoder.x86_64                   1.0-0.48.svn20100703.el6.rf      @rpmforge
    mplayer.x86_64                    1.0-0.48.svn20100703.el6.rf      @rpmforge
    nasm.x86_64                       2.07-7.el6                       @base 
    re2c.x86_64                       0.14.3-1                         installed
    ruby.x86_64                       1.8.7.374-4.el6_6                @updates
    ruby-devel.x86_64                 1.8.7.374-4.el6_6                @updates
    ruby-libs.x86_64                  1.8.7.374-4.el6_6                @updates
    vorbis-tools.x86_64               1:1.2.0-7.el6                    @base 
    vorbisgain.x86_64                 0.36-2.2.el6.rf                  @rpmforge
    xvidcore.x86_64                   1.2.2-1.el6.rf                   @rpmforge
    xvidcore-devel.x86_64             1.2.2-1.el6.rf                   @rpmforge
    yasm.x86_64                       1.2.0-1.el6                      @epel 
    
    
    on CentOS 7 seems rpmforge doesn't have the packages in their el7 repo
    Code:
    yum list -q ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel
    Installed Packages
    libvpx.x86_64                                                  1.3.0-5.el7_0                                         @base 
    libvpx-devel.x86_64                                            1.3.0-5.el7_0                                         @base 
    re2c.x86_64                                                    0.14.3-1                                              installed
    Available Packages
    libid3tag.x86_64                                               0.15.1b-17.el7                                        base  
    libogg.x86_64                                                  2:1.3.0-7.el7                                         base  
    libvorbis.x86_64                                               1:1.3.3-8.el7                                         base  
    libvorbis-devel.x86_64                                         1:1.3.3-8.el7                                         base  
    libvorbis-devel-docs.noarch                                    1:1.3.3-8.el7                                         base  
    libwmf.x86_64                                                  0.2.8.4-39.el7                                        base  
    mingw32-libvorbis.noarch                                       1.3.4-1.el7                                           epel  
    mingw64-libvorbis.noarch                                       1.3.4-1.el7                                           epel  
    nasm.x86_64                                                    2.10.07-7.el7                                         base  
    ruby.x86_64                                                    2.0.0.598-25.el7_1                                    updates
    ruby-devel.x86_64                                              2.0.0.598-25.el7_1                                    updates
    ruby-libs.x86_64                                               2.0.0.598-25.el7_1                                    updates
    vorbis-tools.x86_64                                            1:1.4.0-12.el7                                        base  
    yasm.x86_64                                                    1.2.0-4.el7                                           epel   
    double check all 3rd party yum repositories installed by Centmin Mod for available packages

    yup nothing
    Code:
    yum -q list available --disablerepo=* --enablerepo=epel,epel-testing,remi,remi-test,rpmforge --disableplugin=priorities | egrep 'ffmpeg|ffmpeg-devel|mplayer|mencoder|flvtool2|re2c|yasm|nasm|libvpx|libvpx-devel|amrnb-devel|amrwb-devel|libid3tag|libvorbis-devel|lame|libogg|libwmf|xvidcore|xvidcore-devel|facc|faad2|a52decoder|*vorbis*|ruby|ruby-libs|ruby-devel' | egrep -v 'rubygem|twolame|ruby-|'
     
    Last edited: Jul 16, 2015
  6. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    @Matt maybe nux-desktop-release YUM repo My RPM repositories has what you want for CentOS 7 CentOS • View topic - ffmpeg & x264 & codecs installation problem [SOLVED] never used it myself so testing on local virtualbox first

    The Centmin Mod way of setting up 3rd party repos with yum priorities set at 90

    Code:
    rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-1.el7.nux.noarch.rpm
    
    Code:
    cat /etc/yum.repos.d/nux-dextop.repo
    
    [nux-dextop]
    name=Nux.Ro RPMs for general desktop use
    baseurl=http://li.nux.ro/download/nux/dextop/el7/$basearch/ http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    protect=0
    
    [nux-dextop-testing]
    name=Nux.Ro RPMs for general desktop use - testing
    baseurl=http://li.nux.ro/download/nux/dextop-testing/el6/$basearch/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    protect=0
    
    Code:
    cp -a /etc/yum.repos.d/nux-dextop.repo  /etc/yum.repos.d/nux-dextop.repo.OLD
    
    Code:
    ex -s /etc/yum.repos.d/nux-dextop.repo << EOF
    :/\[nux-dextop/ , /gpgkey/
    :a
    priority=90
    .
    :w
    :/\[nux-dextop-testing/ , /gpgkey/
    :a
    priority=90
    .
    :w
    :q
    EOF
    end result
    Code:
    cat /etc/yum.repos.d/nux-dextop.repo                         
    [nux-dextop]
    name=Nux.Ro RPMs for general desktop use
    baseurl=http://li.nux.ro/download/nux/dextop/el7/$basearch/ http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    priority=90
    protect=0
    
    [nux-dextop-testing]
    name=Nux.Ro RPMs for general desktop use - testing
    baseurl=http://li.nux.ro/download/nux/dextop-testing/el6/$basearch/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    priority=90
    protect=0
    disable it by default
    Code:
    sed -i 's|enabled=1|enabled=0|g' /etc/yum.repos.d/nux-dextop.repo
    Code:
    cat /etc/yum.repos.d/nux-dextop.repo                
    [nux-dextop]
    name=Nux.Ro RPMs for general desktop use
    baseurl=http://li.nux.ro/download/nux/dextop/el7/$basearch/ http://mirror.li.nux.ro/li.nux.ro/nux/dextop/el7/$basearch/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    priority=90
    protect=0
    
    [nux-dextop-testing]
    name=Nux.Ro RPMs for general desktop use - testing
    baseurl=http://li.nux.ro/download/nux/dextop-testing/el6/$basearch/
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    priority=90
    protect=0
    Then see what is available :D

    Ensure you disableplugin=priorities and enablerepo specifically on yum list and yum install commands
    Code:
    --disableplugin=priorities --enablerepo=nux-dextop,nux-dextop-testing
    Code:
    yum list -q ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=nux-dextop,nux-dextop-testing
    Installed Packages
    libid3tag.x86_64                                           0.15.1b-17.el7                                            @base
    libogg.x86_64                                              2:1.3.0-7.el7                                             @base
    libvorbis.x86_64                                           1:1.3.3-8.el7                                             @base
    libvorbis-devel.x86_64                                     1:1.3.3-8.el7                                             @base
    libvorbis-devel-docs.noarch                                1:1.3.3-8.el7                                             @base
    libvpx.x86_64                                              1.3.0-5.el7_0                                             @base
    libvpx-devel.x86_64                                        1.3.0-5.el7_0                                             @base
    libwmf.x86_64                                              0.2.8.4-39.el7                                            @base
    mingw32-libvorbis.noarch                                   1.3.4-1.el7                                               @epel
    mingw64-libvorbis.noarch                                   1.3.4-1.el7                                               @epel
    nasm.x86_64                                                2.10.07-7.el7                                             @base
    re2c.x86_64                                                0.14.3-1                                                  installed
    ruby.x86_64                                                2.0.0.598-25.el7_1                                        @updates
    ruby-devel.x86_64                                          2.0.0.598-25.el7_1                                        @updates
    ruby-libs.x86_64                                           2.0.0.598-25.el7_1                                        @updates
    vorbis-tools.x86_64                                        1:1.4.0-12.el7                                            @base
    yasm.x86_64                                                1.2.0-4.el7                                               @epel
    Available Packages
    faad2.x86_64                                               1:2.7-5.el7.nux                                           nux-dextop
    ffmpeg.x86_64                                              2.3.4-2.el7.nux                                           nux-dextop
    ffmpeg-devel.x86_64                                        2.3.4-2.el7.nux                                           nux-dextop
    lame.x86_64                                                3.99.5-2.el7                                              nux-dextop
    mencoder.x86_64                                            1.1-26.20140806svn.el7.nux                                nux-dextop
    mplayer.x86_64                                             1.1-26.20140806svn.el7.nux                                nux-dextop
    vorbisgain.x86_64                                          0.36-10.el7.nux                                           nux-dextop
    vorbisgain-debuginfo.x86_64                                0.36-10.el7.nux                                           nux-dextop
    xvidcore.x86_64                                            1.3.2-5.el7.nux                                           nux-dextop
    xvidcore-devel.x86_64                                      1.3.2-5.el7.nux                                           nux-dexto
    install
    Code:
    yum -y install ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=nux-dextop,nux-dextop-testing
    Code:
    Dependencies Resolved
    
    ===============================================================================================================================
    Package                         Arch              Version                                         Repository             Size
    ===============================================================================================================================
    Installing:
    faad2                           x86_64            1:2.7-5.el7.nux                                 nux-dextop             41 k
    ffmpeg                          x86_64            2.3.4-2.el7.nux                                 nux-dextop            1.5 M
    ffmpeg-devel                    x86_64            2.3.4-2.el7.nux                                 nux-dextop            271 k
    lame                            x86_64            3.99.5-2.el7                                    nux-dextop            128 k
    mencoder                        x86_64            1.1-26.20140806svn.el7.nux                      nux-dextop            834 k
    mplayer                         x86_64            1.1-26.20140806svn.el7.nux                      nux-dextop            1.1 M
    vorbisgain                      x86_64            0.36-10.el7.nux                                 nux-dextop             29 k
    vorbisgain-debuginfo            x86_64            0.36-10.el7.nux                                 nux-dextop             62 k
    xvidcore                        x86_64            1.3.2-5.el7.nux                                 nux-dextop            258 k
    xvidcore-devel                  x86_64            1.3.2-5.el7.nux                                 nux-dextop            138 k
    Installing for dependencies:
    SDL                             x86_64            1.2.15-11.el7                                   base                  204 k
    a52dec                          x86_64            0.7.4-18.el7.nux                                nux-dextop             57 k
    aalib-libs                      x86_64            1.4.0-0.22.rc5.el7                              epel                   65 k
    enca                            x86_64            1.14-1.el7                                      epel                  106 k
    faad2-libs                      x86_64            1:2.7-5.el7.nux                                 nux-dextop            148 k
    ffmpeg-libs                     x86_64            2.3.4-2.el7.nux                                 nux-dextop            4.8 M
    freeglut                        x86_64            2.8.1-3.el7                                     base                  182 k
    fribidi                         x86_64            0.19.4-6.el7                                    base                   63 k
    giflib                          x86_64            4.1.6-9.el7                                     base                   40 k
    gpm-libs                        x86_64            1.20.7-5.el7                                    base                   32 k
    lame-libs                       x86_64            3.99.5-2.el7                                    nux-dextop            339 k
    libXScrnSaver                   x86_64            1.2.2-6.1.el7                                   base                   24 k
    libXinerama                     x86_64            1.1.3-2.1.el7                                   base                   14 k
    libXv                           x86_64            1.0.9-2.1.el7                                   base                   18 k
    libXvMC                         x86_64            1.0.8-2.1.el7                                   base                   22 k
    libass                          x86_64            0.12.1-1.el7                                    epel                   80 k
    libbluray                       x86_64            0.2.3-5.el7                                     base                  135 k
    libbs2b                         x86_64            3.1.0-13.el7                                    epel                   24 k
    libcaca                         x86_64            0.99-0.17.beta17.el7                            epel                  216 k
    libcdio                         x86_64            0.92-1.el7                                      base                  235 k
    libcdio-paranoia                x86_64            10.2+0.90-11.el7                                base                   70 k
    libdc1394                       x86_64            2.2.2-3.el7                                     epel                  121 k
    libdca                          x86_64            0.0.5-7.el7.nux                                 nux-dextop            101 k
    libdv                           x86_64            1.0.0-17.el7                                    base                   78 k
    libdvdnav                       x86_64            4.2.0-8.el7                                     base                   58 k
    libdvdread                      x86_64            4.2.0-6.el7                                     base                   66 k
    libldb                          x86_64            1.1.17-2.el7                                    base                  122 k
    libmpeg2                        x86_64            0.5.1-10.el7.nux                                nux-dextop             66 k
    libmpg123                       x86_64            1.15.1-1.el7.nux                                nux-dextop            159 k
    libnemesi                       x86_64            0.7.0-0.5.20110215git.el7.nux                   nux-dextop            123 k
    libraw1394                      x86_64            2.1.0-2.el7                                     base                   63 k
    librtmp                         x86_64            2.4-2.20131205.gitdc76f0a.el7.nux               nux-dextop             69 k
    libsmbclient                    x86_64            4.1.12-23.el7_1                                 updates               120 k
    libtalloc                       x86_64            2.1.1-1.el7                                     base                   30 k
    libtdb                          x86_64            1.3.0-1.el7                                     base                   44 k
    libtevent                       x86_64            0.9.21-3.el7                                    base                   31 k
    libtheora                       x86_64            1:1.1.1-8.el7                                   base                  136 k
    libusbx                         x86_64            1.0.15-4.el7                                    base                   50 k
    libv4l                          x86_64            0.9.5-4.el7                                     base                  194 k
    libva                           x86_64            1.2.1-3.el7                                     epel                   68 k
    libvdpau                        x86_64            0.9-1.el7                                       epel                   32 k
    libwbclient                     x86_64            4.1.12-23.el7_1                                 updates                90 k
    lirc-libs                       x86_64            0.9.1a-4.el7                                    epel                   39 k
    lksctp-tools                    x86_64            1.0.13-3.el7                                    base                   87 k
    mesa-filesystem                 x86_64            10.2.7-5.20140910.el7                           base                   22 k
    mplayer-common                  x86_64            1.1-26.20140806svn.el7.nux                      nux-dextop            1.2 M
    netembryo                       x86_64            0.1.1-5.el7.nux                                 nux-dextop             25 k
    openal-soft                     x86_64            1.16.0-2.el7                                    epel                  282 k
    openjpeg-libs                   x86_64            1.5.1-10.el7                                    base                   85 k
    opus                            x86_64            1.0.2-6.el7                                     base                  630 k
    orc                             x86_64            0.4.17-5.el7                                    base                  164 k
    pytalloc                        x86_64            2.1.1-1.el7                                     base                   13 k
    samba-common                    x86_64            4.1.12-23.el7_1                                 updates               709 k
    samba-libs                      x86_64            4.1.12-23.el7_1                                 updates               4.3 M
    schroedinger                    x86_64            1.0.11-4.el7                                    epel                  291 k
    soxr                            x86_64            0.1.1-3.el7                                     epel                   77 k
    twolame-libs                    x86_64            0.3.13-3.el7.nux                                nux-dextop             50 k
    x264-libs                       x86_64            0.142-7.20140728gitaf8e768.el7.nux              nux-dextop            568 k
    
    Transaction Summary
    ===============================================================================================================================
    Install  10 Packages (+58 Dependent packages)
    
    Total download size: 21 M
    Installed size: 63 M
    Downloading packages:
    (1/68): SDL-1.2.15-11.el7.x86_64.rpm                                                                    | 204 kB  00:00:00
    (2/68): aalib-libs-1.4.0-0.22.rc5.el7.x86_64.rpm                                                        |  65 kB  00:00:00
    (3/68): enca-1.14-1.el7.x86_64.rpm                                                                      | 106 kB  00:00:00
    warning: /var/cache/yum/x86_64/7/nux-dextop/packages/a52dec-0.7.4-18.el7.nux.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 85c6cd8a: NOKEY
    Public key for a52dec-0.7.4-18.el7.nux.x86_64.rpm is not installed
    (4/68): a52dec-0.7.4-18.el7.nux.x86_64.rpm                                                              |  57 kB  00:00:03
    (5/68): faad2-2.7-5.el7.nux.x86_64.rpm                                                                  |  41 kB  00:00:03
    (6/68): faad2-libs-2.7-5.el7.nux.x86_64.rpm                                                             | 148 kB  00:00:04
    (7/68): ffmpeg-2.3.4-2.el7.nux.x86_64.rpm                                                               | 1.5 MB  00:00:10
    (8/68): freeglut-2.8.1-3.el7.x86_64.rpm                                                                 | 182 kB  00:00:00
    (9/68): giflib-4.1.6-9.el7.x86_64.rpm                                                                   |  40 kB  00:00:00
    (10/68): gpm-libs-1.20.7-5.el7.x86_64.rpm                                                               |  32 kB  00:00:00
    (11/68): fribidi-0.19.4-6.el7.x86_64.rpm                                                                |  63 kB  00:00:00
    (12/68): libXScrnSaver-1.2.2-6.1.el7.x86_64.rpm                                                         |  24 kB  00:00:00
    (13/68): libXinerama-1.1.3-2.1.el7.x86_64.rpm                                                           |  14 kB  00:00:00
    (14/68): libXv-1.0.9-2.1.el7.x86_64.rpm                                                                 |  18 kB  00:00:00
    (15/68): libXvMC-1.0.8-2.1.el7.x86_64.rpm                                                               |  22 kB  00:00:00
    (16/68): libass-0.12.1-1.el7.x86_64.rpm                                                                 |  80 kB  00:00:00
    (17/68): libbluray-0.2.3-5.el7.x86_64.rpm                                                               | 135 kB  00:00:00
    (18/68): libbs2b-3.1.0-13.el7.x86_64.rpm                                                                |  24 kB  00:00:00
    (19/68): libcaca-0.99-0.17.beta17.el7.x86_64.rpm                                                        | 216 kB  00:00:00
    (20/68): libcdio-0.92-1.el7.x86_64.rpm                                                                  | 235 kB  00:00:00
    (21/68): libcdio-paranoia-10.2+0.90-11.el7.x86_64.rpm                                                   |  70 kB  00:00:00
    (22/68): libdc1394-2.2.2-3.el7.x86_64.rpm                                                               | 121 kB  00:00:00
    (23/68): ffmpeg-devel-2.3.4-2.el7.nux.x86_64.rpm                                                        | 271 kB  00:00:07
    (24/68): lame-3.99.5-2.el7.x86_64.rpm                                                                   | 128 kB  00:00:03
    (25/68): libdv-1.0.0-17.el7.x86_64.rpm                                                                  |  78 kB  00:00:00
    (26/68): libdvdnav-4.2.0-8.el7.x86_64.rpm                                                               |  58 kB  00:00:00
    (27/68): libdvdread-4.2.0-6.el7.x86_64.rpm                                                              |  66 kB  00:00:00
    (28/68): libldb-1.1.17-2.el7.x86_64.rpm                                                                 | 122 kB  00:00:00
    (29/68): lame-libs-3.99.5-2.el7.x86_64.rpm                                                              | 339 kB  00:00:05
    (30/68): libdca-0.0.5-7.el7.nux.x86_64.rpm                                                              | 101 kB  00:00:02
    (31/68): libraw1394-2.1.0-2.el7.x86_64.rpm                                                              |  63 kB  00:00:00
    (32/68): libmpeg2-0.5.1-10.el7.nux.x86_64.rpm                                                           |  66 kB  00:00:03
    (33/68): libmpg123-1.15.1-1.el7.nux.x86_64.rpm                                                          | 159 kB  00:00:03
    (34/68): libtalloc-2.1.1-1.el7.x86_64.rpm                                                               |  30 kB  00:00:00
    (35/68): libsmbclient-4.1.12-23.el7_1.x86_64.rpm                                                        | 120 kB  00:00:00
    (36/68): libtdb-1.3.0-1.el7.x86_64.rpm                                                                  |  44 kB  00:00:00
    (37/68): libtevent-0.9.21-3.el7.x86_64.rpm                                                              |  31 kB  00:00:00
    (38/68): libtheora-1.1.1-8.el7.x86_64.rpm                                                               | 136 kB  00:00:00
    (39/68): libnemesi-0.7.0-0.5.20110215git.el7.nux.x86_64.rpm                                             | 123 kB  00:00:02
    (40/68): libusbx-1.0.15-4.el7.x86_64.rpm                                                                |  50 kB  00:00:00
    (41/68): libv4l-0.9.5-4.el7.x86_64.rpm                                                                  | 194 kB  00:00:00
    (42/68): libvdpau-0.9-1.el7.x86_64.rpm                                                                  |  32 kB  00:00:00
    (43/68): lirc-libs-0.9.1a-4.el7.x86_64.rpm                                                              |  39 kB  00:00:00
    (44/68): libwbclient-4.1.12-23.el7_1.x86_64.rpm                                                         |  90 kB  00:00:00
    (45/68): libva-1.2.1-3.el7.x86_64.rpm                                                                   |  68 kB  00:00:00
    (46/68): lksctp-tools-1.0.13-3.el7.x86_64.rpm                                                           |  87 kB  00:00:00
    (47/68): mesa-filesystem-10.2.7-5.20140910.el7.x86_64.rpm                                               |  22 kB  00:00:00
    (48/68): librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64.rpm                                           |  69 kB  00:00:01
    (49/68): mencoder-1.1-26.20140806svn.el7.nux.x86_64.rpm                                                 | 834 kB  00:00:06
    (50/68): mplayer-common-1.1-26.20140806svn.el7.nux.x86_64.rpm                                           | 1.2 MB  00:00:07
    (51/68): mplayer-1.1-26.20140806svn.el7.nux.x86_64.rpm                                                  | 1.1 MB  00:00:10
    (52/68): openjpeg-libs-1.5.1-10.el7.x86_64.rpm                                                          |  85 kB  00:00:00
    (53/68): orc-0.4.17-5.el7.x86_64.rpm                                                                    | 164 kB  00:00:00
    (54/68): pytalloc-2.1.1-1.el7.x86_64.rpm                                                                |  13 kB  00:00:00
    (55/68): openal-soft-1.16.0-2.el7.x86_64.rpm                                                            | 282 kB  00:00:00
    (56/68): samba-libs-4.1.12-23.el7_1.x86_64.rpm                                                          | 4.3 MB  00:00:01
    (57/68): opus-1.0.2-6.el7.x86_64.rpm                                                                    | 630 kB  00:00:01
    (58/68): schroedinger-1.0.11-4.el7.x86_64.rpm                                                           | 291 kB  00:00:00
    (59/68): soxr-0.1.1-3.el7.x86_64.rpm                                                                    |  77 kB  00:00:00
    (60/68): netembryo-0.1.1-5.el7.nux.x86_64.rpm                                                           |  25 kB  00:00:02
    (61/68): vorbisgain-0.36-10.el7.nux.x86_64.rpm                                                          |  29 kB  00:00:01
    (62/68): twolame-libs-0.3.13-3.el7.nux.x86_64.rpm                                                       |  50 kB  00:00:01
    (63/68): vorbisgain-debuginfo-0.36-10.el7.nux.x86_64.rpm                                                |  62 kB  00:00:03
    (64/68): samba-common-4.1.12-23.el7_1.x86_64.rpm                                                        | 709 kB  00:00:06
    (65/68): xvidcore-1.3.2-5.el7.nux.x86_64.rpm                                                            | 258 kB  00:00:04
    (66/68): x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64.rpm                                        | 568 kB  00:00:05
    (67/68): xvidcore-devel-1.3.2-5.el7.nux.x86_64.rpm                                                      | 138 kB  00:00:04
    (68/68): ffmpeg-libs-2.3.4-2.el7.nux.x86_64.rpm                                                         | 4.8 MB  00:00:29
    -------------------------------------------------------------------------------------------------------------------------------
    Total                                                                                          504 kB/s |  21 MB  00:00:43
    Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    Importing GPG key 0x85C6CD8A:
    Userid     : "Nux.Ro (rpm builder) <rpm@li.nux.ro>"
    Fingerprint: 561c 96bd 2f7f dc2a db5a fd46 e98b fbe7 85c6 cd8a
    Package    : nux-dextop-release-0-1.el7.nux.noarch (installed)
    From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
    Warning: RPMDB altered outside of yum.
      Installing : libtalloc-2.1.1-1.el7.x86_64                                                                               1/68
      Installing : xvidcore-1.3.2-5.el7.nux.x86_64                                                                            2/68
      Installing : lame-libs-3.99.5-2.el7.x86_64                                                                              3/68
      Installing : libtdb-1.3.0-1.el7.x86_64                                                                                  4/68
      Installing : libtevent-0.9.21-3.el7.x86_64                                                                              5/68
      Installing : SDL-1.2.15-11.el7.x86_64                                                                                   6/68
      Installing : fribidi-0.19.4-6.el7.x86_64                                                                                7/68
      Installing : libdvdread-4.2.0-6.el7.x86_64                                                                              8/68
      Installing : enca-1.14-1.el7.x86_64                                                                                     9/68
      Installing : libass-0.12.1-1.el7.x86_64                                                                                10/68
      Installing : 1:libtheora-1.1.1-8.el7.x86_64                                                                            11/68
      Installing : libXv-1.0.9-2.1.el7.x86_64                                                                                12/68
      Installing : 1:faad2-libs-2.7-5.el7.nux.x86_64                                                                         13/68
      Installing : x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64                                                       14/68
      Installing : libdvdnav-4.2.0-8.el7.x86_64                                                                              15/68
      Installing : lksctp-tools-1.0.13-3.el7.x86_64                                                                          16/68
      Installing : libmpeg2-0.5.1-10.el7.nux.x86_64                                                                          17/68
      Installing : libbluray-0.2.3-5.el7.x86_64                                                                              18/68
      Installing : libvdpau-0.9-1.el7.x86_64                                                                                 19/68
      Installing : libbs2b-3.1.0-13.el7.x86_64                                                                               20/68
      Installing : libdca-0.0.5-7.el7.nux.x86_64                                                                             21/68
      Installing : mplayer-common-1.1-26.20140806svn.el7.nux.x86_64                                                          22/68
      Installing : libmpg123-1.15.1-1.el7.nux.x86_64                                                                         23/68
      Installing : libdv-1.0.0-17.el7.x86_64                                                                                 24/68
      Installing : a52dec-0.7.4-18.el7.nux.x86_64                                                                            25/68
      Installing : librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64                                                          26/68
      Installing : giflib-4.1.6-9.el7.x86_64                                                                                 27/68
      Installing : netembryo-0.1.1-5.el7.nux.x86_64                                                                          28/68
      Installing : libnemesi-0.7.0-0.5.20110215git.el7.nux.x86_64                                                            29/68
      Installing : libXvMC-1.0.8-2.1.el7.x86_64                                                                              30/68
      Installing : libldb-1.1.17-2.el7.x86_64                                                                                31/68
      Installing : pytalloc-2.1.1-1.el7.x86_64                                                                               32/68
      Installing : libwbclient-4.1.12-23.el7_1.x86_64                                                                        33/68
      Installing : samba-libs-4.1.12-23.el7_1.x86_64                                                                         34/68
      Installing : samba-common-4.1.12-23.el7_1.x86_64                                                                       35/68
      Installing : libsmbclient-4.1.12-23.el7_1.x86_64                                                                       36/68
      Installing : libraw1394-2.1.0-2.el7.x86_64                                                                             37/68
      Installing : libXScrnSaver-1.2.2-6.1.el7.x86_64                                                                        38/68
      Installing : freeglut-2.8.1-3.el7.x86_64                                                                               39/68
      Installing : libcaca-0.99-0.17.beta17.el7.x86_64                                                                       40/68
      Installing : libv4l-0.9.5-4.el7.x86_64                                                                                 41/68
      Installing : openjpeg-libs-1.5.1-10.el7.x86_64                                                                         42/68
      Installing : libusbx-1.0.15-4.el7.x86_64                                                                               43/68
      Installing : libdc1394-2.2.2-3.el7.x86_64                                                                              44/68
      Installing : soxr-0.1.1-3.el7.x86_64                                                                                   45/68
      Installing : twolame-libs-0.3.13-3.el7.nux.x86_64                                                                      46/68
      Installing : lirc-libs-0.9.1a-4.el7.x86_64                                                                             47/68
      Installing : gpm-libs-1.20.7-5.el7.x86_64                                                                              48/68
      Installing : aalib-libs-1.4.0-0.22.rc5.el7.x86_64                                                                      49/68
      Installing : mesa-filesystem-10.2.7-5.20140910.el7.x86_64                                                              50/68
      Installing : libva-1.2.1-3.el7.x86_64                                                                                  51/68
      Installing : openal-soft-1.16.0-2.el7.x86_64                                                                           52/68
      Installing : opus-1.0.2-6.el7.x86_64                                                                                   53/68
      Installing : libXinerama-1.1.3-2.1.el7.x86_64                                                                          54/68
      Installing : orc-0.4.17-5.el7.x86_64                                                                                   55/68
      Installing : schroedinger-1.0.11-4.el7.x86_64                                                                          56/68
      Installing : libcdio-0.92-1.el7.x86_64                                                                                 57/68
      Installing : libcdio-paranoia-10.2+0.90-11.el7.x86_64                                                                  58/68
      Installing : ffmpeg-libs-2.3.4-2.el7.nux.x86_64                                                                        59/68
      Installing : ffmpeg-devel-2.3.4-2.el7.nux.x86_64                                                                       60/68
      Installing : mplayer-1.1-26.20140806svn.el7.nux.x86_64                                                                 61/68
      Installing : mencoder-1.1-26.20140806svn.el7.nux.x86_64                                                                62/68
      Installing : ffmpeg-2.3.4-2.el7.nux.x86_64                                                                             63/68
      Installing : 1:faad2-2.7-5.el7.nux.x86_64                                                                              64/68
      Installing : lame-3.99.5-2.el7.x86_64                                                                                  65/68
      Installing : xvidcore-devel-1.3.2-5.el7.nux.x86_64                                                                     66/68
      Installing : vorbisgain-debuginfo-0.36-10.el7.nux.x86_64                                                               67/68
      Installing : vorbisgain-0.36-10.el7.nux.x86_64                                                                         68/68
      Verifying  : libcdio-0.92-1.el7.x86_64                                                                                  1/68
      Verifying  : orc-0.4.17-5.el7.x86_64                                                                                    2/68
      Verifying  : libcdio-paranoia-10.2+0.90-11.el7.x86_64                                                                   3/68
      Verifying  : samba-common-4.1.12-23.el7_1.x86_64                                                                        4/68
      Verifying  : giflib-4.1.6-9.el7.x86_64                                                                                  5/68
      Verifying  : libXinerama-1.1.3-2.1.el7.x86_64                                                                           6/68
      Verifying  : librtmp-2.4-2.20131205.gitdc76f0a.el7.nux.x86_64                                                           7/68
      Verifying  : x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64                                                        8/68
      Verifying  : libdvdnav-4.2.0-8.el7.x86_64                                                                               9/68
      Verifying  : a52dec-0.7.4-18.el7.nux.x86_64                                                                            10/68
      Verifying  : aalib-libs-1.4.0-0.22.rc5.el7.x86_64                                                                      11/68
      Verifying  : 1:faad2-libs-2.7-5.el7.nux.x86_64                                                                         12/68
      Verifying  : libtalloc-2.1.1-1.el7.x86_64                                                                              13/68
      Verifying  : libdv-1.0.0-17.el7.x86_64                                                                                 14/68
      Verifying  : libtevent-0.9.21-3.el7.x86_64                                                                             15/68
      Verifying  : pytalloc-2.1.1-1.el7.x86_64                                                                               16/68
      Verifying  : 1:faad2-2.7-5.el7.nux.x86_64                                                                              17/68
      Verifying  : opus-1.0.2-6.el7.x86_64                                                                                   18/68
      Verifying  : libnemesi-0.7.0-0.5.20110215git.el7.nux.x86_64                                                            19/68
      Verifying  : openal-soft-1.16.0-2.el7.x86_64                                                                           20/68
      Verifying  : libwbclient-4.1.12-23.el7_1.x86_64                                                                        21/68
      Verifying  : vorbisgain-0.36-10.el7.nux.x86_64                                                                         22/68
      Verifying  : ffmpeg-devel-2.3.4-2.el7.nux.x86_64                                                                       23/68
      Verifying  : mesa-filesystem-10.2.7-5.20140910.el7.x86_64                                                              24/68
      Verifying  : netembryo-0.1.1-5.el7.nux.x86_64                                                                          25/68
      Verifying  : libtdb-1.3.0-1.el7.x86_64                                                                                 26/68
      Verifying  : libmpg123-1.15.1-1.el7.nux.x86_64                                                                         27/68
      Verifying  : lame-libs-3.99.5-2.el7.x86_64                                                                             28/68
      Verifying  : libXv-1.0.9-2.1.el7.x86_64                                                                                29/68
      Verifying  : gpm-libs-1.20.7-5.el7.x86_64                                                                              30/68
      Verifying  : mplayer-common-1.1-26.20140806svn.el7.nux.x86_64                                                          31/68
      Verifying  : mplayer-1.1-26.20140806svn.el7.nux.x86_64                                                                 32/68
      Verifying  : 1:libtheora-1.1.1-8.el7.x86_64                                                                            33/68
      Verifying  : libdca-0.0.5-7.el7.nux.x86_64                                                                             34/68
      Verifying  : enca-1.14-1.el7.x86_64                                                                                    35/68
      Verifying  : lirc-libs-0.9.1a-4.el7.x86_64                                                                             36/68
      Verifying  : twolame-libs-0.3.13-3.el7.nux.x86_64                                                                      37/68
      Verifying  : libbs2b-3.1.0-13.el7.x86_64                                                                               38/68
      Verifying  : libdc1394-2.2.2-3.el7.x86_64                                                                              39/68
      Verifying  : soxr-0.1.1-3.el7.x86_64                                                                                   40/68
      Verifying  : libldb-1.1.17-2.el7.x86_64                                                                                41/68
      Verifying  : schroedinger-1.0.11-4.el7.x86_64                                                                          42/68
      Verifying  : mencoder-1.1-26.20140806svn.el7.nux.x86_64                                                                43/68
      Verifying  : libusbx-1.0.15-4.el7.x86_64                                                                               44/68
      Verifying  : libdvdread-4.2.0-6.el7.x86_64                                                                             45/68
      Verifying  : openjpeg-libs-1.5.1-10.el7.x86_64                                                                         46/68
      Verifying  : samba-libs-4.1.12-23.el7_1.x86_64                                                                         47/68
      Verifying  : libvdpau-0.9-1.el7.x86_64                                                                                 48/68
      Verifying  : libv4l-0.9.5-4.el7.x86_64                                                                                 49/68
      Verifying  : xvidcore-1.3.2-5.el7.nux.x86_64                                                                           50/68
      Verifying  : libXvMC-1.0.8-2.1.el7.x86_64                                                                              51/68
      Verifying  : libbluray-0.2.3-5.el7.x86_64                                                                              52/68
      Verifying  : freeglut-2.8.1-3.el7.x86_64                                                                               53/68
      Verifying  : lame-3.99.5-2.el7.x86_64                                                                                  54/68
      Verifying  : libmpeg2-0.5.1-10.el7.nux.x86_64                                                                          55/68
      Verifying  : fribidi-0.19.4-6.el7.x86_64                                                                               56/68
      Verifying  : libva-1.2.1-3.el7.x86_64                                                                                  57/68
      Verifying  : xvidcore-devel-1.3.2-5.el7.nux.x86_64                                                                     58/68
      Verifying  : libXScrnSaver-1.2.2-6.1.el7.x86_64                                                                        59/68
      Verifying  : vorbisgain-debuginfo-0.36-10.el7.nux.x86_64                                                               60/68
      Verifying  : libcaca-0.99-0.17.beta17.el7.x86_64                                                                       61/68
      Verifying  : ffmpeg-2.3.4-2.el7.nux.x86_64                                                                             62/68
      Verifying  : SDL-1.2.15-11.el7.x86_64                                                                                  63/68
      Verifying  : libsmbclient-4.1.12-23.el7_1.x86_64                                                                       64/68
      Verifying  : lksctp-tools-1.0.13-3.el7.x86_64                                                                          65/68
      Verifying  : libraw1394-2.1.0-2.el7.x86_64                                                                             66/68
      Verifying  : ffmpeg-libs-2.3.4-2.el7.nux.x86_64                                                                        67/68
      Verifying  : libass-0.12.1-1.el7.x86_64                                                                                68/68
    
    Installed:
      faad2.x86_64 1:2.7-5.el7.nux                                  ffmpeg.x86_64 0:2.3.4-2.el7.nux                     
      ffmpeg-devel.x86_64 0:2.3.4-2.el7.nux                         lame.x86_64 0:3.99.5-2.el7                          
      mencoder.x86_64 0:1.1-26.20140806svn.el7.nux                  mplayer.x86_64 0:1.1-26.20140806svn.el7.nux         
      vorbisgain.x86_64 0:0.36-10.el7.nux                           vorbisgain-debuginfo.x86_64 0:0.36-10.el7.nux       
      xvidcore.x86_64 0:1.3.2-5.el7.nux                             xvidcore-devel.x86_64 0:1.3.2-5.el7.nux             
    
    Dependency Installed:
      SDL.x86_64 0:1.2.15-11.el7                                 a52dec.x86_64 0:0.7.4-18.el7.nux                       
      aalib-libs.x86_64 0:1.4.0-0.22.rc5.el7                     enca.x86_64 0:1.14-1.el7                               
      faad2-libs.x86_64 1:2.7-5.el7.nux                          ffmpeg-libs.x86_64 0:2.3.4-2.el7.nux                   
      freeglut.x86_64 0:2.8.1-3.el7                              fribidi.x86_64 0:0.19.4-6.el7                          
      giflib.x86_64 0:4.1.6-9.el7                                gpm-libs.x86_64 0:1.20.7-5.el7                         
      lame-libs.x86_64 0:3.99.5-2.el7                            libXScrnSaver.x86_64 0:1.2.2-6.1.el7                   
      libXinerama.x86_64 0:1.1.3-2.1.el7                         libXv.x86_64 0:1.0.9-2.1.el7                           
      libXvMC.x86_64 0:1.0.8-2.1.el7                             libass.x86_64 0:0.12.1-1.el7                           
      libbluray.x86_64 0:0.2.3-5.el7                             libbs2b.x86_64 0:3.1.0-13.el7                          
      libcaca.x86_64 0:0.99-0.17.beta17.el7                      libcdio.x86_64 0:0.92-1.el7                            
      libcdio-paranoia.x86_64 0:10.2+0.90-11.el7                 libdc1394.x86_64 0:2.2.2-3.el7                         
      libdca.x86_64 0:0.0.5-7.el7.nux                            libdv.x86_64 0:1.0.0-17.el7                            
      libdvdnav.x86_64 0:4.2.0-8.el7                             libdvdread.x86_64 0:4.2.0-6.el7                        
      libldb.x86_64 0:1.1.17-2.el7                               libmpeg2.x86_64 0:0.5.1-10.el7.nux                     
      libmpg123.x86_64 0:1.15.1-1.el7.nux                        libnemesi.x86_64 0:0.7.0-0.5.20110215git.el7.nux       
      libraw1394.x86_64 0:2.1.0-2.el7                            librtmp.x86_64 0:2.4-2.20131205.gitdc76f0a.el7.nux     
      libsmbclient.x86_64 0:4.1.12-23.el7_1                      libtalloc.x86_64 0:2.1.1-1.el7                         
      libtdb.x86_64 0:1.3.0-1.el7                                libtevent.x86_64 0:0.9.21-3.el7                        
      libtheora.x86_64 1:1.1.1-8.el7                             libusbx.x86_64 0:1.0.15-4.el7                          
      libv4l.x86_64 0:0.9.5-4.el7                                libva.x86_64 0:1.2.1-3.el7                             
      libvdpau.x86_64 0:0.9-1.el7                                libwbclient.x86_64 0:4.1.12-23.el7_1                   
      lirc-libs.x86_64 0:0.9.1a-4.el7                            lksctp-tools.x86_64 0:1.0.13-3.el7                     
      mesa-filesystem.x86_64 0:10.2.7-5.20140910.el7             mplayer-common.x86_64 0:1.1-26.20140806svn.el7.nux     
      netembryo.x86_64 0:0.1.1-5.el7.nux                         openal-soft.x86_64 0:1.16.0-2.el7                      
      openjpeg-libs.x86_64 0:1.5.1-10.el7                        opus.x86_64 0:1.0.2-6.el7                              
      orc.x86_64 0:0.4.17-5.el7                                  pytalloc.x86_64 0:2.1.1-1.el7                          
      samba-common.x86_64 0:4.1.12-23.el7_1                      samba-libs.x86_64 0:4.1.12-23.el7_1                    
      schroedinger.x86_64 0:1.0.11-4.el7                         soxr.x86_64 0:0.1.1-3.el7                              
      twolame-libs.x86_64 0:0.3.13-3.el7.nux                     x264-libs.x86_64 0:0.142-7.20140728gitaf8e768.el7.nux  
    
    Complete!
    Code:
    ffmpeg --help
    ffmpeg version 2.3.4 Copyright (c) 2000-2014 the FFmpeg developers
      built on Feb 25 2015 16:24:30 with gcc 4.8.2 (GCC) 20140120 (Red Hat 4.8.2-16)
      configuration: --prefix=/usr --bindir=/usr/bin --datadir=/usr/share/ffmpeg --incdir=/usr/include/ffmpeg --libdir=/usr/lib64 --mandir=/usr/share/man --arch=x86_64 --optflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic' --enable-bzlib --disable-crystalhd --enable-gnutls --enable-libass --enable-libcdio --enable-libdc1394 --disable-indev=jack --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-openal --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libv4l2 --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab --enable-avfilter --enable-avresample --enable-postproc --enable-pthreads --disable-static --enable-shared --enable-gpl --disable-debug --disable-stripping --shlibdir=/usr/lib64 --enable-runtime-cpudetect
      libavutil      52. 92.100 / 52. 92.100
      libavcodec     55. 69.100 / 55. 69.100
      libavformat    55. 48.100 / 55. 48.100
      libavdevice    55. 13.102 / 55. 13.102
      libavfilter     4. 11.100 /  4. 11.100
      libavresample   1.  3.  0 /  1.  3.  0
      libswscale      2.  6.100 /  2.  6.100
      libswresample   0. 19.100 /  0. 19.100
      libpostproc    52.  3.100 / 52.  3.100
    nearly there ! still though ffmpeg headers not found and --enable-shared doesn't make a difference

    Code:
    [root@centos7 ffmpeg-php-0.6.0]# ./configure --with-php-config=/usr/local/bin/php-config --with-ffmpeg=/usr
    
    checking for re2c... re2c
    checking for re2c version... 0.14.3 (ok)
    checking for gawk... gawk
    checking for ffmpeg support... yes, shared
    checking whether to force gd support in ffmpeg-php... no
    checking for ffmpeg headers...
    configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option
    Code:
    rpm -ql ffmpeg-devel
    /usr/include/ffmpeg
    /usr/include/ffmpeg/libavcodec
    /usr/include/ffmpeg/libavcodec/avcodec.h
    /usr/include/ffmpeg/libavcodec/avfft.h
    /usr/include/ffmpeg/libavcodec/dv_profile.h
    /usr/include/ffmpeg/libavcodec/dxva2.h
    /usr/include/ffmpeg/libavcodec/old_codec_ids.h
    /usr/include/ffmpeg/libavcodec/vaapi.h
    /usr/include/ffmpeg/libavcodec/vda.h
    /usr/include/ffmpeg/libavcodec/vdpau.h
    /usr/include/ffmpeg/libavcodec/version.h
    /usr/include/ffmpeg/libavcodec/xvmc.h
    /usr/include/ffmpeg/libavdevice
    /usr/include/ffmpeg/libavdevice/avdevice.h
    /usr/include/ffmpeg/libavdevice/version.h
    /usr/include/ffmpeg/libavfilter
    /usr/include/ffmpeg/libavfilter/asrc_abuffer.h
    /usr/include/ffmpeg/libavfilter/avcodec.h
    /usr/include/ffmpeg/libavfilter/avfilter.h
    /usr/include/ffmpeg/libavfilter/avfiltergraph.h
    /usr/include/ffmpeg/libavfilter/buffersink.h
    /usr/include/ffmpeg/libavfilter/buffersrc.h
    /usr/include/ffmpeg/libavfilter/version.h
    /usr/include/ffmpeg/libavformat
    /usr/include/ffmpeg/libavformat/avformat.h
    /usr/include/ffmpeg/libavformat/avio.h
    /usr/include/ffmpeg/libavformat/version.h
    /usr/include/ffmpeg/libavresample
    /usr/include/ffmpeg/libavresample/avresample.h
    /usr/include/ffmpeg/libavresample/version.h
    /usr/include/ffmpeg/libavutil
    /usr/include/ffmpeg/libavutil/adler32.h
    /usr/include/ffmpeg/libavutil/aes.h
    /usr/include/ffmpeg/libavutil/attributes.h
    /usr/include/ffmpeg/libavutil/audio_fifo.h
    /usr/include/ffmpeg/libavutil/audioconvert.h
    /usr/include/ffmpeg/libavutil/avassert.h
    /usr/include/ffmpeg/libavutil/avconfig.h
    /usr/include/ffmpeg/libavutil/avstring.h
    /usr/include/ffmpeg/libavutil/avutil.h
    /usr/include/ffmpeg/libavutil/base64.h
    /usr/include/ffmpeg/libavutil/blowfish.h
    /usr/include/ffmpeg/libavutil/bprint.h
    /usr/include/ffmpeg/libavutil/bswap.h
    /usr/include/ffmpeg/libavutil/buffer.h
    /usr/include/ffmpeg/libavutil/channel_layout.h
    /usr/include/ffmpeg/libavutil/common.h
    /usr/include/ffmpeg/libavutil/cpu.h
    /usr/include/ffmpeg/libavutil/crc.h
    /usr/include/ffmpeg/libavutil/dict.h
    /usr/include/ffmpeg/libavutil/display.h
    /usr/include/ffmpeg/libavutil/downmix_info.h
    /usr/include/ffmpeg/libavutil/error.h
    /usr/include/ffmpeg/libavutil/eval.h
    /usr/include/ffmpeg/libavutil/ffversion.h
    /usr/include/ffmpeg/libavutil/fifo.h
    /usr/include/ffmpeg/libavutil/file.h
    /usr/include/ffmpeg/libavutil/frame.h
    /usr/include/ffmpeg/libavutil/hash.h
    /usr/include/ffmpeg/libavutil/hmac.h
    /usr/include/ffmpeg/libavutil/imgutils.h
    /usr/include/ffmpeg/libavutil/intfloat.h
    /usr/include/ffmpeg/libavutil/intfloat_readwrite.h
    /usr/include/ffmpeg/libavutil/intreadwrite.h
    /usr/include/ffmpeg/libavutil/lfg.h
    /usr/include/ffmpeg/libavutil/log.h
    /usr/include/ffmpeg/libavutil/lzo.h
    /usr/include/ffmpeg/libavutil/macros.h
    /usr/include/ffmpeg/libavutil/mathematics.h
    /usr/include/ffmpeg/libavutil/md5.h
    /usr/include/ffmpeg/libavutil/mem.h
    /usr/include/ffmpeg/libavutil/murmur3.h
    /usr/include/ffmpeg/libavutil/old_pix_fmts.h
    /usr/include/ffmpeg/libavutil/opt.h
    /usr/include/ffmpeg/libavutil/parseutils.h
    /usr/include/ffmpeg/libavutil/pixdesc.h
    /usr/include/ffmpeg/libavutil/pixfmt.h
    /usr/include/ffmpeg/libavutil/random_seed.h
    /usr/include/ffmpeg/libavutil/rational.h
    /usr/include/ffmpeg/libavutil/replaygain.h
    /usr/include/ffmpeg/libavutil/ripemd.h
    /usr/include/ffmpeg/libavutil/samplefmt.h
    /usr/include/ffmpeg/libavutil/sha.h
    /usr/include/ffmpeg/libavutil/sha512.h
    /usr/include/ffmpeg/libavutil/stereo3d.h
    /usr/include/ffmpeg/libavutil/threadmessage.h
    /usr/include/ffmpeg/libavutil/time.h
    /usr/include/ffmpeg/libavutil/timecode.h
    /usr/include/ffmpeg/libavutil/timestamp.h
    /usr/include/ffmpeg/libavutil/version.h
    /usr/include/ffmpeg/libavutil/xtea.h
    /usr/include/ffmpeg/libpostproc
    /usr/include/ffmpeg/libpostproc/postprocess.h
    /usr/include/ffmpeg/libpostproc/version.h
    /usr/include/ffmpeg/libswresample
    /usr/include/ffmpeg/libswresample/swresample.h
    /usr/include/ffmpeg/libswresample/version.h
    /usr/include/ffmpeg/libswscale
    /usr/include/ffmpeg/libswscale/swscale.h
    /usr/include/ffmpeg/libswscale/version.h
    /usr/lib64/libavcodec.so
    /usr/lib64/libavdevice.so
    /usr/lib64/libavfilter.so
    /usr/lib64/libavformat.so
    /usr/lib64/libavresample.so
    /usr/lib64/libavutil.so
    /usr/lib64/libpostproc.so
    /usr/lib64/libswresample.so
    /usr/lib64/libswscale.so
    /usr/lib64/pkgconfig/libavcodec.pc
    /usr/lib64/pkgconfig/libavdevice.pc
    /usr/lib64/pkgconfig/libavfilter.pc
    /usr/lib64/pkgconfig/libavformat.pc
    /usr/lib64/pkgconfig/libavresample.pc
    /usr/lib64/pkgconfig/libavutil.pc
    /usr/lib64/pkgconfig/libpostproc.pc
    /usr/lib64/pkgconfig/libswresample.pc
    /usr/lib64/pkgconfig/libswscale.pc
    /usr/share/doc/ffmpeg-devel-2.3.4
    /usr/share/doc/ffmpeg-devel-2.3.4/APIchanges
    /usr/share/doc/ffmpeg-devel-2.3.4/MAINTAINERS
    /usr/share/doc/ffmpeg-devel-2.3.4/build_system.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/errno.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/ffmpeg.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/filter_design.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/issue_tracker.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/mips.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/multithreading.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/optimization.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/rate_distortion.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/snow.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/swresample.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/swscale.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/tablegen.txt
    /usr/share/doc/ffmpeg-devel-2.3.4/writing_filters.txt
    On CentOS 6 with rpmforge installed ffmpeg-devel
    Code:
    locate avio.h avformat.h avcodec.h
    /usr/include/libavcodec/avcodec.h
    /usr/include/libavformat/avformat.h
    /usr/include/libavformat/avio.h
    On CentOS 7 with nux-dextop installed ffmpeg-devel
    Code:
    locate avio.h avformat.h avcodec.h
    /usr/include/ffmpeg/libavcodec/avcodec.h
    /usr/include/ffmpeg/libavfilter/avcodec.h
    /usr/include/ffmpeg/libavformat/avformat.h
    /usr/include/ffmpeg/libavformat/avio.h
    /usr/share/doc/ffmpeg/libavcodec.html
    /usr/share/doc/ffmpeg/libavformat.html
    Code:
    [root@centos7 ffmpeg-php-0.6.0]# strace -f -o /ffmpeg-strace ./configure --with-php-config=/usr/local/bin/php-config --with-ffmpeg=/usr --includedir=/usr/include/ffmpeg
    Code:
    cat /ffmpeg-strace | egrep 'avio.h|avformat.h|avcodec.h'
    12401 stat("/usr/include/ffmpeg/avcodec.h", 0x7ffc74eeaee0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/include/avcodec.h", 0x7ffc74eeadd0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/include/libavcodec/avcodec.h", 0x7ffc74eeacc0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/local/include/ffmpeg/avcodec.h", 0x7ffc74eeaee0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/local/include/avcodec.h", 0x7ffc74eeadd0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/local/include/libavcodec/avcodec.h", 0x7ffc74eeacc0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/include/ffmpeg/avcodec.h", 0x7ffc74eeaee0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/include/avcodec.h", 0x7ffc74eeadd0) = -1 ENOENT (No such file or directory)
    12401 stat("/usr/include/libavcodec/avcodec.h", 0x7ffc74eeacc0) = -1 ENOENT (No such file or directory)
    Looks like ffmpeg-devel installed headers at
    • /usr/include/ffmpeg/libavcodec/avcodec.h
    • /usr/include/ffmpeg/libavfilter/avcodec.h
    • /usr/include/ffmpeg/libavformat/avformat.h
    • /usr/include/ffmpeg/libavformat/avio.h
    Problem is specific to avcodec.h - so what about symlinking them
    Code:
    ln -s /usr/include/ffmpeg/libavcodec/avcodec.h /usr/include/ffmpeg/avcodec.h
    
    configure stage works but make falls over
    Code:
    make
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/ffmpeg  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c -o ffmpeg-php.lo
    mkdir .libs
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/ffmpeg -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c  -fPIC -DPIC -o .libs/ffmpeg-php.o
    In file included from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:42:0:
    /usr/include/ffmpeg/avcodec.h:43:21: fatal error: version.h: No such file or directory
    #include "version.h"
    Code:
    locate version.h | grep ffmpeg
    /usr/include/ffmpeg/libavcodec/version.h
    /usr/include/ffmpeg/libavdevice/version.h
    /usr/include/ffmpeg/libavfilter/version.h
    /usr/include/ffmpeg/libavformat/version.h
    /usr/include/ffmpeg/libavresample/version.h
    /usr/include/ffmpeg/libavutil/ffversion.h
    /usr/include/ffmpeg/libavutil/version.h
    /usr/include/ffmpeg/libpostproc/version.h
    /usr/include/ffmpeg/libswresample/version.h
    /usr/include/ffmpeg/libswscale/version.h
    Code:
    ls -lah /usr/include/ffmpeg/libavcodec/
    total 244K
    drwxr-xr-x  2 root root 4.0K Jul 15 17:07 .
    drwxr-xr-x 11 root root 4.0K Jul 15 17:44 ..
    -rw-r--r--  1 root root 173K Feb 25 16:28 avcodec.h
    -rw-r--r--  1 root root 3.1K Feb 25 16:28 avfft.h
    -rw-r--r--  1 root root 3.9K Feb 25 16:28 dv_profile.h
    -rw-r--r--  1 root root 2.4K Feb 25 16:28 dxva2.h
    -rw-r--r--  1 root root  11K Feb 25 16:28 old_codec_ids.h
    -rw-r--r--  1 root root 4.0K Feb 25 16:28 vaapi.h
    -rw-r--r--  1 root root 5.4K Feb 25 16:28 vda.h
    -rw-r--r--  1 root root 6.1K Feb 25 16:28 vdpau.h
    -rw-r--r--  1 root root 5.5K Feb 25 16:28 version.h
    -rw-r--r--  1 root root 6.0K Feb 25 16:28 xvmc.h
    symlinking didn't help either

    Code:
    cd /usr/include/ffmpeg
    ln -sf */* .
    
    make fails
    Code:
    make
    /bin/sh /svr-setup/ffmpeg-php-0.6.0/libtool --mode=compile ccache gcc  -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/ffmpeg  -DHAVE_CONFIG_H  -g -O2 -Wall -fno-strict-aliasing   -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c -o ffmpeg-php.lo
    ccache gcc -I. -I/svr-setup/ffmpeg-php-0.6.0 -DPHP_ATOM_INC -I/svr-setup/ffmpeg-php-0.6.0/include -I/svr-setup/ffmpeg-php-0.6.0/main -I/svr-setup/ffmpeg-php-0.6.0 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -I/usr/include/ffmpeg -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c  -fPIC -DPIC -o .libs/ffmpeg-php.o
    In file included from /usr/include/sys/stat.h:106:0,
                     from /usr/local/include/php/main/php_streams.h:28,
                     from /usr/local/include/php/main/php.h:398,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/include/bits/stat.h:91:21: error: field ‘st_atim’ has incomplete type
         struct timespec st_atim;  /* Time of last access.  */
                         ^
    /usr/include/bits/stat.h:92:21: error: field ‘st_mtim’ has incomplete type
         struct timespec st_mtim;  /* Time of last modification.  */
                         ^
    /usr/include/bits/stat.h:93:21: error: field ‘st_ctim’ has incomplete type
         struct timespec st_ctim;  /* Time of last status change.  */
                         ^
    /usr/include/bits/stat.h:152:21: error: field ‘st_atim’ has incomplete type
         struct timespec st_atim;  /* Time of last access.  */
                         ^
    /usr/include/bits/stat.h:153:21: error: field ‘st_mtim’ has incomplete type
         struct timespec st_mtim;  /* Time of last modification.  */
                         ^
    /usr/include/bits/stat.h:154:21: error: field ‘st_ctim’ has incomplete type
         struct timespec st_ctim;  /* Time of last status change.  */
                         ^
    In file included from /usr/local/include/php/main/php_streams.h:28:0,
                     from /usr/local/include/php/main/php.h:398,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/include/sys/stat.h:366:31: error: array type has incomplete element type
             const struct timespec __times[2],
                                   ^
    /usr/include/sys/stat.h:373:54: error: array type has incomplete element type
    extern int futimens (int __fd, const struct timespec __times[2]) __THROW;
                                                          ^
    In file included from /usr/local/include/php/main/php.h:404:0,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/local/include/php/Zend/zend_virtual_cwd.h:220:2: error: unknown type name ‘time_t’
      time_t                         expires;
      ^
    /usr/local/include/php/Zend/zend_virtual_cwd.h:248:86: error: unknown type name ‘time_t’
    CWD_API realpath_cache_bucket* realpath_cache_lookup(const char *path, int path_len, time_t t TSRMLS_DC);
                                                                                          ^
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c: In function ‘zm_startup_ffmpeg’:
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:94:5: warning: implicit declaration of function ‘avcodec_init’ [-Wimplicit-function-declaration]
         avcodec_init();
         ^
    make: *** [ffmpeg-php.lo] Error 1
    possibly related to #2017 (ogsf compilation error) – GRASS GIS

     
    Last edited: Jul 16, 2015
    • Winner Winner x 1
  7. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    maybe try a different 3rd party yum repo which does have ffmpeg and ffmpeg-devel and maybe it has the headers in right place on centos 7? ATrpms repo

    Code:
    rpm --import http://packages.atrpms.net/RPM-GPG-KEY.atrpms
    rpm -ivh http://dl.atrpms.net/all/atrpms-repo-6-7.el6.x86_64.rpm
    
    Code:
    cat /etc/yum.repos.d/atrpms.repo
    [atrpms]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms
    failovermethod=priority
    baseurl=http://dl.atrpms.net/el$releasever-$basearch/atrpms/stable
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    
    [atrpms-debuginfo]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Debug
    failovermethod=priority
    baseurl=http://dl.atrpms.net/debug/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    
    [atrpms-source]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Source
    failovermethod=priority
    baseurl=http://dl.atrpms.net/src/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    
    Code:
    cp -a /etc/yum.repos.d/atrpms.repo /etc/yum.repos.d/atrpms.repo.OLD
    
    Code:
    ex -s /etc/yum.repos.d/atrpms.repo << EOF
    :/\[atrpms/ , /gpgkey/
    :a
    priority=90
    .
    :w
    :/\[atrpms-debuginfo/ , /gpgkey/
    :a
    priority=90
    .
    :w
    :q
    EOF
    
    Code:
    cat /etc/yum.repos.d/atrpms.repo 
    [atrpms]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms
    failovermethod=priority
    baseurl=http://dl.atrpms.net/el$releasever-$basearch/atrpms/stable
    enabled=1
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    priority=90
    
    [atrpms-debuginfo]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Debug
    failovermethod=priority
    baseurl=http://dl.atrpms.net/debug/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    priority=90
    
    [atrpms-source]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Source
    failovermethod=priority
    baseurl=http://dl.atrpms.net/src/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    
    Code:
    sed -i 's|enabled=1|enabled=0|g' /etc/yum.repos.d/atrpms.repo
    
    Code:
    cat /etc/yum.repos.d/atrpms.repo                     
    [atrpms]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms
    failovermethod=priority
    baseurl=http://dl.atrpms.net/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    priority=90
    
    [atrpms-debuginfo]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Debug
    failovermethod=priority
    baseurl=http://dl.atrpms.net/debug/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    priority=90
    
    [atrpms-source]
    name=Red Hat Enterprise Linux $releasever - $basearch - ATrpms - Source
    failovermethod=priority
    baseurl=http://dl.atrpms.net/src/el$releasever-$basearch/atrpms/stable
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-atrpms
    
    Code:
    Ensure you disableplugin=priorities and enablerepo specifically on yum list and yum install commands
    
    Code:
    --disableplugin=priorities --enablerepo=atrpms
    
    Code:
    yum list -q ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=atrpms
    Installed Packages
    libvpx.x86_64                                               1.3.0-5.el7_0                                             @base
    libvpx-devel.x86_64                                         1.3.0-5.el7_0                                             @base
    re2c.x86_64                                                 0.14.3-1                                                  installed
    Available Packages
    faad2.x86_64                                                1:2.7-18.el7                                              atrpms
    ffmpeg.x86_64                                               2.2.1-65.el7                                              atrpms
    ffmpeg-devel.x86_64                                         2.2.1-65.el7                                              atrpms
    lame.x86_64                                                 3.99.3-23.el7                                             atrpms
    libid3tag.x86_64                                            0.15.1b-17.el7                                            base
    libogg.x86_64                                               2:1.3.0-7.el7                                             base
    libvorbis.x86_64                                            1:1.3.3-8.el7                                             base
    libvorbis-devel.x86_64                                      1:1.3.3-8.el7                                             base
    libvorbis-devel-docs.noarch                                 1:1.3.3-8.el7                                             base
    libwmf.x86_64                                               0.2.8.4-39.el7                                            base
    mingw32-libvorbis.noarch                                    1.3.4-1.el7                                               epel
    mingw64-libvorbis.noarch                                    1.3.4-1.el7                                               epel
    mplayer.x86_64                                              4:1.2-93_snap20140413.el7                                 atrpms
    nasm.x86_64                                                 2.10.07-7.el7                                             base
    ruby.x86_64                                                 2.0.0.598-25.el7_1                                        updates
    ruby-devel.x86_64                                           2.0.0.598-25.el7_1                                        updates
    ruby-libs.x86_64                                            2.0.0.598-25.el7_1                                        updates
    vorbis-tools.x86_64                                         1:1.4.0-12.el7                                            base
    xvidcore.x86_64                                             1.3.2-15.el7                                              atrpms
    xvidcore-devel.x86_64                                       1.3.2-15.el7                                              atrpms
    yasm.x86_64                                                 1.2.0-4.el7                                               epel   
    Doesn't all the packages like nux-dextop yum repo

    Code:
    yum -y install ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=atrpms
    
    No package flvtool2 available.
    Package libvpx-1.3.0-5.el7_0.x86_64 already installed and latest version
    Package libvpx-devel-1.3.0-5.el7_0.x86_64 already installed and latest version
    No package amrnb-devel available.
    No package amrwb-devel available.
    No package facc available.
    No package a52decoder available.
    
    
    ---> Package mpg123.x86_64 0:1.18.1-1.el7 will be installed
    --> Processing Dependency: libaudio.so.2()(64bit) for package: mpg123-1.18.1-1.el7.x86_64
    ---> Package mplayer.x86_64 4:1.2-93_snap20140413.el7 will be installed
    --> Processing Dependency: libaudio.so.2()(64bit) for package: 4:mplayer-1.2-93_snap20140413.el7.x86_64
    --> Processing Dependency: libnemesi.so.1()(64bit) for package: 4:mplayer-1.2-93_snap20140413.el7.x86_64
    --> Processing Dependency: libvga.so.1()(64bit) for package: 4:mplayer-1.2-93_snap20140413.el7.x86_64
    ---> Package pytalloc.x86_64 0:2.1.1-1.el7 will be installed
    ---> Package ruby-irb.noarch 0:2.0.0.598-25.el7_1 will be installed
    ---> Package rubygem-json.x86_64 0:1.7.7-25.el7_1 will be installed
    --> Finished Dependency Resolution
    Error: Package: 4:mplayer-1.2-93_snap20140413.el7.x86_64 (atrpms)
               Requires: libnemesi.so.1()(64bit)
    Error: Package: 4:mplayer-1.2-93_snap20140413.el7.x86_64 (atrpms)
               Requires: libaudio.so.2()(64bit)
    Error: Package: 4:mplayer-1.2-93_snap20140413.el7.x86_64 (atrpms)
               Requires: libvga.so.1()(64bit)
    Error: Package: mpg123-1.18.1-1.el7.x86_64 (atrpms)
               Requires: libaudio.so.2()(64bit)
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest
    Code:
    yum provides */libaudio.so.2 */libnemesi.so.1 */libvga.so.1
    Loaded plugins: downloadonly, fastestmirror, priorities, security
    Loading mirror speeds from cached hostfile
    * base: centos-mirror.jchost.net
    * epel: mirror.sfo12.us.leaseweb.net
    * extras: mirrors.easynews.com
    * rpmforge: mirror.chpc.utah.edu
    * updates: centos.sonn.com
    1606 packages excluded due to repository priority protections
    nas-1.9.1-7.el6.x86_64 : The Network Audio System (NAS)
    Repo        : epel
    Matched from:
    Filename    : /usr/lib64/libaudio.so.2
    
    svgalib-1.9.25-14.el6.x86_64 : Low-level fullscreen SVGA graphics library
    Repo        : epel
    Matched from:
    Filename    : /usr/lib64/libvga.so.1
    
    svgalib-1.9.25-14.el6.x86_64 : Low-level fullscreen SVGA graphics library
    Repo        : installed
    Matched from:
    Filename    : /usr/lib64/libvga.so.1
    so those packages are missing.. on CentOS 6.6 these are provided by EPEL yum repo
    Code:
     yum list -q nas svgalib
    Installed Packages
    svgalib.x86_64                                               1.9.25-14.el6                                                @epel
    Available Packages
    nas.x86_64                                                   1.9.1-7.el6                                                  epel
    nothing in CentOS 7's EPEL el7 repos
    Code:
    yum list -q nas svgalib --enablerepo=remi,remi-test,atrpms,epel,epel-testing --disableplugin=priorities
    Error: No matching Packages to list
    Let's work around this with some borrowed Fedora packages heh

    Code:
    wget ftp://fr2.rpmfind.net/linux/fedora/linux/releases/20/Everything/x86_64/os/Packages/l/libnemesi-0.7.0-0.5.20110215git.fc20.x86_64.rpm
    wget ftp://fr2.rpmfind.net/linux/fedora/linux/releases/20/Everything/x86_64/os/Packages/n/nas-libs-1.9.4-1.fc20.x86_64.rpm
    wget ftp://fr2.rpmfind.net/linux/fedora/linux/releases/20/Everything/x86_64/os/Packages/s/svgalib-1.9.25-14.fc20.x86_64.rpm
    wget ftp://fr2.rpmfind.net/linux/fedora/linux/releases/20/Everything/x86_64/os/Packages/n/netembryo-0.1.1-5.fc20.x86_64.rpm
    
    yum localinstall *.rpm
    Code:
    yum -y install ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=atrpms
    
    No package flvtool2 available.
    Package libvpx-1.3.0-5.el7_0.x86_64 already installed and latest version
    Package libvpx-devel-1.3.0-5.el7_0.x86_64 already installed and latest version
    No package amrnb-devel available.
    No package amrwb-devel available.
    No package facc available.
    No package a52decoder available.
    
    
    Code:
    Dependencies Resolved
    
    ===============================================================================================================================
    Package                               Arch               Version                                   Repository            Size
    ===============================================================================================================================
    Installing:
    faad2                                 x86_64             1:2.7-18.el7                              atrpms                35 k
    ffmpeg                                x86_64             2.2.1-65.el7                              atrpms               1.6 M
    ffmpeg-devel                          x86_64             2.2.1-65.el7                              atrpms               5.4 M
    lame                                  x86_64             3.99.3-23.el7                             atrpms               345 k
    libid3tag                             x86_64             0.15.1b-17.el7                            base                  48 k
    libogg                                x86_64             2:1.3.0-7.el7                             base                  24 k
    libvorbis                             x86_64             1:1.3.3-8.el7                             base                 204 k
    libvorbis-devel                       x86_64             1:1.3.3-8.el7                             base                  21 k
    libvorbis-devel-docs                  noarch             1:1.3.3-8.el7                             base                 162 k
    libwmf                                x86_64             0.2.8.4-39.el7                            base                 134 k
    mingw32-libvorbis                     noarch             1.3.4-1.el7                               epel                 187 k
    mingw64-libvorbis                     noarch             1.3.4-1.el7                               epel                 194 k
    mplayer                               x86_64             4:1.2-93_snap20140413.el7                 atrpms                14 M
    nasm                                  x86_64             2.10.07-7.el7                             base                 402 k
    ruby                                  x86_64             2.0.0.598-25.el7_1                        updates               67 k
    ruby-devel                            x86_64             2.0.0.598-25.el7_1                        updates              127 k
    ruby-libs                             x86_64             2.0.0.598-25.el7_1                        updates              2.8 M
    vorbis-tools                          x86_64             1:1.4.0-12.el7                            base                 214 k
    xvidcore                              x86_64             1.3.2-15.el7                              atrpms               169 k
    xvidcore-devel                        x86_64             1.3.2-15.el7                              atrpms               203 k
    yasm                                  x86_64             1.2.0-4.el7                               epel                 398 k
    Installing for dependencies:
    SDL                                   x86_64             1.2.15-11.el7                             base                 204 k
    a52dec-devel                          x86_64             0.7.4-7.0.1.el7                           atrpms                31 k
    aalib-libs                            x86_64             1.4.0-0.22.rc5.el7                        epel                  65 k
    arts                                  x86_64             8:1.5.10-26.el7                           epel                 969 k
    atk                                   x86_64             2.8.0-4.el7                               base                 233 k
    audiofile                             x86_64             1:0.3.6-4.el7                             base                 153 k
    cdparanoia-libs                       x86_64             10.2-17.el7                               base                  56 k
    dirac-libs                            x86_64             1.0.2-14.el7                              epel                 256 k
    enca                                  x86_64             1.14-1.el7                                epel                 106 k
    esound-libs                           x86_64             1:0.2.41-12.el7                           epel                  78 k
    faad2-devel                           x86_64             1:2.7-18.el7                              atrpms               219 k
    flac-libs                             x86_64             1.3.0-5.el7_1                             updates              169 k
    freeglut                              x86_64             2.8.1-3.el7                               base                 182 k
    giflib                                x86_64             4.1.6-9.el7                               base                  40 k
    glib                                  x86_64             1:1.2.10-41.el7                           epel                 137 k
    glibmm24                              x86_64             2.36.2-4.el7                              base                 433 k
    gpm-libs                              x86_64             1.20.7-5.el7                              base                  32 k
    gsm                                   x86_64             1.0.13-11.el7                             base                  30 k
    gsm-devel                             x86_64             1.0.13-11.el7                             base                  14 k
    gtk+                                  x86_64             1:1.2.10-77.el7                           epel                 841 k
    gtk2                                  x86_64             2.24.22-5.el7_0.1                         base                 3.4 M
    hicolor-icon-theme                    noarch             0.12-7.el7                                base                  42 k
    jack-audio-connection-kit             x86_64             1.9.9.5-4.el7                             epel                 522 k
    lame-devel                            x86_64             3.99.3-23.el7                             atrpms                24 k
    libXScrnSaver                         x86_64             1.2.2-6.1.el7                             base                  24 k
    libXcomposite                         x86_64             0.4.4-4.1.el7                             base                  22 k
    libXcursor                            x86_64             1.1.14-2.1.el7                            base                  30 k
    libXi                                 x86_64             1.7.2-2.1.el7                             base                  39 k
    libXinerama                           x86_64             1.1.3-2.1.el7                             base                  14 k
    libXrandr                             x86_64             1.4.1-2.1.el7                             base                  25 k
    libXtst                               x86_64             1.2.2-2.1.el7                             base                  20 k
    libXv                                 x86_64             1.0.9-2.1.el7                             base                  18 k
    libXvMC                               x86_64             1.0.8-2.1.el7                             base                  22 k
    libXxf86dga                           x86_64             1.1.4-2.1.el7                             base                  19 k
    liba52_0                              x86_64             0.7.4-7.0.1.el7                           atrpms                27 k
    libao                                 x86_64             1.1.0-8.el7                               base                  72 k
    libasyncns                            x86_64             0.8-7.el7                                 base                  26 k
    libavcodec55                          x86_64             2.2.1-65.el7                              atrpms               3.3 M
    libavdevice55                         x86_64             2.2.1-65.el7                              atrpms                38 k
    libavfilter4                          x86_64             2.2.1-65.el7                              atrpms               346 k
    libavformat55                         x86_64             2.2.1-65.el7                              atrpms               677 k
    libavutil52                           x86_64             2.2.1-65.el7                              atrpms               118 k
    libcaca                               x86_64             0.99-0.17.beta17.el7                      epel                 216 k
    libconfig                             x86_64             1.4.9-5.el7                               base                  59 k
    libdc1394                             x86_64             2.2.2-3.el7                               epel                 121 k
    libdc1394-devel                       x86_64             2.2.2-3.el7                               epel                  53 k
    libdca0                               x86_64             0.0.5-4.el7                               atrpms                91 k
    libdirect-1.7_4                       x86_64             1.7.4-17.el7                              atrpms                62 k
    libdirectfb-1.7_4                     x86_64             1.7.4-17.el7                              atrpms               399 k
    libdv                                 x86_64             1.0.0-17.el7                              base                  78 k
    libfaac0                              x86_64             1.28-6.el7                                atrpms                36 k
    libfaad2                              x86_64             1:2.7-18.el7                              atrpms               142 k
    libffado                              x86_64             2.1.0-4.el7                               epel                 650 k
    libfusion-1.7_4                       x86_64             1.7.4-17.el7                              atrpms                27 k
    libiec61883                           x86_64             1.2.0-10.el7                              base                  37 k
    libldb                                x86_64             1.1.17-2.el7                              base                 122 k
    libmad0                               x86_64             0.15.1b-4.el7                             atrpms                54 k
    libmikmod                             x86_64             3.2.0-21.el7                              epel                 138 k
    libmng                                x86_64             1.0.10-14.el7                             base                 171 k
    libmp3lame0                           x86_64             3.99.3-23.el7                             atrpms               131 k
    libmpeg2_0                            x86_64             0.5.1-5.el7                               atrpms                38 k
    libogg-devel                          x86_64             2:1.3.0-7.el7                             base                  13 k
    libopencore-amrnb0                    x86_64             0.1.3-1.el7                               atrpms                93 k
    libopencore-amrwb0                    x86_64             0.1.3-1.el7                               atrpms                46 k
    libpostproc52                         x86_64             2.2.1-65.el7                              atrpms                44 k
    libraw1394                            x86_64             2.1.0-2.el7                               base                  63 k
    libraw1394-devel                      x86_64             2.1.0-2.el7                               base                  39 k
    librtmp0                              x86_64             2.3-1.el7                                 atrpms                42 k
    libsamplerate                         x86_64             0.1.8-6.el7                               base                 1.0 M
    libsigc++20                           x86_64             2.3.1-4.el7                               base                  59 k
    libsmbclient                          x86_64             4.1.12-23.el7_1                           updates              120 k
    libsndfile                            x86_64             1.0.25-9.el7                              base                 149 k
    libswresample0                        x86_64             2.2.1-65.el7                              atrpms                41 k
    libswscale2                           x86_64             2.2.1-65.el7                              atrpms               114 k
    libtalloc                             x86_64             2.1.1-1.el7                               base                  30 k
    libtdb                                x86_64             1.3.0-1.el7                               base                  44 k
    libtevent                             x86_64             0.9.21-3.el7                              base                  31 k
    libtheora                             x86_64             1:1.1.1-8.el7                             base                 136 k
    libtheora-devel                       x86_64             1:1.1.1-8.el7                             base                  33 k
    libusbx                               x86_64             1.0.15-4.el7                              base                  50 k
    libva1                                x86_64             1.3.1-11.el7                              atrpms                37 k
    libvdpau                              x86_64             0.9-1.el7                                 epel                  32 k
    libwbclient                           x86_64             4.1.12-23.el7_1                           updates               90 k
    libx264_142                           x86_64             0.142-20_20140406.2245.el7                atrpms               372 k
    libxavs1                              x86_64             0.1.51-2.el7                              atrpms               131 k
    libxml++                              x86_64             2.37.1-1.el7                              epel                  99 k
    libxvidcore4                          x86_64             1.3.2-15.el7                              atrpms               178 k
    libyaml                               x86_64             0.1.4-11.el7_0                            base                  55 k
    lirc-libs                             x86_64             0.9.1a-4.el7                              epel                  39 k
    live                                  x86_64             2012.02.04-1.el7                          atrpms               292 k
    mingw-filesystem-base                 noarch             100-1.el7                                 epel                  34 k
    mingw32-crt                           noarch             4.0.2-1.el7                               epel                 1.3 M
    mingw32-filesystem                    noarch             100-1.el7                                 epel                 150 k
    mingw32-libogg                        noarch             1.3.0-4.el7                               epel                  27 k
    mingw32-pkg-config                    x86_64             0.28-2.el7                                epel                  47 k
    mingw64-crt                           noarch             4.0.2-1.el7                               epel                 2.4 M
    mingw64-filesystem                    noarch             100-1.el7                                 epel                 174 k
    mingw64-libogg                        noarch             1.3.0-4.el7                               epel                  28 k
    mingw64-pkg-config                    x86_64             0.28-2.el7                                epel                  47 k
    mpg123                                x86_64             1.18.1-1.el7                              atrpms               260 k
    mplayer-fonts                         noarch             4:1.0-7.at                                atrpms               1.0 M
    mplayer-skins                         noarch             4:1.0-16                                  atrpms                14 M
    openal-soft                           x86_64             1.16.0-2.el7                              epel                 282 k
    openjpeg-libs                         x86_64             1.5.1-10.el7                              base                  85 k
    opus                                  x86_64             1.0.2-6.el7                               base                 630 k
    orc                                   x86_64             0.4.17-5.el7                              base                 164 k
    portaudio                             x86_64             19-16.el7                                 epel                  88 k
    pulseaudio-libs                       x86_64             3.0-30.el7                                base                 556 k
    pytalloc                              x86_64             2.1.1-1.el7                               base                  13 k
    qt3                                   x86_64             3.3.8b-51.el7                             base                 3.5 M
    ruby-irb                              noarch             2.0.0.598-25.el7_1                        updates               88 k
    rubygem-bigdecimal                    x86_64             1.2.0-25.el7_1                            updates               79 k
    rubygem-io-console                    x86_64             0.4.2-25.el7_1                            updates               50 k
    rubygem-json                          x86_64             1.7.7-25.el7_1                            updates               75 k
    rubygem-psych                         x86_64             2.0.0-25.el7_1                            updates               77 k
    rubygem-rdoc                          noarch             4.0.0-25.el7_1                            updates              318 k
    rubygems                              noarch             2.0.14-25.el7_1                           updates              212 k
    samba-common                          x86_64             4.1.12-23.el7_1                           updates              709 k
    samba-libs                            x86_64             4.1.12-23.el7_1                           updates              4.3 M
    schroedinger                          x86_64             1.0.11-4.el7                              epel                 291 k
    speex                                 x86_64             1.2-0.19.rc1.el7                          base                  98 k
    twolame                               x86_64             0.3.13-1.el7.rf                           rpmforge             134 k
    x264-devel                            x86_64             0.142-20_20140406.2245.el7                atrpms                19 k
    xmms-libs                             x86_64             1:1.2.11-40.el7                           atrpms               271 k
    
    Transaction Summary
    ===============================================================================================================================
    Install  21 Packages (+124 Dependent packages)
    
    Total download size: 78 M
    Installed size: 313 M
    
    Code:
    
    Installed:
      faad2.x86_64 1:2.7-18.el7                 ffmpeg.x86_64 0:2.2.1-65.el7            ffmpeg-devel.x86_64 0:2.2.1-65.el7    
      lame.x86_64 0:3.99.3-23.el7               libid3tag.x86_64 0:0.15.1b-17.el7       libogg.x86_64 2:1.3.0-7.el7          
      libvorbis.x86_64 1:1.3.3-8.el7            libvorbis-devel.x86_64 1:1.3.3-8.el7    libvorbis-devel-docs.noarch 1:1.3.3-8.el7
      libwmf.x86_64 0:0.2.8.4-39.el7            mingw32-libvorbis.noarch 0:1.3.4-1.el7  mingw64-libvorbis.noarch 0:1.3.4-1.el7
      mplayer.x86_64 4:1.2-93_snap20140413.el7  nasm.x86_64 0:2.10.07-7.el7             ruby.x86_64 0:2.0.0.598-25.el7_1      
      ruby-devel.x86_64 0:2.0.0.598-25.el7_1    ruby-libs.x86_64 0:2.0.0.598-25.el7_1   vorbis-tools.x86_64 1:1.4.0-12.el7    
      xvidcore.x86_64 0:1.3.2-15.el7            xvidcore-devel.x86_64 0:1.3.2-15.el7    yasm.x86_64 0:1.2.0-4.el7            
    
    Dependency Installed:
      SDL.x86_64 0:1.2.15-11.el7                                     a52dec-devel.x86_64 0:0.7.4-7.0.1.el7                    
      aalib-libs.x86_64 0:1.4.0-0.22.rc5.el7                         arts.x86_64 8:1.5.10-26.el7                              
      atk.x86_64 0:2.8.0-4.el7                                       audiofile.x86_64 1:0.3.6-4.el7                          
      cdparanoia-libs.x86_64 0:10.2-17.el7                           dirac-libs.x86_64 0:1.0.2-14.el7                        
      enca.x86_64 0:1.14-1.el7                                       esound-libs.x86_64 1:0.2.41-12.el7                      
      faad2-devel.x86_64 1:2.7-18.el7                                flac-libs.x86_64 0:1.3.0-5.el7_1                        
      freeglut.x86_64 0:2.8.1-3.el7                                  giflib.x86_64 0:4.1.6-9.el7                              
      glib.x86_64 1:1.2.10-41.el7                                    glibmm24.x86_64 0:2.36.2-4.el7                          
      gpm-libs.x86_64 0:1.20.7-5.el7                                 gsm.x86_64 0:1.0.13-11.el7                              
      gsm-devel.x86_64 0:1.0.13-11.el7                               gtk+.x86_64 1:1.2.10-77.el7                              
      gtk2.x86_64 0:2.24.22-5.el7_0.1                                hicolor-icon-theme.noarch 0:0.12-7.el7                  
      jack-audio-connection-kit.x86_64 0:1.9.9.5-4.el7               lame-devel.x86_64 0:3.99.3-23.el7                        
      libXScrnSaver.x86_64 0:1.2.2-6.1.el7                           libXcomposite.x86_64 0:0.4.4-4.1.el7                    
      libXcursor.x86_64 0:1.1.14-2.1.el7                             libXi.x86_64 0:1.7.2-2.1.el7                            
      libXinerama.x86_64 0:1.1.3-2.1.el7                             libXrandr.x86_64 0:1.4.1-2.1.el7                        
      libXtst.x86_64 0:1.2.2-2.1.el7                                 libXv.x86_64 0:1.0.9-2.1.el7                            
      libXvMC.x86_64 0:1.0.8-2.1.el7                                 libXxf86dga.x86_64 0:1.1.4-2.1.el7                      
      liba52_0.x86_64 0:0.7.4-7.0.1.el7                              libao.x86_64 0:1.1.0-8.el7                              
      libasyncns.x86_64 0:0.8-7.el7                                  libavcodec55.x86_64 0:2.2.1-65.el7                      
      libavdevice55.x86_64 0:2.2.1-65.el7                            libavfilter4.x86_64 0:2.2.1-65.el7                      
      libavformat55.x86_64 0:2.2.1-65.el7                            libavutil52.x86_64 0:2.2.1-65.el7                        
      libcaca.x86_64 0:0.99-0.17.beta17.el7                          libconfig.x86_64 0:1.4.9-5.el7                          
      libdc1394.x86_64 0:2.2.2-3.el7                                 libdc1394-devel.x86_64 0:2.2.2-3.el7                    
      libdca0.x86_64 0:0.0.5-4.el7                                   libdirect-1.7_4.x86_64 0:1.7.4-17.el7                    
      libdirectfb-1.7_4.x86_64 0:1.7.4-17.el7                        libdv.x86_64 0:1.0.0-17.el7                              
      libfaac0.x86_64 0:1.28-6.el7                                   libfaad2.x86_64 1:2.7-18.el7                            
      libffado.x86_64 0:2.1.0-4.el7                                  libfusion-1.7_4.x86_64 0:1.7.4-17.el7                    
      libiec61883.x86_64 0:1.2.0-10.el7                              libldb.x86_64 0:1.1.17-2.el7                            
      libmad0.x86_64 0:0.15.1b-4.el7                                 libmikmod.x86_64 0:3.2.0-21.el7                          
      libmng.x86_64 0:1.0.10-14.el7                                  libmp3lame0.x86_64 0:3.99.3-23.el7                      
      libmpeg2_0.x86_64 0:0.5.1-5.el7                                libogg-devel.x86_64 2:1.3.0-7.el7                        
      libopencore-amrnb0.x86_64 0:0.1.3-1.el7                        libopencore-amrwb0.x86_64 0:0.1.3-1.el7                  
      libpostproc52.x86_64 0:2.2.1-65.el7                            libraw1394.x86_64 0:2.1.0-2.el7                          
      libraw1394-devel.x86_64 0:2.1.0-2.el7                          librtmp0.x86_64 0:2.3-1.el7                              
      libsamplerate.x86_64 0:0.1.8-6.el7                             libsigc++20.x86_64 0:2.3.1-4.el7                        
      libsmbclient.x86_64 0:4.1.12-23.el7_1                          libsndfile.x86_64 0:1.0.25-9.el7                        
      libswresample0.x86_64 0:2.2.1-65.el7                           libswscale2.x86_64 0:2.2.1-65.el7                        
      libtalloc.x86_64 0:2.1.1-1.el7                                 libtdb.x86_64 0:1.3.0-1.el7                              
      libtevent.x86_64 0:0.9.21-3.el7                                libtheora.x86_64 1:1.1.1-8.el7                          
      libtheora-devel.x86_64 1:1.1.1-8.el7                           libusbx.x86_64 0:1.0.15-4.el7                            
      libva1.x86_64 0:1.3.1-11.el7                                   libvdpau.x86_64 0:0.9-1.el7                              
      libwbclient.x86_64 0:4.1.12-23.el7_1                           libx264_142.x86_64 0:0.142-20_20140406.2245.el7          
      libxavs1.x86_64 0:0.1.51-2.el7                                 libxml++.x86_64 0:2.37.1-1.el7                          
      libxvidcore4.x86_64 0:1.3.2-15.el7                             libyaml.x86_64 0:0.1.4-11.el7_0                          
      lirc-libs.x86_64 0:0.9.1a-4.el7                                live.x86_64 0:2012.02.04-1.el7                          
      mingw-filesystem-base.noarch 0:100-1.el7                       mingw32-crt.noarch 0:4.0.2-1.el7                        
      mingw32-filesystem.noarch 0:100-1.el7                          mingw32-libogg.noarch 0:1.3.0-4.el7                      
      mingw32-pkg-config.x86_64 0:0.28-2.el7                         mingw64-crt.noarch 0:4.0.2-1.el7                        
      mingw64-filesystem.noarch 0:100-1.el7                          mingw64-libogg.noarch 0:1.3.0-4.el7                      
      mingw64-pkg-config.x86_64 0:0.28-2.el7                         mpg123.x86_64 0:1.18.1-1.el7                            
      mplayer-fonts.noarch 4:1.0-7.at                                mplayer-skins.noarch 4:1.0-16                            
      openal-soft.x86_64 0:1.16.0-2.el7                              openjpeg-libs.x86_64 0:1.5.1-10.el7                      
      opus.x86_64 0:1.0.2-6.el7                                      orc.x86_64 0:0.4.17-5.el7                                
      portaudio.x86_64 0:19-16.el7                                   pulseaudio-libs.x86_64 0:3.0-30.el7                      
      pytalloc.x86_64 0:2.1.1-1.el7                                  qt3.x86_64 0:3.3.8b-51.el7                              
      ruby-irb.noarch 0:2.0.0.598-25.el7_1                           rubygem-bigdecimal.x86_64 0:1.2.0-25.el7_1              
      rubygem-io-console.x86_64 0:0.4.2-25.el7_1                     rubygem-json.x86_64 0:1.7.7-25.el7_1                    
      rubygem-psych.x86_64 0:2.0.0-25.el7_1                          rubygem-rdoc.noarch 0:4.0.0-25.el7_1                    
      rubygems.noarch 0:2.0.14-25.el7_1                              samba-common.x86_64 0:4.1.12-23.el7_1                    
      samba-libs.x86_64 0:4.1.12-23.el7_1                            schroedinger.x86_64 0:1.0.11-4.el7                      
      speex.x86_64 0:1.2-0.19.rc1.el7                                twolame.x86_64 0:0.3.13-1.el7.rf                        
      x264-devel.x86_64 0:0.142-20_20140406.2245.el7                 xmms-libs.x86_64 1:1.2.11-40.el7                        
    
    Complete!
    
    check ffmpeg-devel to see if it has a much more sensiable location for the headers

    Code:
    rpm -ql ffmpeg-devel
    /usr/include/libavcodec
    /usr/include/libavcodec/avcodec.h
    /usr/include/libavcodec/avfft.h
    /usr/include/libavcodec/dxva2.h
    /usr/include/libavcodec/old_codec_ids.h
    /usr/include/libavcodec/vaapi.h
    /usr/include/libavcodec/vda.h
    /usr/include/libavcodec/vdpau.h
    /usr/include/libavcodec/version.h
    /usr/include/libavcodec/xvmc.h
    /usr/include/libavdevice
    /usr/include/libavdevice/avdevice.h
    /usr/include/libavdevice/version.h
    /usr/include/libavfilter
    /usr/include/libavfilter/asrc_abuffer.h
    /usr/include/libavfilter/avcodec.h
    /usr/include/libavfilter/avfilter.h
    /usr/include/libavfilter/avfiltergraph.h
    /usr/include/libavfilter/buffersink.h
    /usr/include/libavfilter/buffersrc.h
    /usr/include/libavfilter/version.h
    /usr/include/libavformat
    /usr/include/libavformat/avformat.h
    /usr/include/libavformat/avio.h
    /usr/include/libavformat/version.h
    /usr/include/libavutil
    /usr/include/libavutil/adler32.h
    /usr/include/libavutil/aes.h
    /usr/include/libavutil/attributes.h
    /usr/include/libavutil/audio_fifo.h
    /usr/include/libavutil/audioconvert.h
    /usr/include/libavutil/avassert.h
    /usr/include/libavutil/avconfig.h
    /usr/include/libavutil/avstring.h
    /usr/include/libavutil/avutil.h
    /usr/include/libavutil/base64.h
    /usr/include/libavutil/blowfish.h
    /usr/include/libavutil/bprint.h
    /usr/include/libavutil/bswap.h
    /usr/include/libavutil/buffer.h
    /usr/include/libavutil/channel_layout.h
    /usr/include/libavutil/common.h
    /usr/include/libavutil/cpu.h
    /usr/include/libavutil/crc.h
    /usr/include/libavutil/dict.h
    /usr/include/libavutil/downmix_info.h
    /usr/include/libavutil/error.h
    /usr/include/libavutil/eval.h
    /usr/include/libavutil/ffversion.h
    /usr/include/libavutil/fifo.h
    /usr/include/libavutil/file.h
    /usr/include/libavutil/frame.h
    /usr/include/libavutil/hmac.h
    /usr/include/libavutil/imgutils.h
    /usr/include/libavutil/intfloat.h
    /usr/include/libavutil/intfloat_readwrite.h
    /usr/include/libavutil/intreadwrite.h
    /usr/include/libavutil/lfg.h
    /usr/include/libavutil/log.h
    /usr/include/libavutil/lzo.h
    /usr/include/libavutil/macros.h
    /usr/include/libavutil/mathematics.h
    /usr/include/libavutil/md5.h
    /usr/include/libavutil/mem.h
    /usr/include/libavutil/murmur3.h
    /usr/include/libavutil/old_pix_fmts.h
    /usr/include/libavutil/opt.h
    /usr/include/libavutil/parseutils.h
    /usr/include/libavutil/pixdesc.h
    /usr/include/libavutil/pixfmt.h
    /usr/include/libavutil/random_seed.h
    /usr/include/libavutil/rational.h
    /usr/include/libavutil/ripemd.h
    /usr/include/libavutil/samplefmt.h
    /usr/include/libavutil/sha.h
    /usr/include/libavutil/sha512.h
    /usr/include/libavutil/stereo3d.h
    /usr/include/libavutil/time.h
    /usr/include/libavutil/timecode.h
    /usr/include/libavutil/timestamp.h
    /usr/include/libavutil/version.h
    /usr/include/libavutil/xtea.h
    /usr/include/libpostproc
    /usr/include/libpostproc/postprocess.h
    /usr/include/libpostproc/version.h
    /usr/include/libswresample
    /usr/include/libswresample/swresample.h
    /usr/include/libswresample/version.h
    /usr/include/libswscale
    /usr/include/libswscale/swscale.h
    /usr/include/libswscale/version.h
    /usr/lib64/libavcodec.a
    /usr/lib64/libavcodec.so
    /usr/lib64/libavdevice.a
    /usr/lib64/libavdevice.so
    /usr/lib64/libavfilter.a
    /usr/lib64/libavfilter.so
    /usr/lib64/libavformat.a
    /usr/lib64/libavformat.so
    /usr/lib64/libavutil.a
    /usr/lib64/libavutil.so
    /usr/lib64/libpostproc.a
    /usr/lib64/libpostproc.so
    /usr/lib64/libswresample.a
    /usr/lib64/libswresample.so
    /usr/lib64/libswscale.a
    /usr/lib64/libswscale.so
    /usr/lib64/pkgconfig/libavcodec.pc
    /usr/lib64/pkgconfig/libavdevice.pc
    /usr/lib64/pkgconfig/libavfilter.pc
    /usr/lib64/pkgconfig/libavformat.pc
    /usr/lib64/pkgconfig/libavutil.pc
    /usr/lib64/pkgconfig/libpostproc.pc
    /usr/lib64/pkgconfig/libswresample.pc
    /usr/lib64/pkgconfig/libswscale.pc
    /usr/share/man/man3/libavcodec.3.gz
    /usr/share/man/man3/libavdevice.3.gz
    /usr/share/man/man3/libavfilter.3.gz
    /usr/share/man/man3/libavformat.3.gz
    /usr/share/man/man3/libavutil.3.gz
    /usr/share/man/man3/libswresample.3.gz
    /usr/share/man/man3/libswscale.3.gz
    nope fails at make stage
    Code:
    / -DHAVE_CONFIG_H -g -O2 -Wall -fno-strict-aliasing -c /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c  -fPIC -DPIC -o .libs/ffmpeg-php.o
    In file included from /usr/include/sys/stat.h:106:0,
                     from /usr/local/include/php/main/php_streams.h:28,
                     from /usr/local/include/php/main/php.h:398,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/include/bits/stat.h:91:21: error: field ‘st_atim’ has incomplete type
         struct timespec st_atim;  /* Time of last access.  */
                         ^
    /usr/include/bits/stat.h:92:21: error: field ‘st_mtim’ has incomplete type
         struct timespec st_mtim;  /* Time of last modification.  */
                         ^
    /usr/include/bits/stat.h:93:21: error: field ‘st_ctim’ has incomplete type
         struct timespec st_ctim;  /* Time of last status change.  */
                         ^
    /usr/include/bits/stat.h:152:21: error: field ‘st_atim’ has incomplete type
         struct timespec st_atim;  /* Time of last access.  */
                         ^
    /usr/include/bits/stat.h:153:21: error: field ‘st_mtim’ has incomplete type
         struct timespec st_mtim;  /* Time of last modification.  */
                         ^
    /usr/include/bits/stat.h:154:21: error: field ‘st_ctim’ has incomplete type
         struct timespec st_ctim;  /* Time of last status change.  */
                         ^
    In file included from /usr/local/include/php/main/php_streams.h:28:0,
                     from /usr/local/include/php/main/php.h:398,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/include/sys/stat.h:366:31: error: array type has incomplete element type
             const struct timespec __times[2],
                                   ^
    /usr/include/sys/stat.h:373:54: error: array type has incomplete element type
    extern int futimens (int __fd, const struct timespec __times[2]) __THROW;
                                                          ^
    In file included from /usr/local/include/php/main/php.h:404:0,
                     from /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:40:
    /usr/local/include/php/Zend/zend_virtual_cwd.h:220:2: error: unknown type name ‘time_t’
      time_t                         expires;
      ^
    /usr/local/include/php/Zend/zend_virtual_cwd.h:248:86: error: unknown type name ‘time_t’
    CWD_API realpath_cache_bucket* realpath_cache_lookup(const char *path, int path_len, time_t t TSRMLS_DC);
                                                                                          ^
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c: In function ‘zm_startup_ffmpeg’:
    /svr-setup/ffmpeg-php-0.6.0/ffmpeg-php.c:94:5: warning: implicit declaration of function ‘avcodec_init’ [-Wimplicit-function-declaration]
         avcodec_init();
         ^
    make: *** [ffmpeg-php.lo] Error 1
    problem is the source ffmpeg-php code.. so let's try a different source

    Code:
    cd /svr-setup
    mv ffmpeg-php-0.6.0 ffmpeg-php-0.6.0-old
    git clone https://github.com/tony2001/ffmpeg-php.git ffmpeg-php-0.6.0
    cd ffmpeg-php-0.6.0
    phpize
    ./configure --with-php-config=/usr/local/bin/php-config
    make
    make install
    
    Setup ffmpeg.ini file
    Code:
    echo "" >> /etc/centminmod/php.d/ffmpeg.ini
    echo "[ffmpeg]" >> /etc/centminmod/php.d/ffmpeg.ini
    echo "extension=ffmpeg.so" >> /etc/centminmod/php.d/ffmpeg.ini
    
    restart php-fpm
    Code:
    fpmrestart
    Working ffmpeg for CentOS 7 with updated ffmpeg-php 0.7.0 :D So looks like i need to work on centmin.sh menu 19 !
    Code:
    php --ri ffmpeg
    
    ffmpeg
    
    ffmpeg-php version => 0.7.0
    ffmpeg-php built on => Jul 15 2015 19:52:53
    ffmpeg-php gd support  => disabled
    ffmpeg libavcodec version => Lavc55.52.102
    ffmpeg libavcodec license => GPL version 3 or later
    ffmpeg libavformat version => Lavf55.33.100
    ffmpeg libavformat license => GPL version 3 or later
    ffmpeg swscaler version => SwS2.5.102
    ffmpeg swscaler license => GPL version 3 or later
    ffmpeg codec_list => a64multi(v), a64multi5(v), aasc(v), aic(v), amv(v), amv(v), anm(v), ansi(v), asv1(v), asv1(v), asv2(v), asv2(v), aura(v), aura2(v), avrp(v), avrp(v), avrn(v), avs(v), avui(v), avui(v), ayuv(v), ayuv(v), bethsoftvid(v), bfi(v), binkvideo(v), bmp(v), bmp(v), bmv_video(v), brender_pix(v), c93(v), cavs(v), cdgraphics(v), cdxl(v), cinepak(v), cinepak(v), cljr(v), cljr(v), cllc(v), comfortnoise(a), comfortnoise(a), cpia(v), camstudio(v), cyuv(v), dfa(v), dirac(v), dnxhd(v), dnxhd(v), dpx(v), dpx(v), dsicinvideo(v), dvvideo(v), dvvideo(v), dxa(v), dxtory(v), eacmv(v), eamad(v), eatgq(v), eatgv(v), eatqi(v), 8bps(v), 8svx_exp(a), 8svx_fib(a), escape124(v), escape130(v), exr(v), ffv1(v), ffv1(v), ffvhuff(v), ffvhuff(v), fic(v), flashsv(v), flashsv(v), flashsv2(v), flashsv2(v), flic(v), flv(v), flv(v), 4xm(v), fraps(v), frwu(v), g2m(v), gif(v), gif(v), h261(v), h261(v), h263(v), h263(v), h263i(v), h263p(v), h263p(v), h264(v), h264_vdpau(v), hevc(v), hnm4video(v), huffyuv(v), huffyuv(v), idcinvideo(v), iff(v), iff(v), indeo2(v), indeo3(v), indeo4(v), indeo5(v), interplayvideo(v), jpeg2000(v), jpeg2000(v), jpegls(v), jpegls(v), jv(v), kgv1(v), kmvc(v), lagarith(v), ljpeg(v), loco(v), mdec(v), mimic(v), mjpeg(v), mjpeg(v), mjpegb(v), mmvideo(v), motionpixels(v), mpeg1video(v), mpeg1video(v), mpeg2video(v), mpeg2video(v), mpeg4(v), mpeg4(v), mpeg4_vdpau(v), mpegvideo(v), mpegvideo_vdpau(v), mpeg1video_vdpau(v), msa1(v), msmpeg4v1(v), msmpeg4v2(v), msmpeg4v2(v), msmpeg4(v), msmpeg4(v), msrle(v), mss1(v), mss2(v), msvideo1(v), msvideo1(v), mszh(v), mts2(v), mvc1(v), mvc2(v), mxpeg(v), nuv(v), paf_video(v), pam(v), pam(v), pbm(v), pbm(v), pcx(v), pcx(v), pgm(v), pgm(v), pgmyuv(v), pgmyuv(v), pictor(v), png(v), png(v), ppm(v), ppm(v), prores(v), prores(v), prores_aw(v), prores_ks(v), prores_lgpl(v), ptx(v), qdraw(v), qpeg(v), qtrle(v), qtrle(v), r10k(v), r10k(v), r210(v), r210(v), rawvideo(v), rawvideo(v), rl2(v), roqvideo(v), roqvideo(v), rpza(v), rv10(v), rv10(v), rv20(v), rv20(v), rv30(v), rv40(v), s302m(a), s302m(a), sanm(v), sgi(v), sgi(v), sgirle(v), smackvid(v), smc(v), smvjpeg(v), snow(v), snow(v), sp5x(v), sunrast(v), sunrast(v), svq1(v), svq1(v), svq3(v), targa(v), targa(v), targa_y216(v), theora(v), thp(v), tiertexseqvideo(v), tiff(v), tiff(v), tmv(v), truemotion1(v), truemotion2(v), camtasia(v), tscc2(v), txd(v), ultimotion(v), utvideo(v), utvideo(v), v210(v), v210(v), v210x(v), v308(v), v308(v), v408(v), v408(v), v410(v), v410(v), vb(v), vble(v), vc1(v), vc1_vdpau(v), vc1image(v), vcr1(v), vmdvideo(v), vmnc(v), vp3(v), vp5(v), vp6(v), vp6a(v), vp6f(v), vp8(v), vp9(v), vqavideo(v), webp(v), wmv1(v), wmv1(v), wmv2(v), wmv2(v), wmv3(v), wmv3_vdpau(v), wmv3image(v), wnv1(v), xan_wc3(v), xan_wc4(v), xbm(v), xbm(v), xface(v), xface(v), xl(v), xwd(v), xwd(v), y41p(v), y41p(v), yop(v), yuv4(v), yuv4(v), 012v(v), zerocodec(v), zlib(v), zlib(v), zmbv(v), zmbv(v), aac(a), aac(a), aac_latm(a), ac3(a), ac3(a), ac3_fixed(a), alac(a), alac(a), als(a), amrnb(a), amrwb(a), ape(a), atrac1(a), atrac3(a), atrac3plus(a), binkaudio_dct(a), binkaudio_rdft(a), bmv_audio(a), cook(a), dca(a), dca(a), dsicinaudio(a), eac3(a), eac3(a), evrc(a), wavesynth(a), flac(a), flac(a), g723_1(a), g723_1(a), g729(a), gsm(a), gsm_ms(a), iac(a), imc(a), mace3(a), mace6(a), metasound(a), mlp(a), mp1(a), mp1float(a), mp2(a), mp2(a), mp2float(a), mp2fixed(a), mp3(a), mp3float(a), mp3adu(a), mp3adufloat(a), mp3on4(a), mp3on4float(a), mpc7(a), mpc8(a), nellymoser(a), nellymoser(a), paf_audio(a), qcelp(a), qdm2(a), real_144(a), real_144(a), real_288(a), ralf(a), shorten(a), sipr(a), smackaud(a), sonic(a), sonic(a), sonicls(a), tak(a), truehd(a), truespeech(a), tta(a), tta(a), twinvq(a), vmdaudio(a), vorbis(a), vorbis(a), wavpack(a), wavpack(a), wmalossless(a), wmapro(a), wmav1(a), wmav1(a), wmav2(a), wmav2(a), wmavoice(a), ws_snd1(a), pcm_alaw(a), pcm_alaw(a), pcm_bluray(a), pcm_dvd(a), pcm_f32be(a), pcm_f32be(a), pcm_f32le(a), pcm_f32le(a), pcm_f64be(a), pcm_f64be(a), pcm_f64le(a), pcm_f64le(a), pcm_lxf(a), pcm_mulaw(a), pcm_mulaw(a), pcm_s8(a), pcm_s8(a), pcm_s8_planar(a), pcm_s8_planar(a), pcm_s16be(a), pcm_s16be(a), pcm_s16be_planar(a), pcm_s16be_planar(a), pcm_s16le(a), pcm_s16le(a), pcm_s16le_planar(a), pcm_s16le_planar(a), pcm_s24be(a), pcm_s24be(a), pcm_s24daud(a), pcm_s24daud(a), pcm_s24le(a), pcm_s24le(a), pcm_s24le_planar(a), pcm_s24le_planar(a), pcm_s32be(a), pcm_s32be(a), pcm_s32le(a), pcm_s32le(a), pcm_s32le_planar(a), pcm_s32le_planar(a), pcm_u8(a), pcm_u8(a), pcm_u16be(a), pcm_u16be(a), pcm_u16le(a), pcm_u16le(a), pcm_u24be(a), pcm_u24be(a), pcm_u24le(a), pcm_u24le(a), pcm_u32be(a), pcm_u32be(a), pcm_u32le(a), pcm_u32le(a), pcm_zork(a), interplay_dpcm(a), roq_dpcm(a), roq_dpcm(a), sol_dpcm(a), xan_dpcm(a), adpcm_4xm(a), adpcm_adx(a), adpcm_adx(a), adpcm_afc(a), adpcm_ct(a), adpcm_dtk(a), adpcm_ea(a), adpcm_ea_maxis_xa(a), adpcm_ea_r1(a), adpcm_ea_r2(a), adpcm_ea_r3(a), adpcm_ea_xas(a), g722(a), g722(a), g726(a), g726(a), g726le(a), adpcm_ima_amv(a), adpcm_ima_apc(a), adpcm_ima_dk3(a), adpcm_ima_dk4(a), adpcm_ima_ea_eacs(a), adpcm_ima_ea_sead(a), adpcm_ima_iss(a), adpcm_ima_oki(a), adpcm_ima_qt(a), adpcm_ima_qt(a), adpcm_ima_rad(a), adpcm_ima_smjpeg(a), adpcm_ima_wav(a), adpcm_ima_wav(a), adpcm_ima_ws(a), adpcm_ms(a), adpcm_ms(a), adpcm_sbpro_2(a), adpcm_sbpro_3(a), adpcm_sbpro_4(a), adpcm_swf(a), adpcm_swf(a), adpcm_thp(a), adpcm_xa(a), adpcm_yamaha(a), adpcm_yamaha(a), vima(a), ssa(s), ssa(s), ass(s), ass(s), dvbsub(s), dvbsub(s), dvdsub(s), dvdsub(s), jacosub(s), microdvd(s), mov_text(s), mov_text(s), mpl2(s), pgssub(s), pjs(s), realtext(s), sami(s), srt(s), srt(s), subrip(s), subrip(s), subviewer(s), subviewer1(s), text(s), vplayer(s), webvtt(s), xsub(s), xsub(s), libgsm(a), libgsm(a), libgsm_ms(a), libgsm_ms(a), libmp3lame(a), libopencore_amrnb(a), libopencore_amrnb(a), libopencore_amrwb(a), libopenjpeg(v), libopenjpeg(v), libspeex(a), libspeex(a), libtheora(v), libvorbis(a), libvorbis(a), libvpx(v), libvpx(v), libx264(v), libx264rgb(v), libxavs(v), libxvid(v), bintext(v), xbin(v), idf(v),
    
    Directive => Local Value => Master Value
    ffmpeg.allow_persistent => 0 => 0
    ffmpeg.show_warnings => 0 => 0
    
     
    Last edited: Jul 16, 2015
  8. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    @Matt created an experimental Centmin Mod .08 beta03 branch = 123.08beta03-el7ffmpeg-fix with ATrpms repo integration and support and fixed centmin.sh menu option 19 ffmpeg php extension installation with a few July 16th commits Commits · centminmod/centminmod · GitHub

    Code:
    ---------------------------------------------------------------------------
    Total Curl Installer YUM Time: 75.2637 seconds
    Total YUM Time: 59.116081038 seconds
    Total YUM + Source Download Time: 83.9907
    Total Nginx First Time Install Time: 134.2309
    Total PHP First Time Install Time: 167.3461
    Download Zip From Github Time: 4.2156
    Total Time Other eg. source compiles: 214.8614
    Total Centmin Mod Install Time: 600.4291
    ---------------------------------------------------------------------------
    Total Install Time (curl yum + cm install + zip download): 679.9084 seconds
    ---------------------------------------------------------------------------
    repolist all supported Centmin Mod YUM repos on CentOS 7.1
    Code:
    yum repolist all -q
    repo id                              repo name                                                               status
    C7.0.1406-base/x86_64                CentOS-7.0.1406 - Base                                                  disabled
    C7.0.1406-centosplus/x86_64          CentOS-7.0.1406 - CentOSPlus                                            disabled
    C7.0.1406-extras/x86_64              CentOS-7.0.1406 - Extras                                                disabled
    C7.0.1406-fasttrack/x86_64           CentOS-7.0.1406 - CentOSPlus                                            disabled
    C7.0.1406-updates/x86_64             CentOS-7.0.1406 - Updates                                               disabled
    atrpms/7/x86_64                      Red Hat Enterprise Linux 7 - x86_64 - ATrpms                            disabled
    atrpms-bleeding/7/x86_64             Red Hat Enterprise Linux 7 - x86_64 - ATrpms bleeding                   disabled
    atrpms-bleeding-debuginfo/7/x86_64   Red Hat Enterprise Linux 7 - x86_64 - ATrpms bleeding - Debug           disabled
    atrpms-bleeding-source/7/x86_64      Red Hat Enterprise Linux 7 - x86_64 - ATrpms bleeding - Source          disabled
    atrpms-debuginfo/7/x86_64            Red Hat Enterprise Linux 7 - x86_64 - ATrpms - Debug                    disabled
    atrpms-source/7/x86_64               Red Hat Enterprise Linux 7 - x86_64 - ATrpms - Source                   disabled
    atrpms-testing/7/x86_64              Red Hat Enterprise Linux 7 - x86_64 - ATrpms testing                    disabled
    atrpms-testing-debuginfo/7/x86_64    Red Hat Enterprise Linux 7 - x86_64 - ATrpms testing - Debug            disabled
    atrpms-testing-source/7/x86_64       Red Hat Enterprise Linux 7 - x86_64 - ATrpms testing - Source           disabled
    axivo/7/x86_64                       AXIVO Packages for Enterprise Linux 7 - x86_64                          disabled
    axivoclient/7/x86_64                 AXIVO Client Packages for Enterprise Linux 7 - x86_64                   disabled
    axivoplus/7/x86_64                   AXIVO Plus Packages for Enterprise Linux 7 - x86_64                     disabled
    base/7/x86_64                        CentOS-7 - Base                                                         enabled: 6710+1942
    base-debuginfo/x86_64                CentOS-7 - Debuginfo                                                    disabled
    base-source/7                        CentOS-7 - Base Sources                                                 disabled
    centosplus/7/x86_64                  CentOS-7 - Plus                                                         disabled
    centosplus-source/7                  CentOS-7 - Plus Sources                                                 disabled
    cr/7/x86_64                          CentOS-7 - cr                                                           disabled
    epel/x86_64                          Extra Packages for Enterprise Linux 7 - x86_64                          enabled:  7583+682
    epel-debuginfo/x86_64                Extra Packages for Enterprise Linux 7 - x86_64 - Debug                  disabled
    epel-source/x86_64                   Extra Packages for Enterprise Linux 7 - x86_64 - Source                 disabled
    epel-testing/x86_64                  Extra Packages for Enterprise Linux 7 - Testing - x86_64                disabled
    epel-testing-debuginfo/x86_64        Extra Packages for Enterprise Linux 7 - Testing - x86_64 - Debug        disabled
    epel-testing-source/x86_64           Extra Packages for Enterprise Linux 7 - Testing - x86_64 - Source       disabled
    extras/7/x86_64                      CentOS-7 - Extras                                                       enabled:       149
    extras-source/7                      CentOS-7 - Extras Sources                                               disabled
    fasttrack/7/x86_64                   CentOS-7 - fasttrack                                                    disabled
    mariadb                              MariaDB                                                                 enabled:      10+4
    percona-experimental-noarch/7        Percona-Experimental YUM repository - noarch                            disabled
    percona-experimental-source/7        Percona-Experimental YUM repository - Source packages                   disabled
    percona-experimental-x86_64/7/x86_64 Percona-Experimental YUM repository - x86_64                            disabled
    percona-release-noarch/7             Percona-Release YUM repository - noarch                                 disabled
    percona-release-source/7             Percona-Release YUM repository - Source packages                        disabled
    percona-release-x86_64/7/x86_64      Percona-Release YUM repository - x86_64                                 disabled
    percona-testing-noarch/7             Percona-Testing YUM repository - noarch                                 disabled
    percona-testing-source/7             Percona-Testing YUM repository - Source packages                        disabled
    percona-testing-x86_64/7/x86_64      Percona-Testing YUM repository - x86_64                                 disabled
    remi                                 Les RPM de remi pour Enterprise Linux 7 - x86_64                        disabled
    remi-debuginfo/x86_64                Les RPM de remi pour Enterprise Linux 7 - x86_64 - debuginfo            disabled
    remi-php55                           Les RPM de remi de PHP 5.5 pour Enterprise Linux 7 - x86_64             disabled
    remi-php55-debuginfo/x86_64          Les RPM de remi de PHP 5.5 pour Enterprise Linux 7 - x86_64 - debuginfo disabled
    remi-php56                           Les RPM de remi de PHP 5.6 pour Enterprise Linux 7 - x86_64             disabled
    remi-php56-debuginfo/x86_64          Les RPM de remi de PHP 5.6 pour Enterprise Linux 7 - x86_64 - debuginfo disabled
    remi-test                            Les RPM de remi en test pour Enterprise Linux 7 - x86_64                disabled
    remi-test-debuginfo/x86_64           Les RPM de remi en test pour Enterprise Linux 7 - x86_64 - debuginfo    disabled
    rpmforge                             RHEL 7 - RPMforge.net - dag                                             enabled:    164+81
    rpmforge-extras                      RHEL 7 - RPMforge.net - extras                                          disabled
    rpmforge-testing                     RHEL 7 - RPMforge.net - testing                                         disabled
    updates/7/x86_64                     CentOS-7 - Updates                                                      enabled:   735+209
    updates-source/7                     CentOS-7 - Updates Sources                                              disabled
    varnish-3.0/x86_64                   Varnish 3.0 for Enterprise Linux el6 - x86_64                           disabled
    vz-base                              vz-base                                                                 enabled:         1
    vz-updates                           vz-updates                                                              enabled:         0
    Code:
     yum list ffmpeg ffmpeg-devel mplayer mencoder flvtool2 re2c yasm nasm libvpx libvpx-devel amrnb-devel amrwb-devel libid3tag libvorbis-devel lame libogg libwmf xvidcore xvidcore-devel facc faad2 a52decoder *vorbis* ruby ruby-libs ruby-devel --disableplugin=priorities --enablerepo=atrpms
    Loaded plugins: fastestmirror
    atrpms                                                                                                  | 3.0 kB  00:00:00 
    atrpms/7/x86_64/primary_db                                                                              | 459 kB  00:00:01 
    Loading mirror speeds from cached hostfile
    * base: centos-distro.cavecreek.net
    * epel: mirror.hmc.edu
    * extras: mirror.pac-12.org
    * rpmforge: mirror.webnx.com
    * updates: mirrors.psychz.net
    Installed Packages
    libvpx.x86_64                                               1.3.0-5.el7_0                                             @base
    libvpx-devel.x86_64                                         1.3.0-5.el7_0                                             @base
    re2c.x86_64                                                 0.14.3-1                                                  installed
    Available Packages
    faad2.x86_64                                                1:2.7-18.el7                                              atrpms
    ffmpeg.x86_64                                               2.2.1-65.el7                                              atrpms
    ffmpeg-devel.x86_64                                         2.2.1-65.el7                                              atrpms
    lame.x86_64                                                 3.99.3-23.el7                                             atrpms
    libid3tag.x86_64                                            0.15.1b-17.el7                                            base 
    libogg.x86_64                                               2:1.3.0-7.el7                                             base 
    libvorbis.x86_64                                            1:1.3.3-8.el7                                             base 
    libvorbis-devel.x86_64                                      1:1.3.3-8.el7                                             base 
    libvorbis-devel-docs.noarch                                 1:1.3.3-8.el7                                             base 
    libwmf.x86_64                                               0.2.8.4-39.el7                                            base 
    mingw32-libvorbis.noarch                                    1.3.4-1.el7                                               epel 
    mingw64-libvorbis.noarch                                    1.3.4-1.el7                                               epel 
    mplayer.x86_64                                              4:1.2-93_snap20140413.el7                                 atrpms
    nasm.x86_64                                                 2.10.07-7.el7                                             base 
    ruby.x86_64                                                 2.0.0.598-25.el7_1                                        updates
    ruby-devel.x86_64                                           2.0.0.598-25.el7_1                                        updates
    ruby-libs.x86_64                                            2.0.0.598-25.el7_1                                        updates
    vorbis-tools.x86_64                                         1:1.4.0-12.el7                                            base 
    xvidcore.x86_64                                             1.3.2-15.el7                                              atrpms
    xvidcore-devel.x86_64                                       1.3.2-15.el7                                              atrpms
    yasm.x86_64                                                 1.2.0-4.el7                                               epel     
    if you have centmin mod .08 beta 03 git environment setup via centmin.sh menu option 23 submenu 1, then switch to experimental branch can be done using centmin.sh menu option 23 submenu 3 and specify the branch = 123.08beta03-el7ffmpeg-fix

    Code:
    --------------------------------------------------------
    Centmin Mod 1.2.3-eva2000.08 - http://centminmod.com
    --------------------------------------------------------
                       Centmin Mod Menu                 
    --------------------------------------------------------
    1).  Centmin Install
    2).  Add Nginx vhost domain
    3).  NSD setup domain name DNS
    4).  Nginx Upgrade / Downgrade
    5).  PHP Upgrade / Downgrade
    6).  XCache Re-install
    7).  APC Cache Re-install
    8).  XCache Install
    9).  APC Cache Install
    10). Memcached Server Re-install
    11). MariaDB 5.2/5.5 & 10.x Upgrade Sub-Menu
    12). Zend OpCache Install/Re-install
    13). Install ioping.sh vbtechsupport.com/1239/
    14). SELinux disable
    15). Install/Reinstall ImagicK PHP Extension
    16). Change SSHD Port Number
    17). Multi-thread compression: pigz,pbzip2,lbzip2...
    18). Suhosin PHP Extension install
    19). Install FFMPEG and FFMPEG PHP Extension
    20). NSD Re-install
    21). Update - Nginx + PHP-FPM + Siege
    22). Add Wordpress Nginx vhost + WP Super Cache
    23). Update Centmin Mod Code Base
    24). Exit
    --------------------------------------------------------
    Enter option [ 1 - 24 ] 23
    --------------------------------------------------------
    
    --------------------------------------------------------
            Centmin Mod Updater Sub-Menu            
    --------------------------------------------------------
    1). Setup Centmin Mod Github Environment
    2). Update Centmin Mod Current Branch
    3). Update Centmin Mod Newer Branch
    4). Back to Main menu
    --------------------------------------------------------
    Enter option [ 1 - 4 ] 3
    --------------------------------------------------------
    
    Update Centmin Mod to newer branch via git
    You need to input the name of the branch
    List of current remote branches by descending date order
    
    2015-07-16 07:46:33 +1000 2 minutes ago 123.08beta03-el7ffmpeg-fix
    2015-07-15 05:22:07 +1000 26 hours ago  123.08beta03
    2015-07-13 16:28:45 +1000 3 days ago    master
    2015-07-13 16:28:45 +1000 3 days ago    master
    2015-07-10 19:59:08 +1000 6 days ago    123.07stable
    2015-06-29 13:57:14 +1000 2 weeks ago   123.08beta03curl743
    2015-06-14 13:15:27 +1000 5 weeks ago   123.08beta03-rtmp
    2015-06-10 00:47:37 +1000 5 weeks ago   123.08beta03-libresslclang
    2015-06-09 21:28:18 +1000 5 weeks ago   123.08beta03clang
    2015-06-03 21:13:57 +1000 6 weeks ago   123.08beta03libressl
    2015-05-27 15:54:13 +1000 7 weeks ago   123.08centos7beta02
    2015-03-25 03:45:39 +1000 4 months ago  123.08zerodown
    2015-03-10 16:52:37 +1000 4 months ago  123.08centos7beta01
    2014-06-23 17:08:44 +1000 1 year, 1 month ago   123.06stable
            ->
    
    Enter the branch name you want to switch to i.e. 123.08beta03 : 123.08beta03-el7ffmpeg-fix
    back up main menu via submenu option 4, then exist centmin.sh menu option 24
    Code:
    --------------------------------------------------------
            Centmin Mod Updater Sub-Menu            
    --------------------------------------------------------
    1). Setup Centmin Mod Github Environment
    2). Update Centmin Mod Current Branch
    3). Update Centmin Mod Newer Branch
    4). Back to Main menu
    --------------------------------------------------------
    Enter option [ 1 - 4 ] 4
    --------------------------------------------------------
    --------------------------------------------------------
    Centmin Mod 1.2.3-eva2000.08 - http://centminmod.com
    --------------------------------------------------------
                       Centmin Mod Menu                 
    --------------------------------------------------------
    1).  Centmin Install
    2).  Add Nginx vhost domain
    3).  NSD setup domain name DNS
    4).  Nginx Upgrade / Downgrade
    5).  PHP Upgrade / Downgrade
    6).  XCache Re-install
    7).  APC Cache Re-install
    8).  XCache Install
    9).  APC Cache Install
    10). Memcached Server Re-install
    11). MariaDB 5.2/5.5 & 10.x Upgrade Sub-Menu
    12). Zend OpCache Install/Re-install
    13). Install ioping.sh vbtechsupport.com/1239/
    14). SELinux disable
    15). Install/Reinstall ImagicK PHP Extension
    16). Change SSHD Port Number
    17). Multi-thread compression: pigz,pbzip2,lbzip2...
    18). Suhosin PHP Extension install
    19). Install FFMPEG and FFMPEG PHP Extension
    20). NSD Re-install
    21). Update - Nginx + PHP-FPM + Siege
    22). Add Wordpress Nginx vhost + WP Super Cache
    23). Update Centmin Mod Code Base
    24). Exit
    --------------------------------------------------------
    Enter option [ 1 - 24 ] 24
    --------------------------------------------------------
    switch to the experimental branch directory
    Code:
     cd ../centminmod-123.08beta03-el7ffmpeg-fix/
    run centmin.sh menu option 19
    Code:
    ./centmin.sh
    
    --------------------------------------------------------
    Centmin Mod 1.2.3-eva2000.08 - http://centminmod.com
    --------------------------------------------------------
                       Centmin Mod Menu                 
    --------------------------------------------------------
    1).  Centmin Install
    2).  Add Nginx vhost domain
    3).  NSD setup domain name DNS
    4).  Nginx Upgrade / Downgrade
    5).  PHP Upgrade / Downgrade
    6).  XCache Re-install
    7).  APC Cache Re-install
    8).  XCache Install
    9).  APC Cache Install
    10). Memcached Server Re-install
    11). MariaDB 5.2/5.5 & 10.x Upgrade Sub-Menu
    12). Zend OpCache Install/Re-install
    13). Install ioping.sh vbtechsupport.com/1239/
    14). SELinux disable
    15). Install/Reinstall ImagicK PHP Extension
    16). Change SSHD Port Number
    17). Multi-thread compression: pigz,pbzip2,lbzip2...
    18). Suhosin PHP Extension install
    19). Install FFMPEG and FFMPEG PHP Extension
    20). NSD Re-install
    21). Update - Nginx + PHP-FPM + Siege
    22). Add Wordpress Nginx vhost + WP Super Cache
    23). Update Centmin Mod Code Base
    24). Exit
    --------------------------------------------------------
    Enter option [ 1 - 24 ] 19
    --------------------------------------------------------
    FFMPEG install starting...
    CentOS 7 detected
    installing yum packages...
    Loaded plugins: fastestmirror, priorities
    Examining libnemesi-0.7.0-0.5.20110215git.fc20.x86_64.rpm: libnemesi-0.7.0-0.5.20110215git.fc20.x86_64
    Marking libnemesi-0.7.0-0.5.20110215git.fc20.x86_64.rpm to be installed
    Examining nas-libs-1.9.4-1.fc20.x86_64.rpm: nas-libs-1.9.4-1.fc20.x86_64
    Marking nas-libs-1.9.4-1.fc20.x86_64.rpm to be installed
    Examining svgalib-1.9.25-14.fc20.x86_64.rpm: svgalib-1.9.25-14.fc20.x86_64
    Marking svgalib-1.9.25-14.fc20.x86_64.rpm to be installed
    Examining netembryo-0.1.1-5.fc20.x86_64.rpm: netembryo-0.1.1-5.fc20.x86_64
    Marking netembryo-0.1.1-5.fc20.x86_64.rpm to be installed
    
    Code:
    ----------------------------------------------------------------------
    Libraries have been installed in:
       /svr-setup/ffmpeg-php-git/modules
    
    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the `-LLIBDIR'
    flag during linking and do at least one of the following:
       - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
         during execution
       - add LIBDIR to the `LD_RUN_PATH' environment variable
         during linking
       - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
       - have your system administrator add LIBDIR to `/etc/ld.so.conf'
    
    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ----------------------------------------------------------------------
    
    Build complete.
    Don't forget to run 'make test'.
    
    Installing shared extensions:     /usr/local/lib/php/extensions/no-debug-non-zts-20100525/
    
    FFMPEG PHP extension installed..
    restarting php-fpm service ...
    
    service php-fpm restart
    Gracefully shutting down php-fpm  done
    Starting php-fpm  done
    
    check phpinfo for FFMPEG PHP Extension...
    
    
    ffmpeg
    
    ffmpeg-php version => 0.7.0
    ffmpeg-php built on => Jul 15 2015 21:52:30
    ffmpeg-php gd support  => enabled
    ffmpeg libavcodec version => Lavc55.52.102
    ffmpeg libavcodec license => GPL version 3 or later
    ffmpeg libavformat version => Lavf55.33.100
    ffmpeg libavformat license => GPL version 3 or later
    ffmpeg swscaler version => SwS2.5.102
    ffmpeg swscaler license => GPL version 3 or later
    ffmpeg codec_list => a64multi(v), a64multi5(v), aasc(v), aic(v), amv(v), amv(v), anm(v), ansi(v), asv1(v), asv1(v), asv2(v), asv2(v), aura(v), aura2(v), avrp(v), avrp(v), avrn(v), avs(v), avui(v), avui(v), ayuv(v), ayuv(v), bethsoftvid(v), bfi(v), binkvideo(v), bmp(v), bmp(v), bmv_video(v), brender_pix(v), c93(v), cavs(v), cdgraphics(v), cdxl(v), cinepak(v), cinepak(v), cljr(v), cljr(v), cllc(v), comfortnoise(a), comfortnoise(a), cpia(v), camstudio(v), cyuv(v), dfa(v), dirac(v), dnxhd(v), dnxhd(v), dpx(v), dpx(v), dsicinvideo(v), dvvideo(v), dvvideo(v), dxa(v), dxtory(v), eacmv(v), eamad(v), eatgq(v), eatgv(v), eatqi(v), 8bps(v), 8svx_exp(a), 8svx_fib(a), escape124(v), escape130(v), exr(v), ffv1(v), ffv1(v), ffvhuff(v), ffvhuff(v), fic(v), flashsv(v), flashsv(v), flashsv2(v), flashsv2(v), flic(v), flv(v), flv(v), 4xm(v), fraps(v), frwu(v), g2m(v), gif(v), gif(v), h261(v), h261(v), h263(v), h263(v), h263i(v), h263p(v), h263p(v), h264(v), h264_vdpau(v), hevc(v), hnm4video(v), huffyuv(v), huffyuv(v), idcinvideo(v), iff(v), iff(v), indeo2(v), indeo3(v), indeo4(v), indeo5(v), interplayvideo(v), jpeg2000(v), jpeg2000(v), jpegls(v), jpegls(v), jv(v), kgv1(v), kmvc(v), lagarith(v), ljpeg(v), loco(v), mdec(v), mimic(v), mjpeg(v), mjpeg(v), mjpegb(v), mmvideo(v), motionpixels(v), mpeg1video(v), mpeg1video(v), mpeg2video(v), mpeg2video(v), mpeg4(v), mpeg4(v), mpeg4_vdpau(v), mpegvideo(v), mpegvideo_vdpau(v), mpeg1video_vdpau(v), msa1(v), msmpeg4v1(v), msmpeg4v2(v), msmpeg4v2(v), msmpeg4(v), msmpeg4(v), msrle(v), mss1(v), mss2(v), msvideo1(v), msvideo1(v), mszh(v), mts2(v), mvc1(v), mvc2(v), mxpeg(v), nuv(v), paf_video(v), pam(v), pam(v), pbm(v), pbm(v), pcx(v), pcx(v), pgm(v), pgm(v), pgmyuv(v), pgmyuv(v), pictor(v), png(v), png(v), ppm(v), ppm(v), prores(v), prores(v), prores_aw(v), prores_ks(v), prores_lgpl(v), ptx(v), qdraw(v), qpeg(v), qtrle(v), qtrle(v), r10k(v), r10k(v), r210(v), r210(v), rawvideo(v), rawvideo(v), rl2(v), roqvideo(v), roqvideo(v), rpza(v), rv10(v), rv10(v), rv20(v), rv20(v), rv30(v), rv40(v), s302m(a), s302m(a), sanm(v), sgi(v), sgi(v), sgirle(v), smackvid(v), smc(v), smvjpeg(v), snow(v), snow(v), sp5x(v), sunrast(v), sunrast(v), svq1(v), svq1(v), svq3(v), targa(v), targa(v), targa_y216(v), theora(v), thp(v), tiertexseqvideo(v), tiff(v), tiff(v), tmv(v), truemotion1(v), truemotion2(v), camtasia(v), tscc2(v), txd(v), ultimotion(v), utvideo(v), utvideo(v), v210(v), v210(v), v210x(v), v308(v), v308(v), v408(v), v408(v), v410(v), v410(v), vb(v), vble(v), vc1(v), vc1_vdpau(v), vc1image(v), vcr1(v), vmdvideo(v), vmnc(v), vp3(v), vp5(v), vp6(v), vp6a(v), vp6f(v), vp8(v), vp9(v), vqavideo(v), webp(v), wmv1(v), wmv1(v), wmv2(v), wmv2(v), wmv3(v), wmv3_vdpau(v), wmv3image(v), wnv1(v), xan_wc3(v), xan_wc4(v), xbm(v), xbm(v), xface(v), xface(v), xl(v), xwd(v), xwd(v), y41p(v), y41p(v), yop(v), yuv4(v), yuv4(v), 012v(v), zerocodec(v), zlib(v), zlib(v), zmbv(v), zmbv(v), aac(a), aac(a), aac_latm(a), ac3(a), ac3(a), ac3_fixed(a), alac(a), alac(a), als(a), amrnb(a), amrwb(a), ape(a), atrac1(a), atrac3(a), atrac3plus(a), binkaudio_dct(a), binkaudio_rdft(a), bmv_audio(a), cook(a), dca(a), dca(a), dsicinaudio(a), eac3(a), eac3(a), evrc(a), wavesynth(a), flac(a), flac(a), g723_1(a), g723_1(a), g729(a), gsm(a), gsm_ms(a), iac(a), imc(a), mace3(a), mace6(a), metasound(a), mlp(a), mp1(a), mp1float(a), mp2(a), mp2(a), mp2float(a), mp2fixed(a), mp3(a), mp3float(a), mp3adu(a), mp3adufloat(a), mp3on4(a), mp3on4float(a), mpc7(a), mpc8(a), nellymoser(a), nellymoser(a), paf_audio(a), qcelp(a), qdm2(a), real_144(a), real_144(a), real_288(a), ralf(a), shorten(a), sipr(a), smackaud(a), sonic(a), sonic(a), sonicls(a), tak(a), truehd(a), truespeech(a), tta(a), tta(a), twinvq(a), vmdaudio(a), vorbis(a), vorbis(a), wavpack(a), wavpack(a), wmalossless(a), wmapro(a), wmav1(a), wmav1(a), wmav2(a), wmav2(a), wmavoice(a), ws_snd1(a), pcm_alaw(a), pcm_alaw(a), pcm_bluray(a), pcm_dvd(a), pcm_f32be(a), pcm_f32be(a), pcm_f32le(a), pcm_f32le(a), pcm_f64be(a), pcm_f64be(a), pcm_f64le(a), pcm_f64le(a), pcm_lxf(a), pcm_mulaw(a), pcm_mulaw(a), pcm_s8(a), pcm_s8(a), pcm_s8_planar(a), pcm_s8_planar(a), pcm_s16be(a), pcm_s16be(a), pcm_s16be_planar(a), pcm_s16be_planar(a), pcm_s16le(a), pcm_s16le(a), pcm_s16le_planar(a), pcm_s16le_planar(a), pcm_s24be(a), pcm_s24be(a), pcm_s24daud(a), pcm_s24daud(a), pcm_s24le(a), pcm_s24le(a), pcm_s24le_planar(a), pcm_s24le_planar(a), pcm_s32be(a), pcm_s32be(a), pcm_s32le(a), pcm_s32le(a), pcm_s32le_planar(a), pcm_s32le_planar(a), pcm_u8(a), pcm_u8(a), pcm_u16be(a), pcm_u16be(a), pcm_u16le(a), pcm_u16le(a), pcm_u24be(a), pcm_u24be(a), pcm_u24le(a), pcm_u24le(a), pcm_u32be(a), pcm_u32be(a), pcm_u32le(a), pcm_u32le(a), pcm_zork(a), interplay_dpcm(a), roq_dpcm(a), roq_dpcm(a), sol_dpcm(a), xan_dpcm(a), adpcm_4xm(a), adpcm_adx(a), adpcm_adx(a), adpcm_afc(a), adpcm_ct(a), adpcm_dtk(a), adpcm_ea(a), adpcm_ea_maxis_xa(a), adpcm_ea_r1(a), adpcm_ea_r2(a), adpcm_ea_r3(a), adpcm_ea_xas(a), g722(a), g722(a), g726(a), g726(a), g726le(a), adpcm_ima_amv(a), adpcm_ima_apc(a), adpcm_ima_dk3(a), adpcm_ima_dk4(a), adpcm_ima_ea_eacs(a), adpcm_ima_ea_sead(a), adpcm_ima_iss(a), adpcm_ima_oki(a), adpcm_ima_qt(a), adpcm_ima_qt(a), adpcm_ima_rad(a), adpcm_ima_smjpeg(a), adpcm_ima_wav(a), adpcm_ima_wav(a), adpcm_ima_ws(a), adpcm_ms(a), adpcm_ms(a), adpcm_sbpro_2(a), adpcm_sbpro_3(a), adpcm_sbpro_4(a), adpcm_swf(a), adpcm_swf(a), adpcm_thp(a), adpcm_xa(a), adpcm_yamaha(a), adpcm_yamaha(a), vima(a), ssa(s), ssa(s), ass(s), ass(s), dvbsub(s), dvbsub(s), dvdsub(s), dvdsub(s), jacosub(s), microdvd(s), mov_text(s), mov_text(s), mpl2(s), pgssub(s), pjs(s), realtext(s), sami(s), srt(s), srt(s), subrip(s), subrip(s), subviewer(s), subviewer1(s), text(s), vplayer(s), webvtt(s), xsub(s), xsub(s), libgsm(a), libgsm(a), libgsm_ms(a), libgsm_ms(a), libmp3lame(a), libopencore_amrnb(a), libopencore_amrnb(a), libopencore_amrwb(a), libopenjpeg(v), libopenjpeg(v), libspeex(a), libspeex(a), libtheora(v), libvorbis(a), libvorbis(a), libvpx(v), libvpx(v), libx264(v), libx264rgb(v), libxavs(v), libxvid(v), bintext(v), xbin(v), idf(v),
    
    Directive => Local Value => Master Value
    ffmpeg.allow_persistent => 0 => 0
    ffmpeg.show_warnings => 0 => 0
    
    check FFMPEG
    
    ffmpeg version 2.2.1 Copyright (c) 2000-2014 the FFmpeg developers
      built on Jun 17 2014 01:25:46 with gcc 4.8.2 (GCC) 20140120 (Red Hat 4.8.2-16)
      configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --enable-shared --enable-runtime-cpudetect --enable-gpl --enable-version3 --enable-postproc --enable-avfilter --enable-pthreads --enable-x11grab --enable-vdpau --disable-avisynth --enable-frei0r --enable-libdc1394 --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librtmp --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -m64 -mtune=generic -fPIC' --disable-stripping
      libavutil      52. 66.100 / 52. 66.100
      libavcodec     55. 52.102 / 55. 52.102
      libavformat    55. 33.100 / 55. 33.100
      libavdevice    55. 10.100 / 55. 10.100
      libavfilter     4.  2.100 /  4.  2.100
      libswscale      2.  5.102 /  2.  5.102
      libswresample   0. 18.100 /  0. 18.100
      libpostproc    52.  3.100 / 52.  3.100
    Hyper fast Audio and Video encoder
     
    Last edited: Jul 16, 2015
  9. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    Just merged the branch into official 123.08beta03 branch Commits · centminmod/centminmod · GitHub :D

    for existing .08 beta03 users after updating your code, to sync the new ATrpms YUM repo, run centmin.sh menu option 5 and when prompted for YUM install checks answer yes = y but when asked to upgrade PHP answer NO = n.

    Code:
    --------------------------------------------------------
    Centmin Mod 1.2.3-eva2000.08 - http://centminmod.com
    --------------------------------------------------------
                       Centmin Mod Menu                 
    --------------------------------------------------------
    1).  Centmin Install
    2).  Add Nginx vhost domain
    3).  NSD setup domain name DNS
    4).  Nginx Upgrade / Downgrade
    5).  PHP Upgrade / Downgrade
    6).  XCache Re-install
    7).  APC Cache Re-install
    8).  XCache Install
    9).  APC Cache Install
    10). Memcached Server Re-install
    11). MariaDB 5.2/5.5 & 10.x Upgrade Sub-Menu
    12). Zend OpCache Install/Re-install
    13). Install ioping.sh vbtechsupport.com/1239/
    14). SELinux disable
    15). Install/Reinstall ImagicK PHP Extension
    16). Change SSHD Port Number
    17). Multi-thread compression: pigz,pbzip2,lbzip2...
    18). Suhosin PHP Extension install
    19). Install FFMPEG and FFMPEG PHP Extension
    20). NSD Re-install
    21). Update - Nginx + PHP-FPM + Siege
    22). Add Wordpress Nginx vhost + WP Super Cache
    23). Update Centmin Mod Code Base
    24). Exit
    --------------------------------------------------------
    Enter option [ 1 - 24 ] 5
    --------------------------------------------------------
    Custom configure CSF settings...set
    
    Do you want to run YUM install checks ?  [y/n]
    
    This will increase your upgrade duration time wise.
    Check the change log centminmod.com/changelog.html
    to see if any Nginx or PHP related new additions
    which require checking YUM prequisites are met.
    If no new additions made, you can skip the
    YUM install check to speed up upgrade time.
    
    [y/n]: y
    
    PHP Upgrade - Would you like to continue? [y/n] n
    Then you should have ATrpms added and setup then you can proceed with centmin.sh menu option 19
     
    Last edited: Jul 16, 2015
  10. jeffwidman

    jeffwidman Active Member

    152
    27
    28
    Dec 3, 2014
    Ratings:
    +51
    Local Time:
    12:36 AM
    Checking in here now that Xenforo Media Gallery uses ffmpeg... I hadn't realized it wasn't already installed on my server.

    Just installed it using centmin.sh menu option 19, but noticed it installs a version last built in 2014.

    Are you using a packaged rpm such that when the repo maintainers update it, it'll show up in yum upgrade? If not, is there any reason why the menu option doesn't just curl the latest static build from here? FFmpeg Static Builds
     
  11. jeffwidman

    jeffwidman Active Member

    152
    27
    28
    Dec 3, 2014
    Ratings:
    +51
    Local Time:
    12:36 AM
    Actually, just hit a bug after running centmin.sh menu option #19:

    Code:
    root@cloud1 centminmod]# php -v
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/ffmpeg.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
    PHP 5.6.12 (cli) (built: Aug  8 2015 06:31:16)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
    
    On this particular box, I last upgraded PHP when 5.6.12 came out. I'll try recompiling PHP just in case @eva2000 updated the library references for Imagemagick or ffmpeg and that somehow affects it. I have another box I just built tonight using centminmod and it doesn't display this error.
     
  12. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    Yeah try centmin.sh menu option 15 to recompile imagick PHP extension
     
    • Like Like x 1
  13. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    yeah using FFMPEG YUM packages on menu option 19. For Xenforo specific usage for XMG best to use just FFMPEG static builds as you don't need the rest
     
    • Informative Informative x 1
  14. jeffwidman

    jeffwidman Active Member

    152
    27
    28
    Dec 3, 2014
    Ratings:
    +51
    Local Time:
    12:36 AM
    Thanks, that fixed the imagemagick error, but still getting:

    Code:
    [root@host1 centminmod]# php -v
    PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/ffmpeg.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.6.12 (cli) (built: Aug 29 2015 06:44:19)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
    
    As you can see from the PHP build date, I just recompiled PHP. I'm getting this on two boxes, both of which I've done `git pull` to get latest centminmod master, then recompiled PHP, then re-installed imagemagick and the FFMPEG menu options after recompiling PHP. And weirdly, not getting this error on another box that I'm building brand new this evening, only getting the error message on boxes that I've had running for several months and been upgrading.
     
  15. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    check the /root/centminlogs/*ffmpeg_install.log log for clues as to what happened during centmin.sh menu option 19 run :)
     
  16. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    i did change that ffmpeg centmin.sh menu option 19 routine due to above @Matt's reported problems inc/ffmpeginstall.inc for 123.08stable as it stands so could be you have older routine for older installs
     
  17. eva2000

    eva2000 Administrator Staff Member

    29,733
    6,713
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,023
    Local Time:
    5:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    the change also added ATrpms YUM repo for ffmpeg at Unable to install FFMPEG PHP extension | Page 2 | Centmin Mod Community so double check if ATrpms YUM repo exists

    Code:
    yum repolist all
    if it doens't exist, run centmin.sh menu option 5 and at YUM CHECK prompt answer yes. Then when it says to proceed to upgrade answer no to abort PHP upgrade..

    the YUMCHECK should at ATrpms YUM repo if it's missing
     
  18. jeffwidman

    jeffwidman Active Member

    152
    27
    28
    Dec 3, 2014
    Ratings:
    +51
    Local Time:
    12:36 AM
    No, I did git pull immediately before this, so I am on latest master.

    Nice! Didn't realize output was logged. Here's the two errors I see:

    Code:
    Error getting repository data for atrpms, repository not found
    fatal: destination path 'ffmpeg-php-git' already exists and is not an empty directory.
    make: *** No rule to make target `clean'.  Stop.
    
    Code:
    checking for ffmpeg headers...
    configure: error: ffmpeg headers not found. Make sure ffmpeg is compiled as shared libraries using the --enable-shared option
    make: *** No targets specified and no makefile found.  Stop.
    make: *** No rule to make target `install'.  Stop.
    
    `yum repolist all` doesn't include the ATrpms repo, and looking at the errors in the log above, this is likely the underlying issue. I just re-ran the option #5 and hit yes on updating the Yum check. Then did `yum repolist all` and still not seeing anything that looks like ATrpms... the only repos listed under 'A' are axivo.

    So looks like for some reason the Yum install checks are not realizing they need to add the ATrpms repo?
     
  19. RoldanLT

    RoldanLT Well-Known Member

    3,882
    947
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,291
    Local Time:
    3:36 PM
    1.11
    10.2
    You don't need to install that @jeffwidman
     
  20. jeffwidman

    jeffwidman Active Member

    152
    27
    28
    Dec 3, 2014
    Ratings:
    +51
    Local Time:
    12:36 AM
    Thanks @RoldanLT but in this case I'd still prefer to install it via a Yum repo (which is what Eva is doing behind the scenes) rather than copy the static build.

    But the bigger issue here is that the Yum checks for some reason aren't working correctly... could cause issues the next time Eva adds another repo if the Yum check doesn't find it.
     
    Last edited: Aug 29, 2015