Get the most out of your Centmin Mod LEMP stack
Become a Member

Wordpress unable to complete Wordpress install

Discussion in 'Blogs & CMS usage' started by EckyBrazzz, Nov 30, 2020.

  1. EckyBrazzz

    EckyBrazzz Active Member

    884
    186
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +342
    Local Time:
    12:04 PM
    Latest
    Latest
    Code:
    configure autoptimize-gzip https://community.centminmod.com/threads/15314/
    2020-11-29 21:16:50 URL:https://raw.githubusercontent.com/centminmod/autoptimize-gzip/master/autoptimize-gzip.php [573/573] -> "/home/nginx/domains/domain.com.br/public/wp-content/plugins/autoptimize-gzip/autoptimize-gzip.php" [1]
    2020-11-29 21:16:50 URL:https://raw.githubusercontent.com/centminmod/autoptimize-gzip/master/index.html [192/192] -> "/home/nginx/domains/domain.com.br/public/wp-content/plugins/autoptimize-gzip/index.html" [1]
    2020-11-29 21:16:51 URL:https://github.com/centminmod/autoptimize-gzip/blob/master/readme.md [115043] -> "/home/nginx/domains/domain.com.br/public/wp-content/plugins/autoptimize-gzip/readme.md" [1]
    2020-11-29 21:16:51 URL:https://raw.githubusercontent.com/centminmod/autoptimize-gzip/master/LICENSE [18026/18026] -> "/home/nginx/domains/domain.com.br/public/wp-content/plugins/autoptimize-gzip/LICENSE" [1]
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    ------------------------------------------------------------
    ------------------------------------------------------------
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    ------------------------------------------------------------
    ------------------------------------------------------------
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    ------------------------------------------------------------
    ------------------------------------------------------------
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    ------------------------------------------------------------
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    ------------------------------------------------------------

     
  2. eva2000

    eva2000 Administrator Staff Member

    45,971
    10,444
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,206
    Local Time:
    1:04 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Need more of the wordpress install log as it's possible Wordpress itself failed to download/install and that excerpt doesn't show enough.

    To troubleshoot centmin.sh menu option 22 wordpress installation, you need to check the centmin.sh menu option 22 log located in /root/centminlogs at /root/centminlogs/centminmod_*_wordpress_addvhost.log based log where * is the centminmod version and date timestamp. Edit and mask any actual ftp username/password or wordpress usernames and logins before posting the log contents to Pastebin.com or Gists to share a sanitised version of the contents of the log.

    Example list /root/centminlogs files in date ascending order and grep for wordpress_addvhost.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep wordpress_addvhost.log
    

    example output returns log at /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_wordpress_addvhost.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep wordpress_addvhost.log
    -rw-r--r--  1 root root 2.2M Oct 11 01:40 /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_wordpress_addvhost.log
    

    in SSH use cat to ouput contents of /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_wordpress_addvhost.log. Clear your SSH client window/buffer so only output is the contents of the file
    Code (Text):
    cat /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_wordpress_addvhost.log
    

    Then copy and paste into Pastebin.com or Gists entry. If your SSH window scroll buffer isn't that large to get the whole contents of the install log, you can download file manually and copy and paste contents. But makes sure it's sanitised version of the contents without revealing sensitive info. For example you can replace domain name of the wordpress site with generic dummy entry = domain.com if you want and mask site/server IP revealed in the log with generic dummy entry = 111.222.333.444.
     
  3. EckyBrazzz

    EckyBrazzz Active Member

    884
    186
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +342
    Local Time:
    12:04 PM
    Latest
    Latest
  4. EckyBrazzz

    EckyBrazzz Active Member

    884
    186
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +342
    Local Time:
    12:04 PM
    Latest
    Latest
    @eva2000 I posted the logfile. Can you please have a look at it?
     
  5. eva2000

    eva2000 Administrator Staff Member

    45,971
    10,444
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,206
    Local Time:
    1:04 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    looks like you hit some kind of memory limit in PHP/WP-CLI
    Code (Text):
    Downloading WordPress 5.5.3 (en_US)...
    Using cached file '/root/.wp-cli/cache/core/wordpress-5.5.3-en_US.tar.gz'...
    PHP Fatal error:  Allowed memory size of 50331648 bytes exhausted (tried to allocate 36864 bytes) in phar:///usr/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Extractor.php on line 101
    Error: This does not seem to be a WordPress installation.
    Pass --path=`path/to/wordpress` or run `wp core download`.
    

    50331648 bytes is very low limit. How much memory does your system have? output for these commands
    Code (Text):
    php -i | grep memory_limit
    

    Code (Text):
    free -mlt

    Code (Text):
    cminfo sar-mem
     
  6. EckyBrazzz

    EckyBrazzz Active Member

    884
    186
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +342
    Local Time:
    12:04 PM
    Latest
    Latest
    @eva2000 , thanks, I added more memory and the problem was partaly resolved and also I could upgrade to version 8.0.0.

    Now it gives me a error on the install of the plugins, but they work.

     
  7. eva2000

    eva2000 Administrator Staff Member

    45,971
    10,444
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,206
    Local Time:
    1:04 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Wordpress 5.5 doesn't support PHP 8.0. You need to wait for next Wordpress 5.6 for PHP 8.0 support