Join the community today
Become a Member

Beta Branch switch to DEVTOOLSETEIGHT='y' default in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Feb 24, 2019.

  1. eva2000

    eva2000 Administrator Staff Member

    40,634
    9,023
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,891
    Local Time:
    5:51 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    switch to DEVTOOLSETEIGHT='y' default in 123.09beta01

    - Intel cpus newer than Intel Broadwell, aren't detected by distro native GCC compilers or even devtoolset-7 GCC 7.3.1. They require devtoolset-8 GCC 8.2.1 compiler to properly detect up to Intel Skylake processors which means changing from DEVTOOLSETSEVEN='y' default to DEVTOOLSETEIGHT='y' default https://community.centminmod.com/threads/php-isnt-installed.16678/#post-71026. This will allow nginx to be compiled with GCC 8.2.1 compiler and php-fpm PGO enabled, PHP_PGO='y' builds to also be compiled with GCC 8.2.1 as well as force GCC 8.2.1 compiles for PHP 7.3 non-PGO builds due to PHP 7.3 required additional avx instructions which are not enabled by default with centos GCC native compiler versions on newer Intel cpus like Intel Kaby Lake or Intel Skylake https://community.centminmod.com/th...r-1-cpu-thread-systems-in-123-09beta01.16679/.

    Continue reading...

    123.09beta01 branch
     
    • Winner Winner x 1
  2. eva2000

    eva2000 Administrator Staff Member

    40,634
    9,023
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,891
    Local Time:
    5:51 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x