Want to subscribe to topics you're interested in?
Become a Member

Sucuri blocked my searching

Discussion in 'Forum Feedback & Suggestions' started by Sunka, Jul 4, 2017.

  1. Sunka

    Sunka Well-Known Member

    1,044
    286
    83
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +464
    Local Time:
    11:32 AM
    Nginx 1.15.0
    MariaDB 10.2.15
    I tried to search shell_exec() in search and suscuri firewall show me this :LOL:

    centmin.png

    I need to know is it OK (and if it is, how to enable it) because of this server error

    Code:
    ErrorException: shell_exec() has been disabled for security reasons - library/phc/AttachmentPlus/Helper/Helper.php:456
     
    • Informative Informative x 1
  2. eva2000

    eva2000 Administrator Staff Member

    37,202
    8,125
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,511
    Local Time:
    8:32 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    LOL yeah sucuri in action

    If your addon uses shell_exec, then you need to either enable shell_exec or remove the addon. It can be security issue with shell_exec enabled if a php script is compromised though. Use your own judgement.
     
  3. Sunka

    Sunka Well-Known Member

    1,044
    286
    83
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +464
    Local Time:
    11:32 AM
    Nginx 1.15.0
    MariaDB 10.2.15
    Is it disabled by default on centmin installation?
     
  4. eva2000

    eva2000 Administrator Staff Member

    37,202
    8,125
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,511
    Local Time:
    8:32 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    yes in /usr/local/etc/php-fpm.conf
    Code (Text):
    php_admin_value[disable_functions] = shell_exec
     
    • Like Like x 1
..