Welcome to Centmin Mod Community
Become a Member

Vultr SSH time outs with Vultr

Discussion in 'Virtual Private Server (VPS) hosting' started by Josephm, Sep 13, 2014.

  1. Josephm

    Josephm Active Member

    132
    44
    28
    Aug 26, 2014
    Ratings:
    +48
    Local Time:
    11:42 PM
    1.9.5
    10.0.21
    Another confirmation that no more time-out issue :D
    Code:
    [[email protected] ~]# uptime
     01:28:00 up 1 day,  8:04,  1 user,  load average: 0.00, 0.01, 0.05
    

     
    • Like Like x 2
  2. Josephm

    Josephm Active Member

    132
    44
    28
    Aug 26, 2014
    Ratings:
    +48
    Local Time:
    11:42 PM
    1.9.5
    10.0.21
    I had another timeout problem at Vultr. I suspect that the second NIC which uses private network (internal IP) might make my connection timeout. I used your latest beta script with fresh Centos 7:
    And this is my var/log/messages
    [​IMG]
    [​IMG]
    Will try single NIC to see if problem still occurs.
     
    Last edited: Oct 22, 2014
  3. eva2000

    eva2000 Administrator Staff Member

    42,346
    9,560
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,732
    Local Time:
    2:42 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    is this the same vps that you got timeout in 1st post of this thread ?
     
  4. eva2000

    eva2000 Administrator Staff Member

    42,346
    9,560
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,732
    Local Time:
    2:42 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    just confirmed with Vultr support that multicast dns isn't used by them but CentOS 7 default enables avahi-daemon which uses multicast dns i believe, so you can disable it on CentOS 7 (do not remove avahi-daemon just disable and stop it service - removing it will remove network service and all ip functionality).

    Code:
    systemctl stop avahi-daemon.socket avahi-daemon.service
    systemctl disable avahi-daemon.socket avahi-daemon.service
    see if that works.. if it does will add to check for CentOS 7 only step to run
     
    • Like Like x 2
  5. Josephm

    Josephm Active Member

    132
    44
    28
    Aug 26, 2014
    Ratings:
    +48
    Local Time:
    11:42 PM
    1.9.5
    10.0.21
    It's not the same my 1st post vps, I'll try to stop and disable avahi-daemon to know where it solves this problem.

    Edited: Just stopped and disabled daemon and it's not solved. The strange thing is that vps in Chicago has this issue, I tested in Atlanta and Seattle location and did not see this problem.
     
    Last edited: Oct 22, 2014
  6. Josephm

    Josephm Active Member

    132
    44
    28
    Aug 26, 2014
    Ratings:
    +48
    Local Time:
    11:42 PM
    1.9.5
    10.0.21
    I switched both eth0 and eth1 to static ip addresses instead of DHCP and it's fine now.
     
    • Like Like x 1
  7. eva2000

    eva2000 Administrator Staff Member

    42,346
    9,560
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,732
    Local Time:
    2:42 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    interesting solution but thanks for sharing :)