Welcome to Centmin Mod Community
Register Now

Wordpress Some WordPress issues

Discussion in 'Blogs & CMS usage' started by fly, Jan 24, 2020.

  1. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    From that blog directory. Same as the formerly working server.
     
  2. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    strange then, i retested with PHP 7.4.3 and wp cli only reports an issue with PHP 7.4 compatibility AFAIK but still works

    when run with PHP 7.4.3
    Code (Text):
    wp plugin status
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 662
    Notice: Trying to access array offset on value of type null in phar:///usr/bin/wp/vendor/wp-cli/extension-command/src/Plugin_Command.php on line 663
    9 installed plugins:
      I akismet            4.1.3
      A autoptimize        2.6.1
      A autoptimize-gzip   0.1
      A cache-enabler      1.3.4
      I cdn-enabler        1.0.9
      A classic-editor     1.5
      A disable-xml-rpc    1.0.1
      A sucuri-scanner     1.8.24
      D advanced-cache.php
    

    when run with PHP 7.3.15
    Code (Text):
    wp plugin status
    9 installed plugins:
      I akismet            4.1.3
      A autoptimize        2.6.1
      A autoptimize-gzip   0.1
      A cache-enabler      1.3.4
      I cdn-enabler        1.0.9
      A classic-editor     1.5
      A disable-xml-rpc    1.0.1
      A sucuri-scanner     1.8.24
      D advanced-cache.php
    Legend: I = Inactive, A = Active, D = Drop-In
    
     
  3. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Did you go through the recompile steps? In my case it only started after a recompile.
     
  4. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Did you go through the recompile steps? In my case it only started after a recompile.
     
  5. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    yes i did

    can you share the contents of your persistent config file /etc/centminmod/custom_config.inc as well ?
     
  6. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Sure. Here's the old server contents:

    Code:
    NGINX_PAGESPEED=y
    NGINX_ZLIBCUSTOM='y'
    ORESTY_LUANGINX=n
    NGINX_XSLT='n'
    NGINX_LIBBROTLI='y'
    NGXDYNAMIC_XSLT='n'
    NGXDYNAMIC_IMAGEFILTER='y'
    NGXDYNAMIC_GEOIP='y'
    NGXDYNAMIC_STREAM='y'
    NGXDYNAMIC_HEADERSMORE='y'
    NGXDYNAMIC_SETMISC='y'
    NGXDYNAMIC_ECHO='y'
    NGXDYNAMIC_SRCCACHE='y'
    NGXDYNAMIC_MEMC='y'
    NGXDYNAMIC_REDISTWO='y'
    NGXDYNAMIC_NGXPAGESPEED='y'
    NGXDYNAMIC_BROTLI='y'
    PHPMSSQL='y'
    PHP_PGO='y'
    PHP_PGO_CENTOSSIX='y'
    NGINX_DEVTOOLSETGCC='y'
    GENERAL_DEVTOOLSETGCC='y'
    CLANG='n'
    LIBRESSL_SWITCH='n'
    MARIADB_INSTALLTENTHREE='y'
    LETSENCRYPT_DETECT='y'
    PHPFINFO=y
    CLOUDFLARE_ZLIBPHP='y'
    DUALCERTS='y'
    New server custom:

    Code:
    ALERTEMAIL='[email protected]'
    MM_LICENSE_KEY='keykeykey'
    NGINX_PAGESPEED='n'
    NGINX_ZLIBCUSTOM='y'
    ORESTY_LUANGINX=n
    NGINX_XSLT='n'
    NGINX_LIBBROTLI='y'
    NGXDYNAMIC_XSLT='n'
    NGXDYNAMIC_IMAGEFILTER='y'
    NGXDYNAMIC_GEOIP='y'
    NGXDYNAMIC_STREAM='y'
    NGXDYNAMIC_HEADERSMORE='y'
    NGXDYNAMIC_SETMISC='y'
    NGXDYNAMIC_ECHO='y'
    NGXDYNAMIC_SRCCACHE='y'
    NGXDYNAMIC_MEMC='y'
    NGXDYNAMIC_REDISTWO='y'
    NGXDYNAMIC_NGXPAGESPEED='y'
    NGXDYNAMIC_BROTLI='y'
    PHPMSSQL='y'
    PHP_PGO='y'
    PHP_PGO_CENTOSSIX='y'
    NGINX_DEVTOOLSETGCC='y'
    GENERAL_DEVTOOLSETGCC='y'
    CLANG='n'
    LIBRESSL_SWITCH='n'
    MARIADB_INSTALLTENTHREE='y'
    LETSENCRYPT_DETECT='y'
    PHPFINFO=y
    #CLOUDFLARE_ZLIBPHP='y'
    DUALCERTS='y'
    AUTODETECPHP_OVERRIDE='y'
    PHP_BROTLI='y'
    PHP_LZFOUR='y'
    PHP_LZF='y'
    PHP_ZSTD='y'
    
    # Maintenance Mode (will run maintenance mode during these upgrades)
    NGINX_UPDATEMAINTENANCE='y'
    PHP_UPDATEMAINTENANCE='y'
    MARIADB_UPDATEMAINTENANCE='y'
    
    NGINX_IOURING_PATCH='y' #disable
    NGINX_HPACK='y' #Disable
    AUTOTUNE_CLIENTMAXBODY='y'
    NGINX_DYNAMICTLS='y' #disable
    NGINX_SSLCACHE_ALLOWOVERRIDE='y'
    AUTOHARDTUNE_NGINXBACKLOG='y'
    ZSTD_LOGROTATE_NGINX='y'
    ZSTD_LOGROTATE_PHPFPM='y'
    #NGINX_ZERODT='y'
    
    
    SET_DEFAULT_MYSQLCHARSET='utf8mb4'
    
    CRYPTO_DEVTOOLSETGCC='y'
    MARCH_TARGETNATIVE='y'
    MARCH_TARGETNATIVE_ALWAYS='y'
    DEVTOOLSETNINE='y'
    
    Both having the same issue as I mentioned earlier.
     
  7. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    you using CentOS 6.10 or CentOS 7.7 ?
     
  8. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Always 7....

    Both configs were derived from beta-installerlatest...

    I was actually wondering about that parameter yesterday and why it was added. Should I set that to No (or remove it entirely)
     
  9. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    if using CentOS 7, then you can remove PHP_PGO_CENTOSSIX='y' as it isn't needed but should be related to your wp cli phar issue anyway
     
  10. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Thanks, removed it and doing a recompile though that option has always been there since day 1.
     
  11. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    No that was not the issue sadly.
     
  12. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    OK, so tried it on another WP site (that's in root) same config and it works so looks like specific to /subdirectory..... Hmmmm. Plot thickens.
     
  13. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    i meant should NOT be related heh
    interesting

    tried downgrading to PHP 7.2.28 first ?
     
  14. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    OK, 7.2.28 exactly same issue. /blog subdir doesn't work, root works.

    It appears to be subdirectory related and appears to be an issue introduced in the last 6-8 weeks or so. It's been that long since I ran cmupdate and did a php upgrade on the old server.
     
  15. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    what about command like
    Code (Text):
    wp plugin status --path=/home/nginx/domains/mysite.com/public/blog
    
     
  16. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    also try
    Code (Text):
    wp plugin status --path=/home/nginx/domains/mysite.com/public/blog --debug
    
     
  17. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    Same issue though I do get many screens of debug bootstrap commands and what appear to be my plugins and a An unexpected error occurred. Please try again later. at the end.... It's a huge log so let me know if you want it....
     
  18. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    sounds like a plugin incompatibility with wp-cli, it's been known to happen. Try temporarily disabling wp plugins and re-running wp plugin status command to isolate which wordpress plugin (s) maybe having issues

    you can also try isolated testing via wp plugin status with --skip-plugins argument too on command line wp plugin status | WordPress Developer Resources
     
  19. Nik

    Nik Member

    66
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    11:17 AM
    I don't understand how this would happen at all, it's an unused server, it worked, I did a PHP upgrade then stopped working. I appreciate your time on this issue. It's quite possible it could be widespread and people are not combing through their logs to spot it.
     
  20. eva2000

    eva2000 Administrator Staff Member

    43,482
    9,870
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,242
    Local Time:
    1:17 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    yeah it could happen if wordpress plugin updated and made it incompatible as centmin.sh menu option 22 wordpress installs have a cronjob setup to auto update wordpress plugins every 8hrs. So while you had an unused/idle server, it would of still had auto updated wordpress plugins :)