Welcome to Centmin Mod Community
Register Now

Nginx server reached max_children setting problem

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by reallove0810, Jan 4, 2015.

  1. reallove0810

    reallove0810 New Member

    22
    10
    3
    Jan 3, 2015
    Ratings:
    +11
    Local Time:
    2:22 AM
    1.7.9
    5.5.41
    Hello,

    I see this error in log file
    Code:
    [04-Jan-2015 09:28:23] WARNING: [pool www] server reached max_children setting (5), consider raising it
    I searching on the internet in order to increase max_children setting. But I can't find where to edit in Centmin Mod.
    And sometime I met 502 Bad Gateway nginx and log say
    Code:
    [03-Jan-2015 23:46:58] WARNING: [pool www] child 5511 exited on signal 9 (SIGKILL) after 32.830814 seconds from start
    How can I decrease the 502 error?

    Thankyou!
     
  2. RoldanLT

    RoldanLT Well-Known Member

    3,901
    949
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,298
    Local Time:
    8:22 AM
    1.11
    10.2
    • Edit php-fpm.conf = fpmconf ( /usr/local/etc/php-fpm.conf )
     
  3. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    10:22 AM
    Nginx 1.13.x
    MariaDB 5.5