Want more timely Centmin Mod News Updates?
Become a Member

Email server not sending emails

Discussion in 'Domains, DNS, Email & SSL Certificates' started by hitman, Nov 5, 2016.

  1. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    3:34 AM
    hello
    i made a fresh install of beta09 on centos 6 and i am using mail notifications on maldet alerts and csf
    but i am not receiving any mails
    any idea why?

    edit:
    could it be due to the fact that i am using cloudflare for one of the domains?
    although i find it kind of irrelevant, but i thought to add it just in case i am missing something
     
    Last edited: Nov 6, 2016
  2. eva2000

    eva2000 Administrator Staff Member

    30,956
    6,917
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,418
    Local Time:
    11:34 AM
    Nginx 1.13.x
    MariaDB 5.5
    Who's your web host ? some web hosts block outgoing smtp email ports until you contact them to request unblocking i.e. Vultr does this and require you to provide ID verification to unblock you.

    Emails would only be sent if there are alerts to be sent. You can check manually if emails from server are being sent and check your junk/spam folders - see Email - Steps to ensure your site/server email doesn't end up in spam inboxes | Centmin Mod Community

    test email via SSH command
    Code (Text):
    echo "test" | mail -s "test subject" youremail@address.com
     
    • Like Like x 1
  3. hitman

    hitman Member

    117
    10
    18
    Jul 18, 2014
    Ratings:
    +14
    Local Time:
    3:34 AM
    well i am on vultr and i have tested with different vps and it works, it does not work in this one
    could it be that they have blocked this one?
     
  4. RB1

    RB1 Active Member

    281
    72
    28
    Nov 11, 2016
    California
    Ratings:
    +119
    Local Time:
    5:34 PM
    Nginx 1.13.x
    MariaDB 10.1.x
    Is postfix running? I had this same problem when my server wasn't sending emails...for some reason it was disabled.
    Code (Text):
    service postfix status
    

    To enable it:
    Code (Text):
    service postfix start
    chkconfig postfix on
    
     
    • Like Like x 1
  5. Colin

    Colin Premium Member Premium Member

    122
    35
    28
    Oct 7, 2015
    Sheffield UK
    Ratings:
    +87
    Local Time:
    1:34 AM
    1.11.#
    MariaDB 10.1.#
    99% yes, they block by default. It vexed me for a bit, thought I was loosing it. I'd missed it in the docs and various comments. They have a $ charge if you spam/complaint gets back to them, or used to. I offload mine to services and just let the local box mail do system stuff.

    Drop them a support ticket :D
     
    • Like Like x 1
  6. dorobo

    dorobo Active Member

    420
    104
    43
    Jun 6, 2014
    Ratings:
    +162
    Local Time:
    9:34 AM
    latest
    latest
    source: What Ports Are Blocked? - Vultr.com
     
    • Like Like x 1