Want to subscribe to topics you're interested in?
Become a Member

SSL self-signed ssl cert - https mixed content warnings

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by tdubs, Dec 1, 2016.

  1. tdubs

    tdubs Member

    77
    11
    8
    Apr 10, 2015
    Ratings:
    +14
    Local Time:
    1:04 AM
    1.7.12
    10.0.17
    Hello,

    I'm not sure if I'm just jumping to conclusion or what but I opted into the self-sign SSL certificate option upon installation of Centmin Mod and also enabled a page rule to force the use of HTTPS always via Cloudflare. However, whenever I visit my site, it throws errors such as Mixed Content: The page at 'License Mania was loaded over HTTPS, but requested an insecure stylesheet 'http://licensemania.com/css.php?css=xenforo,form,public&style=1&dir=LTR&d=1480584990'. This request has been blocked; the content must be served over HTTPS. I'm not too sure if the self-sign SSL option is forcing it to use HTTPS or what but I disabled it completely from Cloudflare so it stops forcing it there via page rule. However, it's still being forced causing none of my content to properly load.

    Any ideas?

    Thanks!
     
  2. eva2000

    eva2000 Administrator Staff Member

    28,976
    6,578
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,764
    Local Time:
    1:04 AM
    Nginx 1.13.x
    MariaDB 5.5
    You have mixed content issue so need to adjust your web app and/or web site style itself see What Is Mixed Content? - KeyCDN Support

    It's related to your site theme/style that you need to fix nothing to do with server level i.e. if you theme has 3rd party url with non-https elements

    For xenforo means setting https url as default in admin.php throughout
     
    • Like Like x 1