Learn about Centmin Mod LEMP Stack today
Become a Member

Xenforo Seeking help with setting up xenforo

Discussion in 'Forum software usage' started by Artonn, Nov 20, 2023.

  1. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    I'm quite new and have much to learn, I'm setting op a droplet at digitalocean hoping to use cloudflare and aws SES for mail handling, but it is such a complex world to me.

    Currently I have nothing but a droplet with almalinux 9 setup, I have been recommeneded to use centminmod a couple of times now, but I finding it hard to figure out where to begin from.


    I am hoping there's some kind souls out there, that can guide med through it or give some kind of step guide to move my xenforo from shared hosting to a droplet successfully with working mails and connected to cloudflare and certbot for https?. Thank you!
     
  2. MaximilianKohler

    MaximilianKohler Member

    157
    3
    18
    Jun 23, 2023
    Ratings:
    +18
    Local Time:
    12:05 PM
  3. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
  4. MaximilianKohler

    MaximilianKohler Member

    157
    3
    18
    Jun 23, 2023
    Ratings:
    +18
    Local Time:
    12:05 PM
    I haven't upgraded from CentOS 7 yet, so some of it will be outdated for sure. I think most of it should apply or be easily modified though.
     
  5. eva2000

    eva2000 Administrator Staff Member

    52,220
    12,000
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,503
    Local Time:
    5:05 AM
    Nginx 1.25.x
    MariaDB 10.x
    From welcome email, these are older guides
    The latter one I believe is still applicable to Xenforo 2 now. The sticky threads in Forum software subforum also have info https://community.centminmod.com/forums/forum-software-usage.34/ like at https://community.centminmod.com/th...on-centmin-mod-123-09beta01-lemp-stack.16060/ along with guide mentioned above in this thread.
     
  6. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM

    I'm finally going through setting it up now. I'm getting all of these errors, I'm unsure of how to handle them.


    [20:02][root@danskeakvarier-almalinux-centminmod centminmod]# centmin
    /usr/local/src/centminmod /etc/centminmod
    ./centmin.sh: line 4: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or director y
    ./centmin.sh: line 4: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

    /usr/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /usr/bin/sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 788: jq: command not found
    inc/cpcheck.inc: line 789: jq: command not found
    /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /usr/local/src/centminmod/tools/email.sh: line 50: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF -8)
    /usr/local/src/centminmod/tools/email.sh: line 50: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF -8)

    --------------------------------------------------------------------
    Setup Server Administration Email
    Emails will be used for future notification alert features
    --------------------------------------------------------------------
    Hit Enter To Skip...
    Will be prompted everytime run centmin.sh if both emails not entered
    --------------------------------------------------------------------
    enter primary email:
    enter secondary email:
    --------------------------------------------------------------------
    primary email setup skipped...
    secondary email setup skipped...

    inc/cpcheck.inc: line 2339: jq: command not found
    inc/cpcheck.inc: line 2888: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2896: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2899: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2902: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2905: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2908: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2911: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2914: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2917: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 2920: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1601: pcre-config: command not found
    /root/tools/ex_stats_print.c: In function 'do_something':
    /root/tools/ex_stats_print.c:9:9: warning: ignoring return value of 'malloc' declared with attribute 'warn_unu sed_result' [-Wunused-result]
    9 | malloc(i * 100);
    | ^~~~~~~~~~~~~~~
    inc/cpcheck.inc: line 1351: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1361: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1371: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1340: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    Failed to set locale, defaulting to C.UTF-8
    Warning: failed loading '/etc/yum.repos.d/CentOS-Base.repo', skipping.
    Warning: failed loading '/etc/yum.repos.d/mariadb.repo', skipping.
    Command line error: one of the following arguments is required: --save --add-repo --dump --dump-variables --se t-enabled --enable --set-disabled --disable
    inc/cpcheck.inc: line 1024: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    Failed to set locale, defaulting to C.UTF-8
    Warning: failed loading '/etc/yum.repos.d/CentOS-Base.repo', skipping.
    Warning: failed loading '/etc/yum.repos.d/mariadb.repo', skipping.
    inc/cpcheck.inc: line 256: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    inc/cpcheck.inc: line 1: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    /bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    sed: can't read /etc/cron.d/sysstat: No such file or directory
    /usr/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
    Redirecting to /bin/systemctl restart sysstat.service
    ./centmin.sh: line 1481: chkconfig: command not found
     
  7. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    I actually think my issue is I'm running almalinux 9, it seems like only 8 is supported?
     
  8. duderuud

    duderuud Premium Member Premium Member

    207
    75
    28
    Dec 5, 2020
    The Netherlands
    Ratings:
    +158
    Local Time:
    9:05 PM
    1.25 x
    10.6
    That is correct. El9 still has some bugs
     
  9. eva2000

    eva2000 Administrator Staff Member

    52,220
    12,000
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,503
    Local Time:
    5:05 AM
    Nginx 1.25.x
    MariaDB 10.x
    Are you running as sudo or full root user?Try as full root user

    EL9 and EL8 should not show such errors. Also what SSH client you using? What local PC/Mac operating system is your SSH client on?

    Also if you are running sudo user, can you run this command first as sudo user and then as full root user and show the respective outputs
    Code (Text):
    locale -a
    

    For folks reading this message and yourself for posting code or output from commands to keep the formatting, you might want to use CODE tags for code How to use forum BBCODE code tags :)
     
    Last edited: Nov 27, 2023
  10. eva2000

    eva2000 Administrator Staff Member

    52,220
    12,000
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,503
    Local Time:
    5:05 AM
    Nginx 1.25.x
    MariaDB 10.x
    Looks like maybe Centmin Mod wasn't properly installed? How did you install Centmin Mod? Might need initial install log - How to troubleshoot Centmin Mod initial install issues
     
  11. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    I think i'm going to drop the droplet and try again on almelinux 8, i don't want to debug it if the version can be an issue.

    Nothing important on it, just testing this out.
     
  12. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
  13. duderuud

    duderuud Premium Member Premium Member

    207
    75
    28
    Dec 5, 2020
    The Netherlands
    Ratings:
    +158
    Local Time:
    9:05 PM
    1.25 x
    10.6
    Just run screen (or tmux) and run the cm installation in there.
     
  14. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    I'm a bit new to this, how do I run screen or tmux?
     
  15. duderuud

    duderuud Premium Member Premium Member

    207
    75
    28
    Dec 5, 2020
    The Netherlands
    Ratings:
    +158
    Local Time:
    9:05 PM
    1.25 x
    10.6
    Try tmux:

    yum install tmux
    tmux

    You can disconnect the session with "ctrl-b d" and reconnect with "tmux a"
     
  16. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    Responds like this, seems like my install has become murderous

    upload_2023-11-27_17-35-1.png
     
  17. brijendrasial

    brijendrasial Active Member

    201
    145
    43
    Mar 21, 2018
    Ratings:
    +227
    Local Time:
    12:35 AM
    1.13.9
    10.0.22-MariaDB
    on el8 version screen is provided with epel repository

    dnf install epel-release -y
    screen
     
  18. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
  19. duderuud

    duderuud Premium Member Premium Member

    207
    75
    28
    Dec 5, 2020
    The Netherlands
    Ratings:
    +158
    Local Time:
    9:05 PM
    1.25 x
    10.6
    That is really weird. AlmaLinux is supported and works great. I have multiple instances running without any issues.

    Seems to me it has to do with the VPS you are using.

    Code (Text):
    curl -4sL https://centminmod.com/installer-el8x-81.sh -o installer-el8x-81.sh; bash installer-el8x-81.sh
    

    Should work on a fresh install of Alma 8.x
     
    Last edited: Nov 28, 2023
  20. Artonn

    Artonn New Member

    21
    1
    3
    Nov 20, 2023
    Ratings:
    +1
    Local Time:
    9:05 PM
    Setting it up on centOS works great, so I guess I should just go with centOS 8?