Join the community today
Register Now

PHP-FPM Running PHP8.1.7 but found some issues with some XF add-ons. Any bad to downgrade to 8.0?

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by modder, Jun 28, 2022.

  1. modder

    modder Member

    94
    15
    8
    Dec 6, 2019
    Ratings:
    +23
    Local Time:
    1:15 AM
    Please fill in any relevant information that applies to you:
    • CentOS Version:CentOS 7 64bit
    • Centmin Mod Version Installed: newest beta
    • Nginx Version Installed: 1.21.6
    • PHP Version Installed: 8.1.7
    I know how to downgrade (option 5 in centmin) but would there be any problems for downgrading?

    Which 8.x (or even 7.x?) version is recommended?


    Thanks.
     
    Last edited: Jun 28, 2022
  2. Jon Snow

    Jon Snow Active Member

    662
    129
    43
    Jun 30, 2017
    Ratings:
    +190
    Local Time:
    2:15 PM
    Nginx 1.13.9
    MariaDB 10.1.31
    Should be fine to downgrade.
     
  3. eva2000

    eva2000 Administrator Staff Member

    49,037
    11,235
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,487
    Local Time:
    3:15 AM
    Nginx 1.21.x
    MariaDB 10.x
    Depends on the PHP app - in your case your addons would be the ones that determine the min PHP version you end up using. PHP 7.4.30 is probably the safetest bet for most XF addons. But some folks like @rdan and @deltahf have reported PHP 8.0 is fine.