Welcome to Centmin Mod Community
Become a Member

Run Option 15 missing or removed ??

Discussion in 'AlmaLinux 8 & Rocky Linux 8 Beta Testing' started by cloud9, Dec 20, 2022.

  1. cloud9

    cloud9 Premium Member Premium Member

    423
    117
    43
    Oct 6, 2015
    England
    Ratings:
    +216
    Local Time:
    5:41 AM
    1.25.3
    10.6.x
    This is on alma beta install

    Run CMupadte - all good

    Run Centmin - 24 exit

    Get a list of yum updates (attached)

    However it used to say run option 15 then yum update

    But no run option 15

    So run the yum update - nothing to update


    Run CMM again option 15 and all the updates go through

    So not sure if the run option 15 has been removed or a bug as sure it used to be there

    Screenshot 2022-12-19 at 17.41.04.png
     
  2. duderuud

    duderuud Premium Member Premium Member

    207
    75
    28
    Dec 5, 2020
    The Netherlands
    Ratings:
    +158
    Local Time:
    6:41 AM
    1.25 x
    10.6
    Noticed the same today.

    And yes, the notification to run option 15 is missing.
    When running it anyway ImageMagick will update and all is well again.
     
  3. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    2:41 PM
    Nginx 1.25.x
    MariaDB 10.x
    Looks like a bug in menu option 24 exit where yum update command listed is missing versionlock in disable plugin comma separated list like on yum list command. On mobile right now so will check it out later
     
  4. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    2:41 PM
    Nginx 1.25.x
    MariaDB 10.x
    The bug is just the message to run option 15 is missing it seems as that check was only for CentOS 7 and forgot to update to check for EL8 and EL9. As to yum update command that is correct not to update via yum update by leaving off disable plugin for versionlock as to prevent folks from independently updating ImageMagick and breaking PHP Imagick extension as when you update ImageMagick you need to recompile Imagick PHP extension - so left that to centmin.sh menu option 15 to do rather than allow users to do it just via normal yum update.

    So fix is just for missing EL8/EL9 check to prompt users to run centmin.sh menu option 15 when ImageMagick YUM package updates are available. Testing the fix now for eventual commit to 130.00beta01
     
  5. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    2:41 PM
    Nginx 1.25.x
    MariaDB 10.x