Learn about Centmin Mod LEMP Stack today
Become a Member

Beta Branch rollback memcache php 7 extension to 3.0.9 in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Mar 3, 2019.

  1. eva2000

    eva2000 Administrator Staff Member

    39,747
    8,767
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,488
    Local Time:
    6:52 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    remove memcache php 7 extension patch in 123.09beta01

    - memcache php extension version 3.0.9 and lower were incompatible with PHP 7.3 so required a patch which centmin.sh memcached/memcache extension auto applied the patch if php 7.3 was detected. But memcache php extension 4.0.1 was released websupport-sk/pecl-memcache which has native PHP 7.3 support so that break centminmod's memcache php extension routine as it still applied the patch when PHP 7.3 was detected.
    - However, even removing the patch still has memcache 4.0.1 extension failing to install on PHP 7.3 but rolling back to memcache 3.0.9 + patch for PHP 7.3 works so doing this temporarily for now PHP-FPM - PHP 7.3.0 - Extensions Issue

    Continue reading...

    123.09beta01 branch
     
..