Join the community today
Become a Member

PHP-FPM Restarting PHP-FPM gives a PHP warning

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by Jon Snow, Aug 11, 2017.

  1. Jon Snow

    Jon Snow Active Member

    156
    25
    28
    Jun 30, 2017
    Ratings:
    +30
    Local Time:
    6:35 AM
    Nginx 1.13.4
    MariaDB 10.1.26
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: i.e. 1.13.4 (latest)
    • PHP Version Installed: i.e. 5.6.31 (latest in 5.6)
    • MariaDB MySQL Version Installed: Latest (just did the security update from the alert)
    • When was last time updated Centmin Mod code base ? : Today
    Restarting PHP-FPM gives me the following error :
    Code (Text):
    # nprestart
    Restarting nginx (via systemctl):                          [  OK  ]
    Gracefully shutting down php-fpm . done
    Starting php-fpm [11-Aug-2017 02:44:39] NOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/imagick.so' - libMagickWand-6.Q16.so.4: cannot open shared object file: No such file or directory in Unknown on line 0
     done

    I had a problem with ImageMagick on PHP 7.1 and updating PHP to the latest version worked. I'm on the latest PHP version of 5.6 so that's out of the question for this one.

    Anyone else getting this error and know how to fix it?

    On xenForo I notice that the avatar gets updated but the old one stays on some parts of the forum. Uploading the new avatar again resolves the issue though (so you have to upload twice).
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    7:35 PM
    Nginx 1.13.x
    MariaDB 5.5
    every time you update imagemagick yum package, you need to re-run centmin.sh menu option 15 in 123.09beta01 to recompile imagick php extension - normally menu option 15 also does a yum update for imagemagick too

    it's something specific to imagick php extensions requirements IIRC. I should look into this :)
     
    • Informative Informative x 2
  3. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    7:35 PM
    Nginx 1.13.x
    MariaDB 5.5
    Updated Centmin Mod 123.09beta01 to do away with future imagick PHP complaints/errors when ImageMagick6 system packages are updated Beta Branch - update inc/imagick_install.inc - versionlock ImageMagick6. For existing 123.09beta01 users, just update via centmin.sh menu option 23 submenu option 2, exit centmin.sh, re-run centmin.sh with menu option 15 to lock in your ImageMagick6 versions.
     
    • Like Like x 1