Discover Centmin Mod today
Register Now

Sysadmin Removing Python 2.7?

Discussion in 'System Administration' started by Andy, Jan 30, 2020.

  1. Andy

    Andy Active Member

    460
    73
    28
    Aug 6, 2014
    Ratings:
    +102
    Local Time:
    2:47 AM
    Seems like 7.7 is deprecated. I got this error. Should I remove it?
    Code:
    pip install --upgrade pip
    DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
    Requirement already up-to-date: pip in /usr/lib/python2.7/site-packages (20.0.2)

     
  2. brijendrasial

    brijendrasial Active Member

    121
    94
    28
    Mar 21, 2018
    Ratings:
    +147
    Local Time:
    12:17 PM
    1.13.9
    10.0.22-MariaDB
    wondering how will yum works then :yuck:
     
  3. eva2000

    eva2000 Administrator Staff Member

    44,426
    10,144
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,696
    Local Time:
    4:47 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    see my reply at https://community.centminmod.com/th...st-2020-running-out-of-time.18806/#post-79973

    you do not want to remove python 2.7 or YUM will break !
     
  4. eva2000

    eva2000 Administrator Staff Member

    44,426
    10,144
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,696
    Local Time:
    4:47 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Last edited: Jan 30, 2020
  5. Andy

    Andy Active Member

    460
    73
    28
    Aug 6, 2014
    Ratings:
    +102
    Local Time:
    2:47 AM
    Thanks @eva2000
    I will leave them as is.